/[packages]/updates/infra_2/perl-RPM4/current/SPECS/perl-RPM4.spec
ViewVC logotype

Annotation of /updates/infra_2/perl-RPM4/current/SPECS/perl-RPM4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 431942 - (hide annotations) (download)
Wed May 29 09:41:22 2013 UTC (10 years, 10 months ago) by tv
Original Path: cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec
File size: 1516 byte(s)
patch 0: fix build
1 jquelin 14433 # This spec is in the SVN
2     # $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $
3    
4     %define module RPM4
5     %define name perl-%{module}
6 tv 332336 %define version 0.32
7 jquelin 431736 %define release %mkrel 8
8 jquelin 14433
9     %define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm)
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}
14     Summary: Perl bindings to use rpmlib and manage hdlist files
15     License: GPL
16     Group: Development/Perl
17 tv 185256 Source: %{module}-%{version}.tar.xz
18 tv 431942 Patch0: build-fix.diff
19 jquelin 14433 Url: http://search.cpan.org/dist/RPM4/
20 sander85 104940
21     BuildRequires: perl-devel >= 5.8.0
22     BuildRequires: rpm-devel
23     BuildRequires: perl-Digest-SHA1
24     BuildRequires: librpmconstant-devel
25     BuildRequires: packdrake
26     BuildRequires: perl-MDV-Packdrakeng
27     BuildRequires: gnupg
28    
29 jquelin 14433 # we can now expect librpm API to be at least backward compatible
30     Requires: rpm >= %{rpm_version}
31    
32     %description
33     This module provides a perl interface to the rpmlib.
34    
35     It allows to write scripts to:
36     - query rpm headers,
37     - query rpm database,
38     - build rpm specs,
39     - install/uninstall specfiles,
40     - check dependencies.
41    
42 tv 183471 It includes:
43 jquelin 14433 - rpm_produced, give what rpm will be produced by a src.rpm or a specfile.
44    
45     %prep
46     %setup -q -n %{module}-%{version}
47 tv 431942 %apply_patches
48 jquelin 14433
49     %build
50     %{__perl} Makefile.PL INSTALLDIRS=vendor
51     %make
52    
53     %check
54 tv 260896 #PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test
55 jquelin 14433
56     %clean
57     rm -rf $RPM_BUILD_ROOT
58    
59     %install
60     rm -rf $RPM_BUILD_ROOT
61     %makeinstall_std
62    
63     %files
64     %defattr(-,root,root)
65 tv 165905 %doc README
66 jquelin 14433 %doc examples
67     %_bindir/*
68     %{perl_vendorarch}/*
69     %{_mandir}/*/*
70    
71    

  ViewVC Help
Powered by ViewVC 1.1.30