/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 256683 - (hide annotations) (download)
Wed Jun 6 23:54:05 2012 UTC (11 years, 10 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20366 byte(s)
BR lua5.1-devel instead of lua-devel
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52     %define libver 4.9
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55     %define release %mkrel %{?snapver:0.%{snapver}.}0.2
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
95 tmb 343
96     # (fredl) add loging facilities through syslog
97 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
98 tmb 343
99 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
100     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
101 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
102     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
103 blino 25212
104 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
105     # From popular request, we allow to do this
106 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
107     Patch70: rpm-4.9.1-bb-shortcircuit.patch
108 tmb 343
109     # don't conflict for doc files
110     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
111 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
112 tmb 343
113     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
114     # (is this working??)
115     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
116    
117     # Fix diff issue when buildroot contains some "//"
118 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
119 tmb 343
120     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
121 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
122 tmb 343
123     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
124     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
125     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
126     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
127     # but this is bad design anyway
128 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
129 tmb 343
130     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
131 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
132 tv 215854 Patch134: extcond.diff
133 tmb 343
134 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
135 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
136     # implementation: as long as debugedit can just overwrite data in the elf
137     # sections things keep relatively easy, but if dest_dir is longer than the
138     # original directory, debugedit would have to expand the whole elf file. Which
139     # might be technically possible but debugedit currently does not even try to."
140 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
141 dmorgan 49378
142 tmb 343 # convert data in the header to a specific encoding which used in the selected locale.
143 tv 256612 # Not that usefull, everything should be UTF-8
144 dmorgan 185007 Patch137: rpm-4.9.1.1-headerIconv.patch
145 tmb 343
146     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
147     # with this patch, "#%define foo bar" is a fatal error
148 dmorgan 185007 # Bug still valid => Send upstream for review.
149 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
150 tmb 343
151     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
152 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
153     Patch146: rpm-4.9.1.1-filetriggers.patch
154 tmb 343
155     # add two fatal errors (during package build)
156 dmorgan 185007 # Useful ? to drop ?
157     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
158 tmb 343
159     # (nb: see the patch for more info about this issue)
160 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
161 tmb 343
162     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
163    
164 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
165     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
166 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
167 tmb 343
168     Patch1007: rpm-4.6.0-rc3-xz-support.patch
169    
170     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
171     # as this breaks stuff that installs files to $DOCDIR during %%install
172 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
173 tmb 343
174     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
175     # break when these unknown tags might be found in the rpmdb. Notice that this
176     # will only make rpm recognize these, not implement actual support for them..
177 tv 256243 Patch1009: rpm-4.10.0-rpm5-tags.patch
178 tmb 343
179     # Turbolinux patches
180     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
181     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
182    
183     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
184     #
185     # This patch fixes the problem when the post-scripts launched by rpm-build.
186     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
187     # other locale except C, then some commands launched by post-scripts will not
188     # display characters which you expected.
189 dmorgan 185007 Patch2005: rpm-4.9.0-buildlang.patch
190 tmb 343
191 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
192 dmorgan 49378
193 tv 255921 # (tv) fix tests on non selinux systems:
194     #BETA Patch2100: rpm-4.9.90-fix-test.diff
195    
196 tmb 343 Patch3000: mips_macros.patch
197     Patch3001: fix_stack_protector_check.patch
198 tv 256616 Patch3002: mips_define_isa_macros.patch
199     Patch3003: rpm_arm_mips_isa_macros.patch
200     Patch3004: rpm_add_armv5tl.patch
201 tmb 343
202 tv 223198 #
203 dmorgan 185007 # Fedora patches
204 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
205     #
206 dmorgan 185007
207     License: GPLv2+
208     BuildRequires: autoconf
209 tmb 343 BuildRequires: zlib-devel
210     BuildRequires: bzip2-devel
211     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
212 dmorgan 185007 BuildRequires: automake
213 tmb 343 BuildRequires: elfutils-devel
214     BuildRequires: libbeecrypt-devel
215 dmorgan 185007 BuildRequires: ed
216     BuildRequires: gettext-devel
217 tmb 343 BuildRequires: libsqlite3-devel
218     BuildRequires: db4.8-devel
219     BuildRequires: neon-devel
220     BuildRequires: popt-devel
221     BuildRequires: nss-devel
222     BuildRequires: magic-devel
223 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
224 tmb 343 BuildRequires: readline-devel
225     BuildRequires: ncurses-devel
226 dmorgan 185007 BuildRequires: openssl-devel
227 tv 256683 BuildRequires: lua5.1-devel
228 dmorgan 185007 BuildRequires: libcap-devel
229     # Needed for doc
230 tmb 343 #BuildRequires: graphviz
231 dmorgan 185007 BuildRequires: tetex
232 tmb 343 %if %buildpython
233     BuildRequires: python-devel
234     %endif
235 tv 223263 # for testsuite:
236     BuildRequires: fakechroot
237 tmb 343
238     Requires: bzip2 >= 0.9.0c-2
239     Requires: lzma
240     Requires: cpio
241     Requires: gawk
242     Requires: glibc >= 2.1.92
243     Requires: mktemp
244 tmb 345 Requires: setup >= 2.2.0-8
245 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
246 tmb 343 Requires: update-alternatives
247     Requires: %librpmname = %epoch:%version-%release
248     URL: http://rpm.org/
249     %define git_url http://rpm.org/git/rpm.git
250 dmorgan 185007 Requires(pre): rpm-helper
251 tmb 343 Requires(pre): coreutils
252 dmorgan 185007 Requires(postun): rpm-helper
253 tmb 343
254 tv 255921 Conflicts: perl-URPM < 3.41-1.mga3
255 dmorgan 185007
256 tmb 343 %description
257     RPM is a powerful command line driven package management system capable of
258     installing, uninstalling, verifying, querying, and updating software packages.
259     Each software package consists of an archive of files along with information
260     about the package like its version, a description, etc.
261    
262 dmorgan 185191 %package -n %librpmbuild
263     Summary: Libraries for building and signing RPM packages
264     Group: System/Libraries
265     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
266     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
267    
268     %description -n %librpmbuild
269     This package contains the RPM shared libraries for building and signing
270     packages.
271    
272     %package -n %librpmsign
273     Summary: Libraries for building and signing RPM packages
274     Group: System/Libraries
275    
276     %description -n %librpmsign
277     This package contains the RPM shared libraries for building and signing
278     packages.
279    
280 tmb 343 %package -n %librpmname
281 tmb 345 Summary: Library used by rpm
282     Group: System/Libraries
283     Provides: librpm = %version-%release
284 tmb 343
285     %description -n %librpmname
286     RPM is a powerful command line driven package management system capable of
287     installing, uninstalling, verifying, querying, and updating software packages.
288     This package contains common files to all applications based on rpm.
289    
290     %package -n %librpmnamedevel
291     Summary: Development files for applications which will manipulate RPM packages
292     Group: Development/C
293     Requires: rpm = %epoch:%{version}-%{release}
294     Provides: librpm-devel = %version-%release
295     Provides: rpm-devel = %version-%release
296 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
297     Requires: %librpmbuild = %epoch:%version-%release
298     Requires: %librpmsign = %epoch:%version-%release
299 tmb 343
300     %description -n %librpmnamedevel
301     This package contains the RPM C library and header files. These
302     development files will simplify the process of writing programs
303     which manipulate RPM packages and databases and are intended to make
304     it easier to create graphical package managers or any other tools
305     that need an intimate knowledge of RPM packages in order to function.
306    
307     This package should be installed if you want to develop programs that
308     will manipulate RPM packages and databases.
309    
310     %package build
311     Summary: Scripts and executable programs used to build packages
312     Group: System/Configuration/Packaging
313     Requires: autoconf
314     Requires: automake
315     Requires: file
316     Requires: gcc-c++
317     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
318 dmorgan 185007 Requires: libtool-base
319     Requires: patch
320 tmb 343 Requires: make
321     Requires: tar
322     Requires: unzip
323     Requires: elfutils
324 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
325 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
326 dmorgan 185007 Requires: perl(YAML::Tiny)
327 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
328 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
329 tmb 343
330     %description build
331     This package contains scripts and executable programs that are used to
332     build packages using RPM.
333    
334 dmorgan 185007 %package sign
335     Summary: Package signing support
336     Group: System/Base
337    
338     %description sign
339     This package contains support for digitally signing RPM packages.
340    
341 tmb 343 %if %buildpython
342     %package -n python-rpm
343     Summary: Python bindings for apps which will manipulate RPM packages
344     Group: Development/Python
345     Requires: rpm = %epoch:%{version}-%{release}
346    
347     %description -n python-rpm
348     The rpm-python package contains a module which permits applications
349     written in the Python programming language to use the interface
350     supplied by RPM (RPM Package Manager) libraries.
351    
352     This package should be installed if you want to develop Python
353     programs that will manipulate RPM packages and databases.
354     %endif
355    
356     %prep
357     %setup -q -n %name-%srcver
358 dmorgan 186388 %apply_patches
359 tmb 343
360     %build
361     autoreconf
362    
363     %if %builddebug
364     RPM_OPT_FLAGS=-g
365     %endif
366     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
367 fwang 215771 %configure2_5x \
368 tmb 343 --enable-nls \
369     --enable-python \
370     --enable-sqlite3 \
371     --without-javaglue \
372     %if %builddebug
373     --enable-debug \
374     %endif
375 dmorgan 185007 --with-external-db \
376 tmb 343 %if %buildpython
377     --with-python=%{pyver} \
378     %else
379     --without-python \
380     %endif
381 dmorgan 185007 %if ! %buildplugins
382     --disable-plugins \
383     %endif
384 tmb 343 --with-glob \
385     --without-selinux \
386 dmorgan 185007 --without-apidocs \
387     --with-cap
388 tmb 343
389     %make
390    
391     %install
392 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
393 tmb 343
394     make DESTDIR=%buildroot install
395    
396 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
397    
398 tmb 343 #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
399    
400     # Save list of packages through cron
401     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
402     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
403    
404     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
405     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
406    
407     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
408     for dbi in \
409     Basenames Conflictname Dirnames Group Installtid Name Providename \
410     Provideversion Removetid Requirename Requireversion Triggername \
411 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
412     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
413 tmb 343 do
414     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
415     done
416    
417     test -d doc-copy || mkdir doc-copy
418     rm -rf doc-copy/*
419     ln -f doc/manual/* doc-copy/
420     rm -f doc-copy/Makefile*
421    
422     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
423    
424     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
425     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
426     # Put your own system macros here
427     # usually contains
428    
429     # Set this one according your locales
430     # %%_install_langs
431    
432     EOF
433    
434     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
435    
436 tv 206214 %check
437     make check
438    
439 tmb 343 %pre
440     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
441    
442     rm -rf /usr/lib/rpm/*-mandrake-*
443 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
444 tmb 343
445 tmb 345
446 tmb 343 %post
447     # nuke __db.00? when updating to this rpm
448     rm -f /var/lib/rpm/__db.00?
449    
450 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
451 tmb 343 /bin/rpm --initdb
452     fi
453    
454     %postun
455     /usr/share/rpm-helper/del-user rpm $1 rpm
456    
457     %define rpmattr %attr(0755, rpm, rpm)
458    
459     %files -f %{name}.lang
460     %defattr(-,root,root)
461     %doc GROUPS CHANGES doc/manual/[a-z]*
462     %attr(0755,rpm,rpm) /bin/rpm
463     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
464     %attr(0755, rpm, rpm) %{_bindir}/gendiff
465     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
466 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
467 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
468     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
469     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
470     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
471    
472     %dir %{_localstatedir}/spool/repackage
473     %dir %{rpmdir}
474     %dir /etc/rpm
475     %config(noreplace) /etc/rpm/macros
476     %dir /etc/rpm/macros.d
477     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
478     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
479     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
480     %attr(0644, rpm, rpm) %{rpmdir}/macros
481     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
482     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
483     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
484     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
485 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
486     %attr(0755, rpm, rpm) %{rpmdir}/script.req
487 tv 256610 %exclude %{rpmdir}/tcl.req
488 tmb 343
489     %rpmattr %{rpmdir}/rpm2cpio.sh
490     %rpmattr %{rpmdir}/tgpg
491    
492 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
493     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
494    
495 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
496     %ifarch %{ix86} x86_64
497     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
498     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
499     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
500     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
501     %endif
502     %ifarch x86_64
503     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
504     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
505     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
506     %endif
507     %ifarch %arm
508 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
509 tv 256613 %else
510     %exclude %{rpmdir}/platform/arm*/macros
511 tmb 343 %endif
512     %ifarch %mips
513     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
514     %endif
515     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
516 tv 256613 # new in 4.10.0:
517     %exclude %{rpmdir}/platform/alpha*-linux/macros
518     %exclude %{rpmdir}/platform/sparc*-linux/macros
519     %exclude %{rpmdir}/platform/ia64*-linux/macros
520     %exclude %{rpmdir}/platform/ppc*-linux/macros
521     %exclude %{rpmdir}/platform/s390*-linux/macros
522     %exclude %{rpmdir}/platform/sh*-linux/macros
523 tmb 343
524 tv 256613
525    
526 tmb 343 %{_mandir}/man[18]/*.[18]*
527     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
528     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
529     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
530     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
531     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
532     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
533    
534     %config(noreplace,missingok) /etc/cron.daily/rpm
535     %config(noreplace,missingok) /etc/logrotate.d/rpm
536    
537     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
538    
539     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
540    
541     %rpmdbattr /var/lib/rpm/Basenames
542     %rpmdbattr /var/lib/rpm/Conflictname
543     %rpmdbattr /var/lib/rpm/__db.0*
544     %rpmdbattr /var/lib/rpm/Dirnames
545     %rpmdbattr /var/lib/rpm/Group
546     %rpmdbattr /var/lib/rpm/Installtid
547     %rpmdbattr /var/lib/rpm/Name
548 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
549 tmb 343 %rpmdbattr /var/lib/rpm/Packages
550     %rpmdbattr /var/lib/rpm/Providename
551     %rpmdbattr /var/lib/rpm/Provideversion
552     %rpmdbattr /var/lib/rpm/Removetid
553     %rpmdbattr /var/lib/rpm/Requirename
554     %rpmdbattr /var/lib/rpm/Requireversion
555 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
556     %rpmdbattr /var/lib/rpm/Sigmd5
557 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
558    
559     %files build
560     %defattr(-,root,root)
561     %doc CHANGES
562     %doc doc-copy/*
563     %rpmattr %{_bindir}/rpmbuild
564 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
565 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
566     %rpmattr %{_prefix}/lib/rpm/check-files
567     %rpmattr %{_prefix}/lib/rpm/debugedit
568 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
569 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
570     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
571     %rpmattr %{_prefix}/lib/rpm/find-provides
572     %rpmattr %{_prefix}/lib/rpm/find-requires
573 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
574 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
575     %rpmattr %{_prefix}/lib/rpm/perl.prov
576     %rpmattr %{_prefix}/lib/rpm/perl.req
577    
578     %rpmattr %{_prefix}/lib/rpm/check-buildroot
579     %rpmattr %{_prefix}/lib/rpm/check-prereqs
580     %rpmattr %{_prefix}/lib/rpm/check-rpaths
581     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
582 tv 255921 #rpmattr %{_prefix}/lib/rpm/javadeps
583 tmb 343 %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
584     %rpmattr %{_prefix}/lib/rpm/macros.perl
585     %rpmattr %{_prefix}/lib/rpm/macros.php
586     %rpmattr %{_prefix}/lib/rpm/macros.python
587     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
588     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
589 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
590     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
591 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
592     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
593 dmorgan 185007 #%rpmattr %{_prefix}/lib/rpm/rpmdiff
594 tmb 343
595     %rpmattr %{_prefix}/lib/rpm/rpmdeps
596     #%rpmattr %{_prefix}/lib/rpm/trpm
597 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
598 tmb 343
599 tv 255921
600 tmb 343 %{_mandir}/man8/rpmbuild.8*
601     %{_mandir}/man8/rpmdeps.8*
602    
603     %if %buildpython
604     %files -n python-rpm
605     %defattr(-,root,root)
606     %{_libdir}/python*/site-packages/rpm
607     %endif
608    
609     %files -n %librpmname
610     %defattr(-,root,root)
611 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
612     %{_libdir}/librpmio.so.%{libmajor}*
613 dmorgan 185007 %if %{with plugins}
614     %{_libdir}/rpm-plugins
615     %endif
616    
617     %files -n %librpmbuild
618 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
619 tmb 343
620 dmorgan 185007 %files -n %librpmsign
621     %{_libdir}/librpmsign.so.%{libmajorsign}*
622    
623     %files sign
624     %defattr(-,root,root)
625     %{_bindir}/rpmsign
626     %{_mandir}/man8/rpmsign.8*
627    
628 tmb 343 %files -n %librpmnamedevel
629     %defattr(-,root,root)
630     %{_includedir}/rpm
631     %{_libdir}/librpm.so
632     %{_libdir}/librpmio.so
633     %{_libdir}/librpmbuild.so
634 dmorgan 185007 %{_libdir}/librpmsign.so
635 tmb 343 %{_libdir}/pkgconfig/rpm.pc
636 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30