/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 260027 - (hide annotations) (download)
Tue Jun 12 12:18:43 2012 UTC (11 years, 10 months ago) by fwang
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20576 byte(s)
add conflicts on jpackage to ease upgarde
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52     %define libver 4.9
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 fwang 260027 %define release %mkrel %{?snapver:0.%{snapver}.}0.3
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
95 tmb 343
96     # (fredl) add loging facilities through syslog
97 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
98 tmb 343
99 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
100     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
101 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
102     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
103 blino 25212
104 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
105     # From popular request, we allow to do this
106 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
107     Patch70: rpm-4.9.1-bb-shortcircuit.patch
108 tmb 343
109     # don't conflict for doc files
110     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
111 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
112 tmb 343
113     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
114     # (is this working??)
115     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
116    
117     # Fix diff issue when buildroot contains some "//"
118 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
119 tmb 343
120     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
121 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
122 tmb 343
123     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
124     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
125     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
126     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
127     # but this is bad design anyway
128 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
129 tmb 343
130     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
131 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
132 tv 215854 Patch134: extcond.diff
133 tmb 343
134 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
135 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
136     # implementation: as long as debugedit can just overwrite data in the elf
137     # sections things keep relatively easy, but if dest_dir is longer than the
138     # original directory, debugedit would have to expand the whole elf file. Which
139     # might be technically possible but debugedit currently does not even try to."
140 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
141 dmorgan 49378
142 tmb 343 # convert data in the header to a specific encoding which used in the selected locale.
143 tv 256612 # Not that usefull, everything should be UTF-8
144 dmorgan 185007 Patch137: rpm-4.9.1.1-headerIconv.patch
145 tmb 343
146     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
147     # with this patch, "#%define foo bar" is a fatal error
148 dmorgan 185007 # Bug still valid => Send upstream for review.
149 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
150 tmb 343
151     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
152 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
153     Patch146: rpm-4.9.1.1-filetriggers.patch
154 tmb 343
155     # add two fatal errors (during package build)
156 dmorgan 185007 # Useful ? to drop ?
157     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
158 tmb 343
159     # (nb: see the patch for more info about this issue)
160 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
161 tmb 343
162     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
163    
164 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
165     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
166 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
167 tmb 343
168     Patch1007: rpm-4.6.0-rc3-xz-support.patch
169    
170     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
171     # as this breaks stuff that installs files to $DOCDIR during %%install
172 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
173 tmb 343
174     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
175     # break when these unknown tags might be found in the rpmdb. Notice that this
176     # will only make rpm recognize these, not implement actual support for them..
177 tv 256243 Patch1009: rpm-4.10.0-rpm5-tags.patch
178 tmb 343
179     # Turbolinux patches
180     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
181     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
182    
183     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
184     #
185     # This patch fixes the problem when the post-scripts launched by rpm-build.
186     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
187     # other locale except C, then some commands launched by post-scripts will not
188     # display characters which you expected.
189 dmorgan 185007 Patch2005: rpm-4.9.0-buildlang.patch
190 tmb 343
191 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
192 dmorgan 49378
193 tv 255921 # (tv) fix tests on non selinux systems:
194     #BETA Patch2100: rpm-4.9.90-fix-test.diff
195    
196 tmb 343 Patch3000: mips_macros.patch
197     Patch3001: fix_stack_protector_check.patch
198 tv 256616 Patch3002: mips_define_isa_macros.patch
199     Patch3003: rpm_arm_mips_isa_macros.patch
200     Patch3004: rpm_add_armv5tl.patch
201 tmb 343
202 tv 223198 #
203 dmorgan 185007 # Fedora patches
204 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
205     #
206 dmorgan 185007
207     License: GPLv2+
208     BuildRequires: autoconf
209 tmb 343 BuildRequires: zlib-devel
210     BuildRequires: bzip2-devel
211     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
212 dmorgan 185007 BuildRequires: automake
213 tmb 343 BuildRequires: elfutils-devel
214     BuildRequires: libbeecrypt-devel
215 dmorgan 185007 BuildRequires: ed
216     BuildRequires: gettext-devel
217 tmb 343 BuildRequires: libsqlite3-devel
218 tv 257954 BuildRequires: db5.2-devel
219 tmb 343 BuildRequires: neon-devel
220     BuildRequires: popt-devel
221     BuildRequires: nss-devel
222     BuildRequires: magic-devel
223 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
224 tmb 343 BuildRequires: readline-devel
225     BuildRequires: ncurses-devel
226 dmorgan 185007 BuildRequires: openssl-devel
227 tv 256683 BuildRequires: lua5.1-devel
228 dmorgan 185007 BuildRequires: libcap-devel
229     # Needed for doc
230 tmb 343 #BuildRequires: graphviz
231 dmorgan 185007 BuildRequires: tetex
232 tmb 343 %if %buildpython
233     BuildRequires: python-devel
234     %endif
235 tv 223263 # for testsuite:
236     BuildRequires: fakechroot
237 tmb 343
238     Requires: bzip2 >= 0.9.0c-2
239     Requires: lzma
240     Requires: cpio
241     Requires: gawk
242     Requires: glibc >= 2.1.92
243     Requires: mktemp
244 tmb 345 Requires: setup >= 2.2.0-8
245 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
246 tmb 343 Requires: update-alternatives
247     Requires: %librpmname = %epoch:%version-%release
248     URL: http://rpm.org/
249     %define git_url http://rpm.org/git/rpm.git
250 dmorgan 185007 Requires(pre): rpm-helper
251 tmb 343 Requires(pre): coreutils
252 dmorgan 185007 Requires(postun): rpm-helper
253 tmb 343
254 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
255 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
256 dmorgan 185007
257 tmb 343 %description
258     RPM is a powerful command line driven package management system capable of
259     installing, uninstalling, verifying, querying, and updating software packages.
260     Each software package consists of an archive of files along with information
261     about the package like its version, a description, etc.
262    
263 dmorgan 185191 %package -n %librpmbuild
264     Summary: Libraries for building and signing RPM packages
265     Group: System/Libraries
266     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
267     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
268    
269     %description -n %librpmbuild
270     This package contains the RPM shared libraries for building and signing
271     packages.
272    
273     %package -n %librpmsign
274     Summary: Libraries for building and signing RPM packages
275     Group: System/Libraries
276    
277     %description -n %librpmsign
278     This package contains the RPM shared libraries for building and signing
279     packages.
280    
281 tmb 343 %package -n %librpmname
282 tmb 345 Summary: Library used by rpm
283     Group: System/Libraries
284     Provides: librpm = %version-%release
285 tmb 343
286     %description -n %librpmname
287     RPM is a powerful command line driven package management system capable of
288     installing, uninstalling, verifying, querying, and updating software packages.
289     This package contains common files to all applications based on rpm.
290    
291     %package -n %librpmnamedevel
292     Summary: Development files for applications which will manipulate RPM packages
293     Group: Development/C
294     Requires: rpm = %epoch:%{version}-%{release}
295     Provides: librpm-devel = %version-%release
296     Provides: rpm-devel = %version-%release
297 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
298     Requires: %librpmbuild = %epoch:%version-%release
299     Requires: %librpmsign = %epoch:%version-%release
300 tmb 343
301     %description -n %librpmnamedevel
302     This package contains the RPM C library and header files. These
303     development files will simplify the process of writing programs
304     which manipulate RPM packages and databases and are intended to make
305     it easier to create graphical package managers or any other tools
306     that need an intimate knowledge of RPM packages in order to function.
307    
308     This package should be installed if you want to develop programs that
309     will manipulate RPM packages and databases.
310    
311     %package build
312     Summary: Scripts and executable programs used to build packages
313     Group: System/Configuration/Packaging
314     Requires: autoconf
315     Requires: automake
316     Requires: file
317     Requires: gcc-c++
318     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
319 dmorgan 185007 Requires: libtool-base
320     Requires: patch
321 tmb 343 Requires: make
322     Requires: tar
323     Requires: unzip
324     Requires: elfutils
325 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
326 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
327 dmorgan 185007 Requires: perl(YAML::Tiny)
328 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
329 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
330 tmb 343
331     %description build
332     This package contains scripts and executable programs that are used to
333     build packages using RPM.
334    
335 dmorgan 185007 %package sign
336     Summary: Package signing support
337     Group: System/Base
338    
339     %description sign
340     This package contains support for digitally signing RPM packages.
341    
342 tmb 343 %if %buildpython
343     %package -n python-rpm
344     Summary: Python bindings for apps which will manipulate RPM packages
345     Group: Development/Python
346     Requires: rpm = %epoch:%{version}-%{release}
347    
348     %description -n python-rpm
349     The rpm-python package contains a module which permits applications
350     written in the Python programming language to use the interface
351     supplied by RPM (RPM Package Manager) libraries.
352    
353     This package should be installed if you want to develop Python
354     programs that will manipulate RPM packages and databases.
355     %endif
356    
357     %prep
358     %setup -q -n %name-%srcver
359 dmorgan 186388 %apply_patches
360 tmb 343
361     %build
362     autoreconf
363    
364     %if %builddebug
365     RPM_OPT_FLAGS=-g
366     %endif
367     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
368 fwang 215771 %configure2_5x \
369 tmb 343 --enable-nls \
370     --enable-python \
371     --enable-sqlite3 \
372     --without-javaglue \
373     %if %builddebug
374     --enable-debug \
375     %endif
376 dmorgan 185007 --with-external-db \
377 tmb 343 %if %buildpython
378     --with-python=%{pyver} \
379     %else
380     --without-python \
381     %endif
382 dmorgan 185007 %if ! %buildplugins
383     --disable-plugins \
384     %endif
385 tmb 343 --with-glob \
386     --without-selinux \
387 dmorgan 185007 --without-apidocs \
388     --with-cap
389 tmb 343
390     %make
391    
392     %install
393 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
394 tmb 343
395     make DESTDIR=%buildroot install
396    
397 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
398    
399 tmb 343 #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
400    
401     # Save list of packages through cron
402     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
403     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
404    
405     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
406     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
407    
408     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
409     for dbi in \
410     Basenames Conflictname Dirnames Group Installtid Name Providename \
411     Provideversion Removetid Requirename Requireversion Triggername \
412 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
413     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
414 tmb 343 do
415     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
416     done
417    
418     test -d doc-copy || mkdir doc-copy
419     rm -rf doc-copy/*
420     ln -f doc/manual/* doc-copy/
421     rm -f doc-copy/Makefile*
422    
423     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
424    
425     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
426     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
427     # Put your own system macros here
428     # usually contains
429    
430     # Set this one according your locales
431     # %%_install_langs
432    
433     EOF
434    
435     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
436    
437 tv 206214 %check
438 tv 257956 exit 0
439 tv 206214 make check
440    
441 tmb 343 %pre
442     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
443    
444     rm -rf /usr/lib/rpm/*-mandrake-*
445 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
446 tmb 343
447 tmb 345
448 tmb 343 %post
449     # nuke __db.00? when updating to this rpm
450     rm -f /var/lib/rpm/__db.00?
451    
452 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
453 tmb 343 /bin/rpm --initdb
454     fi
455    
456     %postun
457     /usr/share/rpm-helper/del-user rpm $1 rpm
458    
459     %define rpmattr %attr(0755, rpm, rpm)
460    
461     %files -f %{name}.lang
462     %defattr(-,root,root)
463     %doc GROUPS CHANGES doc/manual/[a-z]*
464     %attr(0755,rpm,rpm) /bin/rpm
465     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
466     %attr(0755, rpm, rpm) %{_bindir}/gendiff
467     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
468 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
469 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
470     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
471     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
472     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
473    
474     %dir %{_localstatedir}/spool/repackage
475     %dir %{rpmdir}
476     %dir /etc/rpm
477     %config(noreplace) /etc/rpm/macros
478     %dir /etc/rpm/macros.d
479     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
480     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
481     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
482     %attr(0644, rpm, rpm) %{rpmdir}/macros
483     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
484     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
485     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
486     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
487 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
488     %attr(0755, rpm, rpm) %{rpmdir}/script.req
489 tv 256610 %exclude %{rpmdir}/tcl.req
490 tmb 343
491     %rpmattr %{rpmdir}/rpm2cpio.sh
492     %rpmattr %{rpmdir}/tgpg
493    
494 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
495     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
496    
497 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
498     %ifarch %{ix86} x86_64
499     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
500     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
501     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
503     %endif
504 tv 257999 %ifarch %{ix86}
505 tv 257998 %exclude %{rpmdir}/platform/amd64-linux/macros
506     %exclude %{rpmdir}/platform/ia32e-linux/macros
507     %exclude %{rpmdir}/platform/x86_64-linux/macros
508     %endif
509 tmb 343 %ifarch x86_64
510     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
511     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
513     %endif
514     %ifarch %arm
515 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
516 tv 256613 %else
517     %exclude %{rpmdir}/platform/arm*/macros
518 tmb 343 %endif
519     %ifarch %mips
520     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
521     %endif
522     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
523 tv 256613 # new in 4.10.0:
524     %exclude %{rpmdir}/platform/alpha*-linux/macros
525     %exclude %{rpmdir}/platform/sparc*-linux/macros
526     %exclude %{rpmdir}/platform/ia64*-linux/macros
527     %exclude %{rpmdir}/platform/ppc*-linux/macros
528     %exclude %{rpmdir}/platform/s390*-linux/macros
529     %exclude %{rpmdir}/platform/sh*-linux/macros
530 tmb 343
531 tv 256613
532    
533 tmb 343 %{_mandir}/man[18]/*.[18]*
534     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
535     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
536     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
537     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
538     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
539     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
540    
541     %config(noreplace,missingok) /etc/cron.daily/rpm
542     %config(noreplace,missingok) /etc/logrotate.d/rpm
543    
544     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
545    
546     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
547    
548     %rpmdbattr /var/lib/rpm/Basenames
549     %rpmdbattr /var/lib/rpm/Conflictname
550     %rpmdbattr /var/lib/rpm/__db.0*
551     %rpmdbattr /var/lib/rpm/Dirnames
552     %rpmdbattr /var/lib/rpm/Group
553     %rpmdbattr /var/lib/rpm/Installtid
554     %rpmdbattr /var/lib/rpm/Name
555 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
556 tmb 343 %rpmdbattr /var/lib/rpm/Packages
557     %rpmdbattr /var/lib/rpm/Providename
558     %rpmdbattr /var/lib/rpm/Provideversion
559     %rpmdbattr /var/lib/rpm/Removetid
560     %rpmdbattr /var/lib/rpm/Requirename
561     %rpmdbattr /var/lib/rpm/Requireversion
562 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
563     %rpmdbattr /var/lib/rpm/Sigmd5
564 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
565    
566     %files build
567     %defattr(-,root,root)
568     %doc CHANGES
569     %doc doc-copy/*
570     %rpmattr %{_bindir}/rpmbuild
571 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
572 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
573     %rpmattr %{_prefix}/lib/rpm/check-files
574     %rpmattr %{_prefix}/lib/rpm/debugedit
575 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
576 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
577     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
578     %rpmattr %{_prefix}/lib/rpm/find-provides
579     %rpmattr %{_prefix}/lib/rpm/find-requires
580 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
581 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
582     %rpmattr %{_prefix}/lib/rpm/perl.prov
583     %rpmattr %{_prefix}/lib/rpm/perl.req
584    
585     %rpmattr %{_prefix}/lib/rpm/check-buildroot
586     %rpmattr %{_prefix}/lib/rpm/check-prereqs
587     %rpmattr %{_prefix}/lib/rpm/check-rpaths
588     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
589 tv 255921 #rpmattr %{_prefix}/lib/rpm/javadeps
590 tmb 343 %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
591     %rpmattr %{_prefix}/lib/rpm/macros.perl
592     %rpmattr %{_prefix}/lib/rpm/macros.php
593     %rpmattr %{_prefix}/lib/rpm/macros.python
594     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
595     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
596 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
597     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
598 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
599     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
600 dmorgan 185007 #%rpmattr %{_prefix}/lib/rpm/rpmdiff
601 tmb 343
602     %rpmattr %{_prefix}/lib/rpm/rpmdeps
603     #%rpmattr %{_prefix}/lib/rpm/trpm
604 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
605 tmb 343
606 tv 255921
607 tmb 343 %{_mandir}/man8/rpmbuild.8*
608     %{_mandir}/man8/rpmdeps.8*
609    
610     %if %buildpython
611     %files -n python-rpm
612     %defattr(-,root,root)
613     %{_libdir}/python*/site-packages/rpm
614     %endif
615    
616     %files -n %librpmname
617     %defattr(-,root,root)
618 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
619     %{_libdir}/librpmio.so.%{libmajor}*
620 dmorgan 185007 %if %{with plugins}
621     %{_libdir}/rpm-plugins
622     %endif
623    
624     %files -n %librpmbuild
625 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
626 tmb 343
627 dmorgan 185007 %files -n %librpmsign
628     %{_libdir}/librpmsign.so.%{libmajorsign}*
629    
630     %files sign
631     %defattr(-,root,root)
632     %{_bindir}/rpmsign
633     %{_mandir}/man8/rpmsign.8*
634    
635 tmb 343 %files -n %librpmnamedevel
636     %defattr(-,root,root)
637     %{_includedir}/rpm
638     %{_libdir}/librpm.so
639     %{_libdir}/librpmio.so
640     %{_libdir}/librpmbuild.so
641 dmorgan 185007 %{_libdir}/librpmsign.so
642 tmb 343 %{_libdir}/pkgconfig/rpm.pc
643 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30