/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 268937 - (hide annotations) (download)
Sun Jul 8 22:25:34 2012 UTC (11 years, 9 months ago) by dmorgan
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20001 byte(s)
Update rubygem patch ( from mandriva )
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 dmorgan 268937 %define release %mkrel %{?snapver:0.%{snapver}.}4
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97     # (fredl) add loging facilities through syslog
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
123 tmb 343
124     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
125     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
126     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
127     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
128     # but this is bad design anyway
129 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
130 tmb 343
131     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
132 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
133 tv 215854 Patch134: extcond.diff
134 tmb 343
135 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
136 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
137     # implementation: as long as debugedit can just overwrite data in the elf
138     # sections things keep relatively easy, but if dest_dir is longer than the
139     # original directory, debugedit would have to expand the whole elf file. Which
140     # might be technically possible but debugedit currently does not even try to."
141 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
142 dmorgan 49378
143 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
144     # with this patch, "#%define foo bar" is a fatal error
145 dmorgan 185007 # Bug still valid => Send upstream for review.
146 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
147 tmb 343
148     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
149 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
150     Patch146: rpm-4.9.1.1-filetriggers.patch
151 tmb 343
152     # add two fatal errors (during package build)
153 dmorgan 185007 # Useful ? to drop ?
154     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
155 tmb 343
156     # (nb: see the patch for more info about this issue)
157 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
158 tmb 343
159 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
160     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
161 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
162 tmb 343
163     Patch1007: rpm-4.6.0-rc3-xz-support.patch
164    
165     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
166     # as this breaks stuff that installs files to $DOCDIR during %%install
167 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
168 tmb 343
169     # Turbolinux patches
170     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
171     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
172    
173 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
174 dmorgan 49378
175 tv 262316 # (tv) fix tests:
176     Patch2100: rpm-4.10.0-fix-testsuite.diff
177 tv 255921
178 tmb 343 Patch3000: mips_macros.patch
179     Patch3001: fix_stack_protector_check.patch
180 tv 256616 Patch3002: mips_define_isa_macros.patch
181     Patch3003: rpm_arm_mips_isa_macros.patch
182     Patch3004: rpm_add_armv5tl.patch
183 tmb 343
184 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
185     # and not full path
186     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
187 tv 223198 #
188 dmorgan 185007 # Fedora patches
189 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
190     #
191 dmorgan 185007
192     License: GPLv2+
193     BuildRequires: autoconf
194 tmb 343 BuildRequires: zlib-devel
195     BuildRequires: bzip2-devel
196     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
197 dmorgan 185007 BuildRequires: automake
198 tmb 343 BuildRequires: elfutils-devel
199     BuildRequires: libbeecrypt-devel
200 dmorgan 185007 BuildRequires: ed
201     BuildRequires: gettext-devel
202 tmb 343 BuildRequires: libsqlite3-devel
203 tv 257954 BuildRequires: db5.2-devel
204 tmb 343 BuildRequires: neon-devel
205     BuildRequires: popt-devel
206     BuildRequires: nss-devel
207     BuildRequires: magic-devel
208 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
209 tmb 343 BuildRequires: readline-devel
210     BuildRequires: ncurses-devel
211 dmorgan 185007 BuildRequires: openssl-devel
212 tv 256683 BuildRequires: lua5.1-devel
213 dmorgan 185007 BuildRequires: libcap-devel
214     # Needed for doc
215 tmb 343 #BuildRequires: graphviz
216 dmorgan 185007 BuildRequires: tetex
217 tmb 343 %if %buildpython
218     BuildRequires: python-devel
219     %endif
220 tv 223263 # for testsuite:
221     BuildRequires: fakechroot
222 tmb 343
223     Requires: bzip2 >= 0.9.0c-2
224     Requires: lzma
225     Requires: cpio
226     Requires: gawk
227     Requires: glibc >= 2.1.92
228     Requires: mktemp
229 tmb 345 Requires: setup >= 2.2.0-8
230 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
231 tmb 343 Requires: update-alternatives
232     Requires: %librpmname = %epoch:%version-%release
233     URL: http://rpm.org/
234     %define git_url http://rpm.org/git/rpm.git
235 dmorgan 185007 Requires(pre): rpm-helper
236 tmb 343 Requires(pre): coreutils
237 dmorgan 185007 Requires(postun): rpm-helper
238 tmb 343
239 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
240 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
241 dmorgan 185007
242 tmb 343 %description
243     RPM is a powerful command line driven package management system capable of
244     installing, uninstalling, verifying, querying, and updating software packages.
245     Each software package consists of an archive of files along with information
246     about the package like its version, a description, etc.
247    
248 dmorgan 185191 %package -n %librpmbuild
249     Summary: Libraries for building and signing RPM packages
250     Group: System/Libraries
251     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
252     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
253    
254     %description -n %librpmbuild
255     This package contains the RPM shared libraries for building and signing
256     packages.
257    
258     %package -n %librpmsign
259     Summary: Libraries for building and signing RPM packages
260     Group: System/Libraries
261    
262     %description -n %librpmsign
263     This package contains the RPM shared libraries for building and signing
264     packages.
265    
266 tmb 343 %package -n %librpmname
267 tmb 345 Summary: Library used by rpm
268     Group: System/Libraries
269     Provides: librpm = %version-%release
270 tmb 343
271     %description -n %librpmname
272     RPM is a powerful command line driven package management system capable of
273     installing, uninstalling, verifying, querying, and updating software packages.
274     This package contains common files to all applications based on rpm.
275    
276     %package -n %librpmnamedevel
277     Summary: Development files for applications which will manipulate RPM packages
278     Group: Development/C
279     Requires: rpm = %epoch:%{version}-%{release}
280     Provides: librpm-devel = %version-%release
281     Provides: rpm-devel = %version-%release
282 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
283     Requires: %librpmbuild = %epoch:%version-%release
284     Requires: %librpmsign = %epoch:%version-%release
285 tmb 343
286     %description -n %librpmnamedevel
287     This package contains the RPM C library and header files. These
288     development files will simplify the process of writing programs
289     which manipulate RPM packages and databases and are intended to make
290     it easier to create graphical package managers or any other tools
291     that need an intimate knowledge of RPM packages in order to function.
292    
293     This package should be installed if you want to develop programs that
294     will manipulate RPM packages and databases.
295    
296     %package build
297     Summary: Scripts and executable programs used to build packages
298     Group: System/Configuration/Packaging
299     Requires: autoconf
300     Requires: automake
301     Requires: file
302     Requires: gcc-c++
303     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
304 dmorgan 185007 Requires: libtool-base
305     Requires: patch
306 tmb 343 Requires: make
307     Requires: tar
308     Requires: unzip
309     Requires: elfutils
310 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
311 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
312 dmorgan 185007 Requires: perl(YAML::Tiny)
313 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
314 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
315 tmb 343
316     %description build
317     This package contains scripts and executable programs that are used to
318     build packages using RPM.
319    
320 dmorgan 185007 %package sign
321     Summary: Package signing support
322     Group: System/Base
323    
324     %description sign
325     This package contains support for digitally signing RPM packages.
326    
327 tmb 343 %if %buildpython
328     %package -n python-rpm
329     Summary: Python bindings for apps which will manipulate RPM packages
330     Group: Development/Python
331     Requires: rpm = %epoch:%{version}-%{release}
332    
333     %description -n python-rpm
334     The rpm-python package contains a module which permits applications
335     written in the Python programming language to use the interface
336     supplied by RPM (RPM Package Manager) libraries.
337    
338     This package should be installed if you want to develop Python
339     programs that will manipulate RPM packages and databases.
340     %endif
341    
342     %prep
343     %setup -q -n %name-%srcver
344 dmorgan 186388 %apply_patches
345 tmb 343
346     %build
347     autoreconf
348    
349     %if %builddebug
350     RPM_OPT_FLAGS=-g
351     %endif
352 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
353 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
354 fwang 215771 %configure2_5x \
355 tmb 343 --enable-nls \
356     --enable-python \
357     --enable-sqlite3 \
358     --without-javaglue \
359     %if %builddebug
360     --enable-debug \
361     %endif
362 dmorgan 185007 --with-external-db \
363 tmb 343 %if %buildpython
364     --with-python=%{pyver} \
365     %else
366     --without-python \
367     %endif
368 dmorgan 185007 %if ! %buildplugins
369     --disable-plugins \
370     %endif
371 tmb 343 --with-glob \
372     --without-selinux \
373 dmorgan 185007 --without-apidocs \
374     --with-cap
375 tmb 343
376     %make
377    
378     %install
379 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
380 tmb 343
381     make DESTDIR=%buildroot install
382    
383 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
384    
385 tmb 343 #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
386    
387     # Save list of packages through cron
388     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
389     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
390    
391     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
392     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
393    
394     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
395     for dbi in \
396     Basenames Conflictname Dirnames Group Installtid Name Providename \
397     Provideversion Removetid Requirename Requireversion Triggername \
398 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
399     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
400 tmb 343 do
401     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
402     done
403    
404     test -d doc-copy || mkdir doc-copy
405     rm -rf doc-copy/*
406     ln -f doc/manual/* doc-copy/
407     rm -f doc-copy/Makefile*
408    
409     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
410    
411     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
412     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
413     # Put your own system macros here
414     # usually contains
415    
416     # Set this one according your locales
417     # %%_install_langs
418    
419     EOF
420    
421     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
422    
423 tv 206214 %check
424     make check
425    
426 tmb 343 %pre
427     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
428    
429     rm -rf /usr/lib/rpm/*-mandrake-*
430 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
431 tmb 343
432 tmb 345
433 tmb 343 %post
434     # nuke __db.00? when updating to this rpm
435     rm -f /var/lib/rpm/__db.00?
436    
437 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
438 tmb 343 /bin/rpm --initdb
439     fi
440    
441     %postun
442     /usr/share/rpm-helper/del-user rpm $1 rpm
443    
444     %define rpmattr %attr(0755, rpm, rpm)
445    
446     %files -f %{name}.lang
447     %defattr(-,root,root)
448     %doc GROUPS CHANGES doc/manual/[a-z]*
449     %attr(0755,rpm,rpm) /bin/rpm
450     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
451     %attr(0755, rpm, rpm) %{_bindir}/gendiff
452     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
453 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
454 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
455     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
456     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
457    
458     %dir %{_localstatedir}/spool/repackage
459     %dir %{rpmdir}
460     %dir /etc/rpm
461     %config(noreplace) /etc/rpm/macros
462     %dir /etc/rpm/macros.d
463     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
464     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
465     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
466     %attr(0644, rpm, rpm) %{rpmdir}/macros
467     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
468     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
469     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
470     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
471 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
472     %attr(0755, rpm, rpm) %{rpmdir}/script.req
473 tv 256610 %exclude %{rpmdir}/tcl.req
474 tmb 343
475     %rpmattr %{rpmdir}/rpm2cpio.sh
476     %rpmattr %{rpmdir}/tgpg
477    
478 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
479     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
480    
481 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
482     %ifarch %{ix86} x86_64
483     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
484     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
485     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
486     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
487 rtp 267694 %else
488     %exclude %{rpmdir}/platform/i*86-linux/macros
489     %exclude %{rpmdir}/platform/athlon-linux/macros
490     %exclude %{rpmdir}/platform/pentium*-linux/macros
491     %exclude %{rpmdir}/platform/geode-linux/macros
492 tmb 343 %endif
493     %ifarch x86_64
494     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
495     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
496     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
497 rtp 267694 %else
498     %exclude %{rpmdir}/platform/amd64-linux/macros
499     %exclude %{rpmdir}/platform/ia32e-linux/macros
500     %exclude %{rpmdir}/platform/x86_64-linux/macros
501 tmb 343 %endif
502     %ifarch %arm
503 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
504 tv 256613 %else
505     %exclude %{rpmdir}/platform/arm*/macros
506 tmb 343 %endif
507     %ifarch %mips
508     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
509     %endif
510     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
511 tv 256613 # new in 4.10.0:
512     %exclude %{rpmdir}/platform/alpha*-linux/macros
513     %exclude %{rpmdir}/platform/sparc*-linux/macros
514     %exclude %{rpmdir}/platform/ia64*-linux/macros
515     %exclude %{rpmdir}/platform/ppc*-linux/macros
516     %exclude %{rpmdir}/platform/s390*-linux/macros
517     %exclude %{rpmdir}/platform/sh*-linux/macros
518 tmb 343
519 tv 256613
520    
521 tmb 343 %{_mandir}/man[18]/*.[18]*
522     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
523     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
524     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
525     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
526     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
527     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
528    
529     %config(noreplace,missingok) /etc/cron.daily/rpm
530     %config(noreplace,missingok) /etc/logrotate.d/rpm
531    
532     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
533    
534     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
535    
536     %rpmdbattr /var/lib/rpm/Basenames
537     %rpmdbattr /var/lib/rpm/Conflictname
538     %rpmdbattr /var/lib/rpm/__db.0*
539     %rpmdbattr /var/lib/rpm/Dirnames
540     %rpmdbattr /var/lib/rpm/Group
541     %rpmdbattr /var/lib/rpm/Installtid
542     %rpmdbattr /var/lib/rpm/Name
543 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
544 tmb 343 %rpmdbattr /var/lib/rpm/Packages
545     %rpmdbattr /var/lib/rpm/Providename
546     %rpmdbattr /var/lib/rpm/Provideversion
547     %rpmdbattr /var/lib/rpm/Removetid
548     %rpmdbattr /var/lib/rpm/Requirename
549     %rpmdbattr /var/lib/rpm/Requireversion
550 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
551     %rpmdbattr /var/lib/rpm/Sigmd5
552 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
553    
554     %files build
555     %defattr(-,root,root)
556     %doc CHANGES
557     %doc doc-copy/*
558     %rpmattr %{_bindir}/rpmbuild
559 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
560 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
561     %rpmattr %{_prefix}/lib/rpm/check-files
562     %rpmattr %{_prefix}/lib/rpm/debugedit
563 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
564 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
565     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
566     %rpmattr %{_prefix}/lib/rpm/find-provides
567     %rpmattr %{_prefix}/lib/rpm/find-requires
568 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
569 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
570     %rpmattr %{_prefix}/lib/rpm/perl.prov
571     %rpmattr %{_prefix}/lib/rpm/perl.req
572    
573     %rpmattr %{_prefix}/lib/rpm/check-buildroot
574     %rpmattr %{_prefix}/lib/rpm/check-prereqs
575     %rpmattr %{_prefix}/lib/rpm/check-rpaths
576     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
577 tv 255921 #rpmattr %{_prefix}/lib/rpm/javadeps
578 tmb 343 %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
579     %rpmattr %{_prefix}/lib/rpm/macros.perl
580     %rpmattr %{_prefix}/lib/rpm/macros.php
581     %rpmattr %{_prefix}/lib/rpm/macros.python
582     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
583     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
584 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
585     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
586 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
587     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
588 dmorgan 185007 #%rpmattr %{_prefix}/lib/rpm/rpmdiff
589 tmb 343
590     %rpmattr %{_prefix}/lib/rpm/rpmdeps
591     #%rpmattr %{_prefix}/lib/rpm/trpm
592 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
593 tmb 343
594 tv 255921
595 tmb 343 %{_mandir}/man8/rpmbuild.8*
596     %{_mandir}/man8/rpmdeps.8*
597    
598     %if %buildpython
599     %files -n python-rpm
600     %defattr(-,root,root)
601     %{_libdir}/python*/site-packages/rpm
602     %endif
603    
604     %files -n %librpmname
605     %defattr(-,root,root)
606 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
607     %{_libdir}/librpmio.so.%{libmajor}*
608 dmorgan 185007 %if %{with plugins}
609     %{_libdir}/rpm-plugins
610     %endif
611    
612     %files -n %librpmbuild
613 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
614 tmb 343
615 dmorgan 185007 %files -n %librpmsign
616     %{_libdir}/librpmsign.so.%{libmajorsign}*
617    
618     %files sign
619     %defattr(-,root,root)
620     %{_bindir}/rpmsign
621     %{_mandir}/man8/rpmsign.8*
622    
623 tmb 343 %files -n %librpmnamedevel
624     %defattr(-,root,root)
625     %{_includedir}/rpm
626     %{_libdir}/librpm.so
627     %{_libdir}/librpmio.so
628     %{_libdir}/librpmbuild.so
629 dmorgan 185007 %{_libdir}/librpmsign.so
630 tmb 343 %{_libdir}/pkgconfig/rpm.pc
631 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30