/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 276745 - (hide annotations) (download)
Tue Jul 31 10:53:40 2012 UTC (11 years, 8 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20100 byte(s)
- add "compressed" debug packages support
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 276745 %define release %mkrel %{?snapver:0.%{snapver}.}7
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97     # (fredl) add loging facilities through syslog
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
123 tmb 343
124     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
125     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
126     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
127     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
128     # but this is bad design anyway
129 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
130 tmb 343
131     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
132 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
133 tv 215854 Patch134: extcond.diff
134 tmb 343
135 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
136 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
137     # implementation: as long as debugedit can just overwrite data in the elf
138     # sections things keep relatively easy, but if dest_dir is longer than the
139     # original directory, debugedit would have to expand the whole elf file. Which
140     # might be technically possible but debugedit currently does not even try to."
141 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
142 dmorgan 49378
143 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
144     # with this patch, "#%define foo bar" is a fatal error
145 dmorgan 185007 # Bug still valid => Send upstream for review.
146 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
147 tmb 343
148     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
149 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
150     Patch146: rpm-4.9.1.1-filetriggers.patch
151 tmb 343
152     # add two fatal errors (during package build)
153 dmorgan 185007 # Useful ? to drop ?
154     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
155 tmb 343
156     # (nb: see the patch for more info about this issue)
157 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
158 tmb 343
159 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
160     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
161 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
162 tmb 343
163     Patch1007: rpm-4.6.0-rc3-xz-support.patch
164    
165     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
166     # as this breaks stuff that installs files to $DOCDIR during %%install
167 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
168 tmb 343
169     # Turbolinux patches
170     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
171     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
172    
173 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
174 dmorgan 49378
175 tv 262316 # (tv) fix tests:
176     Patch2100: rpm-4.10.0-fix-testsuite.diff
177 tv 255921
178 tmb 343 Patch3000: mips_macros.patch
179     Patch3001: fix_stack_protector_check.patch
180 tv 256616 Patch3002: mips_define_isa_macros.patch
181     Patch3003: rpm_arm_mips_isa_macros.patch
182     Patch3004: rpm_add_armv5tl.patch
183 tmb 343
184 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
185     # and not full path
186     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
187 tv 223198 #
188 dmorgan 185007 # Fedora patches
189 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
190     #
191 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
192     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
193 tv 276745 # (tv) Compressed debuginfo support:
194     Patch3501: rpm-4.10.0-dwz-debuginfo.patch
195     # (tv) Mini debuginfo support:
196     Patch3502: rpm-4.10.0-minidebuginfo.patch
197 dmorgan 185007
198     License: GPLv2+
199     BuildRequires: autoconf
200 tmb 343 BuildRequires: zlib-devel
201     BuildRequires: bzip2-devel
202 tv 276213 BuildRequires: liblzma-devel >= 5
203 dmorgan 185007 BuildRequires: automake
204 tmb 343 BuildRequires: elfutils-devel
205     BuildRequires: libbeecrypt-devel
206 dmorgan 185007 BuildRequires: ed
207     BuildRequires: gettext-devel
208 tmb 343 BuildRequires: libsqlite3-devel
209 tv 276213 BuildRequires: db5.3-devel
210 tmb 343 BuildRequires: neon-devel
211     BuildRequires: popt-devel
212     BuildRequires: nss-devel
213     BuildRequires: magic-devel
214 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
215 tmb 343 BuildRequires: readline-devel
216     BuildRequires: ncurses-devel
217 dmorgan 185007 BuildRequires: openssl-devel
218 tv 256683 BuildRequires: lua5.1-devel
219 dmorgan 185007 BuildRequires: libcap-devel
220     # Needed for doc
221 tmb 343 #BuildRequires: graphviz
222 dmorgan 185007 BuildRequires: tetex
223 tmb 343 %if %buildpython
224     BuildRequires: python-devel
225     %endif
226 tv 223263 # for testsuite:
227     BuildRequires: fakechroot
228 tmb 343
229     Requires: bzip2 >= 0.9.0c-2
230     Requires: lzma
231     Requires: cpio
232     Requires: gawk
233     Requires: glibc >= 2.1.92
234     Requires: mktemp
235 tmb 345 Requires: setup >= 2.2.0-8
236 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
237 tmb 343 Requires: update-alternatives
238     Requires: %librpmname = %epoch:%version-%release
239     URL: http://rpm.org/
240     %define git_url http://rpm.org/git/rpm.git
241 dmorgan 185007 Requires(pre): rpm-helper
242 tmb 343 Requires(pre): coreutils
243 dmorgan 185007 Requires(postun): rpm-helper
244 tmb 343
245 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
246 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
247 dmorgan 185007
248 tmb 343 %description
249     RPM is a powerful command line driven package management system capable of
250     installing, uninstalling, verifying, querying, and updating software packages.
251     Each software package consists of an archive of files along with information
252     about the package like its version, a description, etc.
253    
254 dmorgan 185191 %package -n %librpmbuild
255     Summary: Libraries for building and signing RPM packages
256     Group: System/Libraries
257     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
258     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
259    
260     %description -n %librpmbuild
261     This package contains the RPM shared libraries for building and signing
262     packages.
263    
264     %package -n %librpmsign
265     Summary: Libraries for building and signing RPM packages
266     Group: System/Libraries
267    
268     %description -n %librpmsign
269     This package contains the RPM shared libraries for building and signing
270     packages.
271    
272 tmb 343 %package -n %librpmname
273 tmb 345 Summary: Library used by rpm
274     Group: System/Libraries
275     Provides: librpm = %version-%release
276 tmb 343
277     %description -n %librpmname
278     RPM is a powerful command line driven package management system capable of
279     installing, uninstalling, verifying, querying, and updating software packages.
280     This package contains common files to all applications based on rpm.
281    
282     %package -n %librpmnamedevel
283     Summary: Development files for applications which will manipulate RPM packages
284     Group: Development/C
285     Requires: rpm = %epoch:%{version}-%{release}
286     Provides: librpm-devel = %version-%release
287     Provides: rpm-devel = %version-%release
288 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
289     Requires: %librpmbuild = %epoch:%version-%release
290     Requires: %librpmsign = %epoch:%version-%release
291 tmb 343
292     %description -n %librpmnamedevel
293     This package contains the RPM C library and header files. These
294     development files will simplify the process of writing programs
295     which manipulate RPM packages and databases and are intended to make
296     it easier to create graphical package managers or any other tools
297     that need an intimate knowledge of RPM packages in order to function.
298    
299     This package should be installed if you want to develop programs that
300     will manipulate RPM packages and databases.
301    
302     %package build
303     Summary: Scripts and executable programs used to build packages
304     Group: System/Configuration/Packaging
305     Requires: autoconf
306     Requires: automake
307     Requires: file
308     Requires: gcc-c++
309     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
310 dmorgan 185007 Requires: libtool-base
311     Requires: patch
312 tmb 343 Requires: make
313     Requires: tar
314     Requires: unzip
315     Requires: elfutils
316 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
317 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
318 dmorgan 185007 Requires: perl(YAML::Tiny)
319 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
320 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
321 tmb 343
322     %description build
323     This package contains scripts and executable programs that are used to
324     build packages using RPM.
325    
326 dmorgan 185007 %package sign
327     Summary: Package signing support
328     Group: System/Base
329    
330     %description sign
331     This package contains support for digitally signing RPM packages.
332    
333 tmb 343 %if %buildpython
334     %package -n python-rpm
335     Summary: Python bindings for apps which will manipulate RPM packages
336     Group: Development/Python
337     Requires: rpm = %epoch:%{version}-%{release}
338    
339     %description -n python-rpm
340     The rpm-python package contains a module which permits applications
341     written in the Python programming language to use the interface
342     supplied by RPM (RPM Package Manager) libraries.
343    
344     This package should be installed if you want to develop Python
345     programs that will manipulate RPM packages and databases.
346     %endif
347    
348     %prep
349     %setup -q -n %name-%srcver
350 dmorgan 186388 %apply_patches
351 tmb 343
352     %build
353     autoreconf
354    
355     %if %builddebug
356     RPM_OPT_FLAGS=-g
357     %endif
358 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
359 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
360 fwang 215771 %configure2_5x \
361 tmb 343 --enable-nls \
362     --enable-python \
363     --enable-sqlite3 \
364     --without-javaglue \
365     %if %builddebug
366     --enable-debug \
367     %endif
368 dmorgan 185007 --with-external-db \
369 tmb 343 %if %buildpython
370     --with-python=%{pyver} \
371     %else
372     --without-python \
373     %endif
374 dmorgan 185007 %if ! %buildplugins
375     --disable-plugins \
376     %endif
377 tmb 343 --with-glob \
378     --without-selinux \
379 dmorgan 185007 --without-apidocs \
380     --with-cap
381 tmb 343
382     %make
383    
384     %install
385 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
386 tmb 343
387     make DESTDIR=%buildroot install
388    
389 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
390    
391 tmb 343 # Save list of packages through cron
392     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
393     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
394    
395     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
396     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
397    
398     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
399     for dbi in \
400     Basenames Conflictname Dirnames Group Installtid Name Providename \
401     Provideversion Removetid Requirename Requireversion Triggername \
402 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
403     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
404 tmb 343 do
405     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
406     done
407    
408     test -d doc-copy || mkdir doc-copy
409     rm -rf doc-copy/*
410     ln -f doc/manual/* doc-copy/
411     rm -f doc-copy/Makefile*
412    
413     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
414    
415     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
416     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
417     # Put your own system macros here
418     # usually contains
419    
420     # Set this one according your locales
421     # %%_install_langs
422    
423     EOF
424    
425     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
426    
427 tv 206214 %check
428     make check
429    
430 tmb 343 %pre
431     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
432    
433     rm -rf /usr/lib/rpm/*-mandrake-*
434 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
435 tmb 343
436 tmb 345
437 tmb 343 %post
438     # nuke __db.00? when updating to this rpm
439     rm -f /var/lib/rpm/__db.00?
440    
441 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
442 tmb 343 /bin/rpm --initdb
443     fi
444    
445     %postun
446     /usr/share/rpm-helper/del-user rpm $1 rpm
447    
448     %define rpmattr %attr(0755, rpm, rpm)
449    
450     %files -f %{name}.lang
451     %defattr(-,root,root)
452     %doc GROUPS CHANGES doc/manual/[a-z]*
453     %attr(0755,rpm,rpm) /bin/rpm
454     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
455     %attr(0755, rpm, rpm) %{_bindir}/gendiff
456     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
457 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
458 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
459     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
460     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
461    
462     %dir %{_localstatedir}/spool/repackage
463     %dir %{rpmdir}
464     %dir /etc/rpm
465     %config(noreplace) /etc/rpm/macros
466     %dir /etc/rpm/macros.d
467     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
468     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
469     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
470     %attr(0644, rpm, rpm) %{rpmdir}/macros
471     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
472     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
473     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
474     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
475 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
476     %attr(0755, rpm, rpm) %{rpmdir}/script.req
477 tv 256610 %exclude %{rpmdir}/tcl.req
478 tmb 343
479     %rpmattr %{rpmdir}/rpm2cpio.sh
480     %rpmattr %{rpmdir}/tgpg
481    
482 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
483     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
484    
485 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
486     %ifarch %{ix86} x86_64
487     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
488     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
489     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
490     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
491 rtp 267694 %else
492     %exclude %{rpmdir}/platform/i*86-linux/macros
493     %exclude %{rpmdir}/platform/athlon-linux/macros
494     %exclude %{rpmdir}/platform/pentium*-linux/macros
495     %exclude %{rpmdir}/platform/geode-linux/macros
496 tmb 343 %endif
497     %ifarch x86_64
498     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
499     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
500     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
501 rtp 267694 %else
502     %exclude %{rpmdir}/platform/amd64-linux/macros
503     %exclude %{rpmdir}/platform/ia32e-linux/macros
504     %exclude %{rpmdir}/platform/x86_64-linux/macros
505 tmb 343 %endif
506     %ifarch %arm
507 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
508 tv 256613 %else
509     %exclude %{rpmdir}/platform/arm*/macros
510 tmb 343 %endif
511     %ifarch %mips
512     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
513     %endif
514     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
515 tv 256613 # new in 4.10.0:
516     %exclude %{rpmdir}/platform/alpha*-linux/macros
517     %exclude %{rpmdir}/platform/sparc*-linux/macros
518     %exclude %{rpmdir}/platform/ia64*-linux/macros
519     %exclude %{rpmdir}/platform/ppc*-linux/macros
520     %exclude %{rpmdir}/platform/s390*-linux/macros
521     %exclude %{rpmdir}/platform/sh*-linux/macros
522 tmb 343
523 tv 256613
524    
525 tmb 343 %{_mandir}/man[18]/*.[18]*
526     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
527     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
528     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
529     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
530     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
531     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
532    
533     %config(noreplace,missingok) /etc/cron.daily/rpm
534     %config(noreplace,missingok) /etc/logrotate.d/rpm
535    
536     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
537    
538     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
539    
540     %rpmdbattr /var/lib/rpm/Basenames
541     %rpmdbattr /var/lib/rpm/Conflictname
542     %rpmdbattr /var/lib/rpm/__db.0*
543     %rpmdbattr /var/lib/rpm/Dirnames
544     %rpmdbattr /var/lib/rpm/Group
545     %rpmdbattr /var/lib/rpm/Installtid
546     %rpmdbattr /var/lib/rpm/Name
547 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
548 tmb 343 %rpmdbattr /var/lib/rpm/Packages
549     %rpmdbattr /var/lib/rpm/Providename
550     %rpmdbattr /var/lib/rpm/Provideversion
551     %rpmdbattr /var/lib/rpm/Removetid
552     %rpmdbattr /var/lib/rpm/Requirename
553     %rpmdbattr /var/lib/rpm/Requireversion
554 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
555     %rpmdbattr /var/lib/rpm/Sigmd5
556 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
557    
558     %files build
559     %defattr(-,root,root)
560     %doc CHANGES
561     %doc doc-copy/*
562     %rpmattr %{_bindir}/rpmbuild
563 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
564 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
565     %rpmattr %{_prefix}/lib/rpm/check-files
566     %rpmattr %{_prefix}/lib/rpm/debugedit
567 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
568 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
569     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
570     %rpmattr %{_prefix}/lib/rpm/find-provides
571     %rpmattr %{_prefix}/lib/rpm/find-requires
572 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
573 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
574     %rpmattr %{_prefix}/lib/rpm/perl.prov
575     %rpmattr %{_prefix}/lib/rpm/perl.req
576    
577     %rpmattr %{_prefix}/lib/rpm/check-buildroot
578     %rpmattr %{_prefix}/lib/rpm/check-prereqs
579     %rpmattr %{_prefix}/lib/rpm/check-rpaths
580     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
581     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
582     %rpmattr %{_prefix}/lib/rpm/macros.perl
583     %rpmattr %{_prefix}/lib/rpm/macros.php
584     %rpmattr %{_prefix}/lib/rpm/macros.python
585     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
586     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
587 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
588     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
589 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
590     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
591    
592     %rpmattr %{_prefix}/lib/rpm/rpmdeps
593 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
594 tmb 343
595 tv 255921
596 tmb 343 %{_mandir}/man8/rpmbuild.8*
597     %{_mandir}/man8/rpmdeps.8*
598    
599     %if %buildpython
600     %files -n python-rpm
601     %defattr(-,root,root)
602     %{_libdir}/python*/site-packages/rpm
603     %endif
604    
605     %files -n %librpmname
606     %defattr(-,root,root)
607 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
608     %{_libdir}/librpmio.so.%{libmajor}*
609 dmorgan 185007 %if %{with plugins}
610     %{_libdir}/rpm-plugins
611     %endif
612    
613     %files -n %librpmbuild
614 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
615 tmb 343
616 dmorgan 185007 %files -n %librpmsign
617     %{_libdir}/librpmsign.so.%{libmajorsign}*
618    
619     %files sign
620     %defattr(-,root,root)
621     %{_bindir}/rpmsign
622     %{_mandir}/man8/rpmsign.8*
623    
624 tmb 343 %files -n %librpmnamedevel
625     %defattr(-,root,root)
626     %{_includedir}/rpm
627     %{_libdir}/librpm.so
628     %{_libdir}/librpmio.so
629     %{_libdir}/librpmbuild.so
630 dmorgan 185007 %{_libdir}/librpmsign.so
631 tmb 343 %{_libdir}/pkgconfig/rpm.pc
632 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30