/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 302008 - (hide annotations) (download)
Tue Oct 2 09:15:29 2012 UTC (11 years, 6 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20190 byte(s)
requires xz instead of lzma

1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 284979 %define release %mkrel %{?snapver:0.%{snapver}.}11
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97     # (fredl) add loging facilities through syslog
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
123 tmb 343
124     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
125     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
126     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
127     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
128     # but this is bad design anyway
129 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
130 tmb 343
131     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
132 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
133 tv 215854 Patch134: extcond.diff
134 tmb 343
135 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
136 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
137     # implementation: as long as debugedit can just overwrite data in the elf
138     # sections things keep relatively easy, but if dest_dir is longer than the
139     # original directory, debugedit would have to expand the whole elf file. Which
140     # might be technically possible but debugedit currently does not even try to."
141 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
142 dmorgan 49378
143 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
144     # with this patch, "#%define foo bar" is a fatal error
145 dmorgan 185007 # Bug still valid => Send upstream for review.
146 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
147 tmb 343
148     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
149 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
150     Patch146: rpm-4.9.1.1-filetriggers.patch
151 tmb 343
152     # add two fatal errors (during package build)
153 dmorgan 185007 # Useful ? to drop ?
154     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
155 tmb 343
156     # (nb: see the patch for more info about this issue)
157 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
158 tmb 343
159 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
160     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
161 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
162 tmb 343
163     Patch1007: rpm-4.6.0-rc3-xz-support.patch
164    
165     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
166     # as this breaks stuff that installs files to $DOCDIR during %%install
167 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
168 tmb 343
169     # Turbolinux patches
170     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
171     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
172    
173 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
174 dmorgan 49378
175 tv 262316 # (tv) fix tests:
176     Patch2100: rpm-4.10.0-fix-testsuite.diff
177 tv 255921
178 tmb 343 Patch3000: mips_macros.patch
179     Patch3001: fix_stack_protector_check.patch
180 tv 256616 Patch3002: mips_define_isa_macros.patch
181     Patch3003: rpm_arm_mips_isa_macros.patch
182     Patch3004: rpm_add_armv5tl.patch
183 tmb 343
184 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
185     # and not full path
186     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
187 tv 223198 #
188 dmorgan 185007 # Fedora patches
189 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
190     #
191 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
192     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
193 tv 276745 # (tv) Compressed debuginfo support:
194     Patch3501: rpm-4.10.0-dwz-debuginfo.patch
195     # (tv) Mini debuginfo support:
196     Patch3502: rpm-4.10.0-minidebuginfo.patch
197 dmorgan 185007
198 tv 276795 # (tv) merge mga stuff from rpm-setup:
199     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
200    
201 dmorgan 185007 License: GPLv2+
202     BuildRequires: autoconf
203 tmb 343 BuildRequires: zlib-devel
204     BuildRequires: bzip2-devel
205 tv 276213 BuildRequires: liblzma-devel >= 5
206 dmorgan 185007 BuildRequires: automake
207 tmb 343 BuildRequires: elfutils-devel
208     BuildRequires: libbeecrypt-devel
209 dmorgan 185007 BuildRequires: ed
210     BuildRequires: gettext-devel
211 tmb 343 BuildRequires: libsqlite3-devel
212 tv 276213 BuildRequires: db5.3-devel
213 tmb 343 BuildRequires: neon-devel
214     BuildRequires: popt-devel
215     BuildRequires: nss-devel
216     BuildRequires: magic-devel
217 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
218 tmb 343 BuildRequires: readline-devel
219     BuildRequires: ncurses-devel
220 dmorgan 185007 BuildRequires: openssl-devel
221 tv 256683 BuildRequires: lua5.1-devel
222 dmorgan 185007 BuildRequires: libcap-devel
223     # Needed for doc
224 tmb 343 #BuildRequires: graphviz
225 dmorgan 185007 BuildRequires: tetex
226 tmb 343 %if %buildpython
227     BuildRequires: python-devel
228     %endif
229 tv 223263 # for testsuite:
230     BuildRequires: fakechroot
231 tmb 343
232     Requires: bzip2 >= 0.9.0c-2
233 tv 302008 Requires: xz
234 tmb 343 Requires: cpio
235     Requires: gawk
236     Requires: glibc >= 2.1.92
237     Requires: mktemp
238 tmb 345 Requires: setup >= 2.2.0-8
239 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
240 tmb 343 Requires: update-alternatives
241     Requires: %librpmname = %epoch:%version-%release
242     URL: http://rpm.org/
243     %define git_url http://rpm.org/git/rpm.git
244 dmorgan 185007 Requires(pre): rpm-helper
245 tmb 343 Requires(pre): coreutils
246 dmorgan 185007 Requires(postun): rpm-helper
247 tmb 343
248 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
249 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
250 dmorgan 185007
251 tmb 343 %description
252     RPM is a powerful command line driven package management system capable of
253     installing, uninstalling, verifying, querying, and updating software packages.
254     Each software package consists of an archive of files along with information
255     about the package like its version, a description, etc.
256    
257 dmorgan 185191 %package -n %librpmbuild
258     Summary: Libraries for building and signing RPM packages
259     Group: System/Libraries
260     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
261     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
262    
263     %description -n %librpmbuild
264     This package contains the RPM shared libraries for building and signing
265     packages.
266    
267     %package -n %librpmsign
268     Summary: Libraries for building and signing RPM packages
269     Group: System/Libraries
270    
271     %description -n %librpmsign
272     This package contains the RPM shared libraries for building and signing
273     packages.
274    
275 tmb 343 %package -n %librpmname
276 tmb 345 Summary: Library used by rpm
277     Group: System/Libraries
278     Provides: librpm = %version-%release
279 tmb 343
280     %description -n %librpmname
281     RPM is a powerful command line driven package management system capable of
282     installing, uninstalling, verifying, querying, and updating software packages.
283     This package contains common files to all applications based on rpm.
284    
285     %package -n %librpmnamedevel
286     Summary: Development files for applications which will manipulate RPM packages
287     Group: Development/C
288     Requires: rpm = %epoch:%{version}-%{release}
289     Provides: librpm-devel = %version-%release
290     Provides: rpm-devel = %version-%release
291 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
292     Requires: %librpmbuild = %epoch:%version-%release
293     Requires: %librpmsign = %epoch:%version-%release
294 tmb 343
295     %description -n %librpmnamedevel
296     This package contains the RPM C library and header files. These
297     development files will simplify the process of writing programs
298     which manipulate RPM packages and databases and are intended to make
299     it easier to create graphical package managers or any other tools
300     that need an intimate knowledge of RPM packages in order to function.
301    
302     This package should be installed if you want to develop programs that
303     will manipulate RPM packages and databases.
304    
305     %package build
306     Summary: Scripts and executable programs used to build packages
307     Group: System/Configuration/Packaging
308     Requires: autoconf
309     Requires: automake
310     Requires: file
311     Requires: gcc-c++
312     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
313 dmorgan 185007 Requires: libtool-base
314     Requires: patch
315 tmb 343 Requires: make
316     Requires: tar
317     Requires: unzip
318     Requires: elfutils
319 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
320 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
321 dmorgan 185007 Requires: perl(YAML::Tiny)
322 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
323 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
324 tmb 343
325     %description build
326     This package contains scripts and executable programs that are used to
327     build packages using RPM.
328    
329 dmorgan 185007 %package sign
330     Summary: Package signing support
331     Group: System/Base
332    
333     %description sign
334     This package contains support for digitally signing RPM packages.
335    
336 tmb 343 %if %buildpython
337     %package -n python-rpm
338     Summary: Python bindings for apps which will manipulate RPM packages
339     Group: Development/Python
340     Requires: rpm = %epoch:%{version}-%{release}
341    
342     %description -n python-rpm
343     The rpm-python package contains a module which permits applications
344     written in the Python programming language to use the interface
345     supplied by RPM (RPM Package Manager) libraries.
346    
347     This package should be installed if you want to develop Python
348     programs that will manipulate RPM packages and databases.
349     %endif
350    
351     %prep
352     %setup -q -n %name-%srcver
353 dmorgan 186388 %apply_patches
354 tmb 343
355     %build
356     autoreconf
357    
358     %if %builddebug
359     RPM_OPT_FLAGS=-g
360     %endif
361 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
362 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
363 fwang 215771 %configure2_5x \
364 tmb 343 --enable-nls \
365     --enable-python \
366     --enable-sqlite3 \
367     --without-javaglue \
368     %if %builddebug
369     --enable-debug \
370     %endif
371 dmorgan 185007 --with-external-db \
372 tmb 343 %if %buildpython
373     --with-python=%{pyver} \
374     %else
375     --without-python \
376     %endif
377 dmorgan 185007 %if ! %buildplugins
378     --disable-plugins \
379     %endif
380 tmb 343 --with-glob \
381     --without-selinux \
382 dmorgan 185007 --without-apidocs \
383     --with-cap
384 tmb 343
385     %make
386    
387     %install
388 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
389 tmb 343
390     make DESTDIR=%buildroot install
391    
392 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
393    
394 tmb 343 # Save list of packages through cron
395     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
396     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
397    
398     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
399     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
400    
401     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
402     for dbi in \
403     Basenames Conflictname Dirnames Group Installtid Name Providename \
404     Provideversion Removetid Requirename Requireversion Triggername \
405 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
406     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
407 tmb 343 do
408     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
409     done
410    
411     test -d doc-copy || mkdir doc-copy
412     rm -rf doc-copy/*
413     ln -f doc/manual/* doc-copy/
414     rm -f doc-copy/Makefile*
415    
416     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
417    
418     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
419     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
420     # Put your own system macros here
421     # usually contains
422    
423     # Set this one according your locales
424     # %%_install_langs
425    
426     EOF
427    
428     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
429    
430 tv 206214 %check
431     make check
432    
433 tmb 343 %pre
434     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
435    
436     rm -rf /usr/lib/rpm/*-mandrake-*
437 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
438 tmb 343
439 tmb 345
440 tmb 343 %post
441     # nuke __db.00? when updating to this rpm
442     rm -f /var/lib/rpm/__db.00?
443    
444 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
445 tmb 343 /bin/rpm --initdb
446     fi
447    
448     %postun
449     /usr/share/rpm-helper/del-user rpm $1 rpm
450    
451     %define rpmattr %attr(0755, rpm, rpm)
452    
453     %files -f %{name}.lang
454     %defattr(-,root,root)
455     %doc GROUPS CHANGES doc/manual/[a-z]*
456     %attr(0755,rpm,rpm) /bin/rpm
457     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
458     %attr(0755, rpm, rpm) %{_bindir}/gendiff
459     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
460 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
461 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
462     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
463     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
464    
465     %dir %{_localstatedir}/spool/repackage
466     %dir %{rpmdir}
467     %dir /etc/rpm
468     %config(noreplace) /etc/rpm/macros
469     %dir /etc/rpm/macros.d
470     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
471     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
472     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
473     %attr(0644, rpm, rpm) %{rpmdir}/macros
474     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
475     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
476     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
477     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
478 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
479     %attr(0755, rpm, rpm) %{rpmdir}/script.req
480 tv 256610 %exclude %{rpmdir}/tcl.req
481 tmb 343
482     %rpmattr %{rpmdir}/rpm2cpio.sh
483     %rpmattr %{rpmdir}/tgpg
484    
485 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
486     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
487    
488 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
489     %ifarch %{ix86} x86_64
490     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
491     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
492     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
493     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
494 rtp 267694 %else
495     %exclude %{rpmdir}/platform/i*86-linux/macros
496     %exclude %{rpmdir}/platform/athlon-linux/macros
497     %exclude %{rpmdir}/platform/pentium*-linux/macros
498     %exclude %{rpmdir}/platform/geode-linux/macros
499 tmb 343 %endif
500     %ifarch x86_64
501     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
503     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
504 rtp 267694 %else
505     %exclude %{rpmdir}/platform/amd64-linux/macros
506     %exclude %{rpmdir}/platform/ia32e-linux/macros
507     %exclude %{rpmdir}/platform/x86_64-linux/macros
508 tmb 343 %endif
509     %ifarch %arm
510 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
511 tv 256613 %else
512     %exclude %{rpmdir}/platform/arm*/macros
513 tmb 343 %endif
514     %ifarch %mips
515     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
516     %endif
517     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
518 tv 256613 # new in 4.10.0:
519     %exclude %{rpmdir}/platform/alpha*-linux/macros
520     %exclude %{rpmdir}/platform/sparc*-linux/macros
521     %exclude %{rpmdir}/platform/ia64*-linux/macros
522     %exclude %{rpmdir}/platform/ppc*-linux/macros
523     %exclude %{rpmdir}/platform/s390*-linux/macros
524     %exclude %{rpmdir}/platform/sh*-linux/macros
525 tmb 343
526 tv 256613
527    
528 tmb 343 %{_mandir}/man[18]/*.[18]*
529     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
530     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
531     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
532     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
533     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
534     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
535    
536     %config(noreplace,missingok) /etc/cron.daily/rpm
537     %config(noreplace,missingok) /etc/logrotate.d/rpm
538    
539     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
540    
541     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
542    
543     %rpmdbattr /var/lib/rpm/Basenames
544     %rpmdbattr /var/lib/rpm/Conflictname
545     %rpmdbattr /var/lib/rpm/__db.0*
546     %rpmdbattr /var/lib/rpm/Dirnames
547     %rpmdbattr /var/lib/rpm/Group
548     %rpmdbattr /var/lib/rpm/Installtid
549     %rpmdbattr /var/lib/rpm/Name
550 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
551 tmb 343 %rpmdbattr /var/lib/rpm/Packages
552     %rpmdbattr /var/lib/rpm/Providename
553     %rpmdbattr /var/lib/rpm/Provideversion
554     %rpmdbattr /var/lib/rpm/Removetid
555     %rpmdbattr /var/lib/rpm/Requirename
556     %rpmdbattr /var/lib/rpm/Requireversion
557 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
558     %rpmdbattr /var/lib/rpm/Sigmd5
559 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
560    
561     %files build
562     %defattr(-,root,root)
563     %doc CHANGES
564     %doc doc-copy/*
565     %rpmattr %{_bindir}/rpmbuild
566 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
567 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
568     %rpmattr %{_prefix}/lib/rpm/check-files
569     %rpmattr %{_prefix}/lib/rpm/debugedit
570 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
571 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
572     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
573     %rpmattr %{_prefix}/lib/rpm/find-provides
574     %rpmattr %{_prefix}/lib/rpm/find-requires
575 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
576 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
577     %rpmattr %{_prefix}/lib/rpm/perl.prov
578     %rpmattr %{_prefix}/lib/rpm/perl.req
579    
580     %rpmattr %{_prefix}/lib/rpm/check-buildroot
581     %rpmattr %{_prefix}/lib/rpm/check-prereqs
582     %rpmattr %{_prefix}/lib/rpm/check-rpaths
583     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
584     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
585     %rpmattr %{_prefix}/lib/rpm/macros.perl
586     %rpmattr %{_prefix}/lib/rpm/macros.php
587     %rpmattr %{_prefix}/lib/rpm/macros.python
588     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
589     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
590 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
591     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
592 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
593     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
594    
595     %rpmattr %{_prefix}/lib/rpm/rpmdeps
596 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
597 tmb 343
598 tv 255921
599 tmb 343 %{_mandir}/man8/rpmbuild.8*
600     %{_mandir}/man8/rpmdeps.8*
601    
602     %if %buildpython
603     %files -n python-rpm
604     %defattr(-,root,root)
605     %{_libdir}/python*/site-packages/rpm
606     %endif
607    
608     %files -n %librpmname
609     %defattr(-,root,root)
610 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
611     %{_libdir}/librpmio.so.%{libmajor}*
612 dmorgan 185007 %if %{with plugins}
613     %{_libdir}/rpm-plugins
614     %endif
615    
616     %files -n %librpmbuild
617 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
618 tmb 343
619 dmorgan 185007 %files -n %librpmsign
620     %{_libdir}/librpmsign.so.%{libmajorsign}*
621    
622     %files sign
623     %defattr(-,root,root)
624     %{_bindir}/rpmsign
625     %{_mandir}/man8/rpmsign.8*
626    
627 tmb 343 %files -n %librpmnamedevel
628     %defattr(-,root,root)
629     %{_includedir}/rpm
630     %{_libdir}/librpm.so
631     %{_libdir}/librpmio.so
632     %{_libdir}/librpmbuild.so
633 dmorgan 185007 %{_libdir}/librpmsign.so
634 tmb 343 %{_libdir}/pkgconfig/rpm.pc
635 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30