/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 308048 - (hide annotations) (download)
Thu Oct 18 21:52:55 2012 UTC (11 years, 6 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20337 byte(s)
enhance debugedit message
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 302329 %define rpmversion 4.10.1
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 308048 %define release %mkrel %{?snapver:0.%{snapver}.}4
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97     # (fredl) add loging facilities through syslog
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
123 tmb 343
124     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
125     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
126     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
127     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
128     # but this is bad design anyway
129 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
130 tmb 343
131     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
132 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
133 tv 215854 Patch134: extcond.diff
134 tmb 343
135 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
136 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
137     # implementation: as long as debugedit can just overwrite data in the elf
138     # sections things keep relatively easy, but if dest_dir is longer than the
139     # original directory, debugedit would have to expand the whole elf file. Which
140     # might be technically possible but debugedit currently does not even try to."
141 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
142 dmorgan 49378
143 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
144     # with this patch, "#%define foo bar" is a fatal error
145 dmorgan 185007 # Bug still valid => Send upstream for review.
146 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
147 tmb 343
148     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
149 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
150     Patch146: rpm-4.9.1.1-filetriggers.patch
151 tmb 343
152     # add two fatal errors (during package build)
153 dmorgan 185007 # Useful ? to drop ?
154     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
155 tmb 343
156     # (nb: see the patch for more info about this issue)
157 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
158 tmb 343
159 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
160     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
161 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
162 tmb 343
163     Patch1007: rpm-4.6.0-rc3-xz-support.patch
164    
165     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
166     # as this breaks stuff that installs files to $DOCDIR during %%install
167 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
168 tmb 343
169     # Turbolinux patches
170     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
171     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
172    
173 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
174 dmorgan 49378
175 tv 262316 # (tv) fix tests:
176     Patch2100: rpm-4.10.0-fix-testsuite.diff
177 tv 255921
178 tmb 343 Patch3000: mips_macros.patch
179     Patch3001: fix_stack_protector_check.patch
180 tv 256616 Patch3002: mips_define_isa_macros.patch
181     Patch3003: rpm_arm_mips_isa_macros.patch
182     Patch3004: rpm_add_armv5tl.patch
183 tmb 343
184 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
185     # and not full path
186     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
187 tv 223198 #
188 dmorgan 185007 # Fedora patches
189 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
190     #
191 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
192     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
193 tv 276745 # (tv) Compressed debuginfo support:
194     Patch3501: rpm-4.10.0-dwz-debuginfo.patch
195     # (tv) Mini debuginfo support:
196     Patch3502: rpm-4.10.0-minidebuginfo.patch
197 tv 304675 # (tv) fix a rpm-4.10 regression:
198     Patch5303: rpm-4.10.1-skipped-hardlinks.patch
199 dmorgan 185007
200 tv 276795 # (tv) merge mga stuff from rpm-setup:
201     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
202 tv 308048 # (tv) enhance debugedit message:
203     Patch4001: fix-debugedit-log.diff
204 tv 276795
205 dmorgan 185007 License: GPLv2+
206     BuildRequires: autoconf
207 tmb 343 BuildRequires: zlib-devel
208     BuildRequires: bzip2-devel
209 tv 276213 BuildRequires: liblzma-devel >= 5
210 dmorgan 185007 BuildRequires: automake
211 tmb 343 BuildRequires: elfutils-devel
212     BuildRequires: libbeecrypt-devel
213 dmorgan 185007 BuildRequires: ed
214     BuildRequires: gettext-devel
215 tmb 343 BuildRequires: libsqlite3-devel
216 tv 276213 BuildRequires: db5.3-devel
217 tmb 343 BuildRequires: neon-devel
218     BuildRequires: popt-devel
219     BuildRequires: nss-devel
220     BuildRequires: magic-devel
221 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
222 tmb 343 BuildRequires: readline-devel
223     BuildRequires: ncurses-devel
224 dmorgan 185007 BuildRequires: openssl-devel
225 tv 256683 BuildRequires: lua5.1-devel
226 dmorgan 185007 BuildRequires: libcap-devel
227     # Needed for doc
228 tmb 343 #BuildRequires: graphviz
229 dmorgan 185007 BuildRequires: tetex
230 tmb 343 %if %buildpython
231     BuildRequires: python-devel
232     %endif
233 tv 223263 # for testsuite:
234     BuildRequires: fakechroot
235 tmb 343
236     Requires: bzip2 >= 0.9.0c-2
237 tv 302008 Requires: xz
238 tmb 343 Requires: cpio
239     Requires: gawk
240     Requires: glibc >= 2.1.92
241     Requires: mktemp
242 tmb 345 Requires: setup >= 2.2.0-8
243 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
244 tmb 343 Requires: update-alternatives
245     Requires: %librpmname = %epoch:%version-%release
246     URL: http://rpm.org/
247     %define git_url http://rpm.org/git/rpm.git
248 dmorgan 185007 Requires(pre): rpm-helper
249 tmb 343 Requires(pre): coreutils
250 dmorgan 185007 Requires(postun): rpm-helper
251 tmb 343
252 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
253 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
254 dmorgan 185007
255 tmb 343 %description
256     RPM is a powerful command line driven package management system capable of
257     installing, uninstalling, verifying, querying, and updating software packages.
258     Each software package consists of an archive of files along with information
259     about the package like its version, a description, etc.
260    
261 dmorgan 185191 %package -n %librpmbuild
262     Summary: Libraries for building and signing RPM packages
263     Group: System/Libraries
264     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
265     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
266    
267     %description -n %librpmbuild
268     This package contains the RPM shared libraries for building and signing
269     packages.
270    
271     %package -n %librpmsign
272     Summary: Libraries for building and signing RPM packages
273     Group: System/Libraries
274    
275     %description -n %librpmsign
276     This package contains the RPM shared libraries for building and signing
277     packages.
278    
279 tmb 343 %package -n %librpmname
280 tmb 345 Summary: Library used by rpm
281     Group: System/Libraries
282     Provides: librpm = %version-%release
283 tmb 343
284     %description -n %librpmname
285     RPM is a powerful command line driven package management system capable of
286     installing, uninstalling, verifying, querying, and updating software packages.
287     This package contains common files to all applications based on rpm.
288    
289     %package -n %librpmnamedevel
290     Summary: Development files for applications which will manipulate RPM packages
291     Group: Development/C
292     Requires: rpm = %epoch:%{version}-%{release}
293     Provides: librpm-devel = %version-%release
294     Provides: rpm-devel = %version-%release
295 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
296     Requires: %librpmbuild = %epoch:%version-%release
297     Requires: %librpmsign = %epoch:%version-%release
298 tmb 343
299     %description -n %librpmnamedevel
300     This package contains the RPM C library and header files. These
301     development files will simplify the process of writing programs
302     which manipulate RPM packages and databases and are intended to make
303     it easier to create graphical package managers or any other tools
304     that need an intimate knowledge of RPM packages in order to function.
305    
306     This package should be installed if you want to develop programs that
307     will manipulate RPM packages and databases.
308    
309     %package build
310     Summary: Scripts and executable programs used to build packages
311     Group: System/Configuration/Packaging
312     Requires: autoconf
313     Requires: automake
314     Requires: file
315     Requires: gcc-c++
316     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
317 dmorgan 185007 Requires: libtool-base
318     Requires: patch
319 tmb 343 Requires: make
320     Requires: tar
321     Requires: unzip
322     Requires: elfutils
323 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
324 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
325 dmorgan 185007 Requires: perl(YAML::Tiny)
326 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
327 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
328 tmb 343
329     %description build
330     This package contains scripts and executable programs that are used to
331     build packages using RPM.
332    
333 dmorgan 185007 %package sign
334     Summary: Package signing support
335     Group: System/Base
336    
337     %description sign
338     This package contains support for digitally signing RPM packages.
339    
340 tmb 343 %if %buildpython
341     %package -n python-rpm
342     Summary: Python bindings for apps which will manipulate RPM packages
343     Group: Development/Python
344     Requires: rpm = %epoch:%{version}-%{release}
345    
346     %description -n python-rpm
347     The rpm-python package contains a module which permits applications
348     written in the Python programming language to use the interface
349     supplied by RPM (RPM Package Manager) libraries.
350    
351     This package should be installed if you want to develop Python
352     programs that will manipulate RPM packages and databases.
353     %endif
354    
355     %prep
356     %setup -q -n %name-%srcver
357 dmorgan 186388 %apply_patches
358 tmb 343
359     %build
360     autoreconf
361    
362     %if %builddebug
363     RPM_OPT_FLAGS=-g
364     %endif
365 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
366 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
367 fwang 215771 %configure2_5x \
368 tmb 343 --enable-nls \
369     --enable-python \
370     --enable-sqlite3 \
371     --without-javaglue \
372     %if %builddebug
373     --enable-debug \
374     %endif
375 dmorgan 185007 --with-external-db \
376 tmb 343 %if %buildpython
377     --with-python=%{pyver} \
378     %else
379     --without-python \
380     %endif
381 dmorgan 185007 %if ! %buildplugins
382     --disable-plugins \
383     %endif
384 tmb 343 --with-glob \
385     --without-selinux \
386 dmorgan 185007 --without-apidocs \
387     --with-cap
388 tmb 343
389     %make
390    
391     %install
392 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
393 tmb 343
394     make DESTDIR=%buildroot install
395    
396 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
397    
398 tmb 343 # Save list of packages through cron
399     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
400     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
401    
402     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
403     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
404    
405     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
406     for dbi in \
407     Basenames Conflictname Dirnames Group Installtid Name Providename \
408     Provideversion Removetid Requirename Requireversion Triggername \
409 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
410     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
411 tmb 343 do
412     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
413     done
414    
415     test -d doc-copy || mkdir doc-copy
416     rm -rf doc-copy/*
417     ln -f doc/manual/* doc-copy/
418     rm -f doc-copy/Makefile*
419    
420     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
421    
422     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
423     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
424     # Put your own system macros here
425     # usually contains
426    
427     # Set this one according your locales
428     # %%_install_langs
429    
430     EOF
431    
432     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
433    
434 tv 206214 %check
435     make check
436    
437 tmb 343 %pre
438     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
439    
440     rm -rf /usr/lib/rpm/*-mandrake-*
441 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
442 tmb 343
443 tmb 345
444 tmb 343 %post
445     # nuke __db.00? when updating to this rpm
446     rm -f /var/lib/rpm/__db.00?
447    
448 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
449 tmb 343 /bin/rpm --initdb
450     fi
451    
452     %postun
453     /usr/share/rpm-helper/del-user rpm $1 rpm
454    
455     %define rpmattr %attr(0755, rpm, rpm)
456    
457     %files -f %{name}.lang
458     %defattr(-,root,root)
459     %doc GROUPS CHANGES doc/manual/[a-z]*
460     %attr(0755,rpm,rpm) /bin/rpm
461     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
462     %attr(0755, rpm, rpm) %{_bindir}/gendiff
463     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
464 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
465 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
466     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
467     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
468    
469     %dir %{_localstatedir}/spool/repackage
470     %dir %{rpmdir}
471     %dir /etc/rpm
472     %config(noreplace) /etc/rpm/macros
473     %dir /etc/rpm/macros.d
474     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
475     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
476     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
477     %attr(0644, rpm, rpm) %{rpmdir}/macros
478     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
479     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
480     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
481     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
482 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
483     %attr(0755, rpm, rpm) %{rpmdir}/script.req
484 tv 256610 %exclude %{rpmdir}/tcl.req
485 tmb 343
486     %rpmattr %{rpmdir}/rpm2cpio.sh
487     %rpmattr %{rpmdir}/tgpg
488    
489 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
490     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
491    
492 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
493     %ifarch %{ix86} x86_64
494     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
495     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
496     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
497     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
498 rtp 267694 %else
499     %exclude %{rpmdir}/platform/i*86-linux/macros
500     %exclude %{rpmdir}/platform/athlon-linux/macros
501     %exclude %{rpmdir}/platform/pentium*-linux/macros
502     %exclude %{rpmdir}/platform/geode-linux/macros
503 tmb 343 %endif
504     %ifarch x86_64
505     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
506     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
507     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
508 rtp 267694 %else
509     %exclude %{rpmdir}/platform/amd64-linux/macros
510     %exclude %{rpmdir}/platform/ia32e-linux/macros
511     %exclude %{rpmdir}/platform/x86_64-linux/macros
512 tmb 343 %endif
513     %ifarch %arm
514 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
515 tv 256613 %else
516     %exclude %{rpmdir}/platform/arm*/macros
517 tmb 343 %endif
518     %ifarch %mips
519     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
520     %endif
521     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
522 tv 256613 # new in 4.10.0:
523     %exclude %{rpmdir}/platform/alpha*-linux/macros
524     %exclude %{rpmdir}/platform/sparc*-linux/macros
525     %exclude %{rpmdir}/platform/ia64*-linux/macros
526     %exclude %{rpmdir}/platform/ppc*-linux/macros
527     %exclude %{rpmdir}/platform/s390*-linux/macros
528     %exclude %{rpmdir}/platform/sh*-linux/macros
529 tmb 343
530 tv 256613
531    
532 tmb 343 %{_mandir}/man[18]/*.[18]*
533     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
534     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
535     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
536     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
537     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
538     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
539    
540     %config(noreplace,missingok) /etc/cron.daily/rpm
541     %config(noreplace,missingok) /etc/logrotate.d/rpm
542    
543     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
544    
545     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
546    
547     %rpmdbattr /var/lib/rpm/Basenames
548     %rpmdbattr /var/lib/rpm/Conflictname
549     %rpmdbattr /var/lib/rpm/__db.0*
550     %rpmdbattr /var/lib/rpm/Dirnames
551     %rpmdbattr /var/lib/rpm/Group
552     %rpmdbattr /var/lib/rpm/Installtid
553     %rpmdbattr /var/lib/rpm/Name
554 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
555 tmb 343 %rpmdbattr /var/lib/rpm/Packages
556     %rpmdbattr /var/lib/rpm/Providename
557     %rpmdbattr /var/lib/rpm/Provideversion
558     %rpmdbattr /var/lib/rpm/Removetid
559     %rpmdbattr /var/lib/rpm/Requirename
560     %rpmdbattr /var/lib/rpm/Requireversion
561 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
562     %rpmdbattr /var/lib/rpm/Sigmd5
563 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
564    
565     %files build
566     %defattr(-,root,root)
567     %doc CHANGES
568     %doc doc-copy/*
569     %rpmattr %{_bindir}/rpmbuild
570 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
571 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
572     %rpmattr %{_prefix}/lib/rpm/check-files
573     %rpmattr %{_prefix}/lib/rpm/debugedit
574 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
575 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
576     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
577     %rpmattr %{_prefix}/lib/rpm/find-provides
578     %rpmattr %{_prefix}/lib/rpm/find-requires
579 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
580 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
581     %rpmattr %{_prefix}/lib/rpm/perl.prov
582     %rpmattr %{_prefix}/lib/rpm/perl.req
583    
584     %rpmattr %{_prefix}/lib/rpm/check-buildroot
585     %rpmattr %{_prefix}/lib/rpm/check-prereqs
586     %rpmattr %{_prefix}/lib/rpm/check-rpaths
587     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
588     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
589     %rpmattr %{_prefix}/lib/rpm/macros.perl
590     %rpmattr %{_prefix}/lib/rpm/macros.php
591     %rpmattr %{_prefix}/lib/rpm/macros.python
592     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
593     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
594 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
595     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
596 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
597     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
598    
599     %rpmattr %{_prefix}/lib/rpm/rpmdeps
600 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
601 tmb 343
602 tv 255921
603 tmb 343 %{_mandir}/man8/rpmbuild.8*
604     %{_mandir}/man8/rpmdeps.8*
605    
606     %if %buildpython
607     %files -n python-rpm
608     %defattr(-,root,root)
609     %{_libdir}/python*/site-packages/rpm
610     %endif
611    
612     %files -n %librpmname
613     %defattr(-,root,root)
614 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
615     %{_libdir}/librpmio.so.%{libmajor}*
616 dmorgan 185007 %if %{with plugins}
617     %{_libdir}/rpm-plugins
618     %endif
619    
620     %files -n %librpmbuild
621 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
622 tmb 343
623 dmorgan 185007 %files -n %librpmsign
624     %{_libdir}/librpmsign.so.%{libmajorsign}*
625    
626     %files sign
627     %defattr(-,root,root)
628     %{_bindir}/rpmsign
629     %{_mandir}/man8/rpmsign.8*
630    
631 tmb 343 %files -n %librpmnamedevel
632     %defattr(-,root,root)
633     %{_includedir}/rpm
634     %{_libdir}/librpm.so
635     %{_libdir}/librpmio.so
636     %{_libdir}/librpmbuild.so
637 dmorgan 185007 %{_libdir}/librpmsign.so
638 tmb 343 %{_libdir}/pkgconfig/rpm.pc
639 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30