/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 327271 - (hide annotations) (download)
Thu Dec 6 10:27:53 2012 UTC (11 years, 4 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20697 byte(s)
unbreak --setperms (RhBug:881835) (regression introduced in rpm >= 4.10
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 302329 %define rpmversion 4.10.1
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 327195 %define release %mkrel %{?snapver:0.%{snapver}.}6
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
123 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
124 tmb 343
125     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
126     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
127     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
128     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
129     # but this is bad design anyway
130 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
131 tmb 343
132     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
133 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
134 tv 215854 Patch134: extcond.diff
135 tmb 343
136 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
137 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
138     # implementation: as long as debugedit can just overwrite data in the elf
139     # sections things keep relatively easy, but if dest_dir is longer than the
140     # original directory, debugedit would have to expand the whole elf file. Which
141     # might be technically possible but debugedit currently does not even try to."
142 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
143 dmorgan 49378
144 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
145     # with this patch, "#%define foo bar" is a fatal error
146 dmorgan 185007 # Bug still valid => Send upstream for review.
147 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
148 tmb 343
149     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
150 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
151     Patch146: rpm-4.9.1.1-filetriggers.patch
152 tmb 343
153     # add two fatal errors (during package build)
154 dmorgan 185007 # Useful ? to drop ?
155     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
156 tmb 343
157     # (nb: see the patch for more info about this issue)
158 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
159 tmb 343
160 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
161 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
162 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
163 tmb 343
164     Patch1007: rpm-4.6.0-rc3-xz-support.patch
165    
166     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
167     # as this breaks stuff that installs files to $DOCDIR during %%install
168 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
169 tmb 343
170     # Turbolinux patches
171     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
172     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
173    
174 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
175 dmorgan 49378
176 tv 262316 # (tv) fix tests:
177     Patch2100: rpm-4.10.0-fix-testsuite.diff
178 tv 255921
179 tmb 343 Patch3000: mips_macros.patch
180     Patch3001: fix_stack_protector_check.patch
181 tv 256616 Patch3002: mips_define_isa_macros.patch
182     Patch3003: rpm_arm_mips_isa_macros.patch
183     Patch3004: rpm_add_armv5tl.patch
184 tmb 343
185 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
186     # and not full path
187     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
188 tv 223198 #
189 dmorgan 185007 # Fedora patches
190 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
191     #
192 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
193     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
194 tv 327188 # (tv) Compressed debuginfo support (UPSTREAM)::
195 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
196 tv 327188 # (tv) Mini debuginfo support (UPSTREAM)::
197 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
198 tv 327188 # (tv) fix a rpm-4.10 regression (UPSTREAM)::
199 tv 325714 Patch3503: rpm-4.10.1-skipped-hardlinks.patch
200 dmorgan 185007
201 tv 276795 # (tv) merge mga stuff from rpm-setup:
202     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
203 tv 327188 # (tv) enhance debugedit message (UPSTREAM):
204 tv 308048 Patch4001: fix-debugedit-log.diff
205 tv 327195 # (tv) upstream fix for RPMDBI_LABEL (UPSTREAM)::
206     Patch4002: nvra-prep.diff
207 tv 327271 # (tv) Unbreak --setperms (RhBug:881835) (regression introduced in rpm >= 4.10)
208     Patch4003: unbreak--setperms.diff
209 tv 327195
210    
211 dmorgan 185007 License: GPLv2+
212     BuildRequires: autoconf
213 tmb 343 BuildRequires: zlib-devel
214     BuildRequires: bzip2-devel
215 tv 276213 BuildRequires: liblzma-devel >= 5
216 dmorgan 185007 BuildRequires: automake
217 tmb 343 BuildRequires: elfutils-devel
218     BuildRequires: libbeecrypt-devel
219 dmorgan 185007 BuildRequires: ed
220     BuildRequires: gettext-devel
221 tmb 343 BuildRequires: libsqlite3-devel
222 tv 276213 BuildRequires: db5.3-devel
223 tmb 343 BuildRequires: neon-devel
224     BuildRequires: popt-devel
225     BuildRequires: nss-devel
226     BuildRequires: magic-devel
227 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
228 tmb 343 BuildRequires: readline-devel
229     BuildRequires: ncurses-devel
230 dmorgan 185007 BuildRequires: openssl-devel
231 tv 256683 BuildRequires: lua5.1-devel
232 dmorgan 185007 BuildRequires: libcap-devel
233     # Needed for doc
234 tmb 343 #BuildRequires: graphviz
235 dmorgan 185007 BuildRequires: tetex
236 tmb 343 %if %buildpython
237     BuildRequires: python-devel
238     %endif
239 tv 223263 # for testsuite:
240     BuildRequires: fakechroot
241 tmb 343
242     Requires: bzip2 >= 0.9.0c-2
243 tv 302008 Requires: xz
244 tmb 343 Requires: cpio
245     Requires: gawk
246     Requires: glibc >= 2.1.92
247     Requires: mktemp
248 tmb 345 Requires: setup >= 2.2.0-8
249 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
250 tmb 343 Requires: update-alternatives
251     Requires: %librpmname = %epoch:%version-%release
252     URL: http://rpm.org/
253     %define git_url http://rpm.org/git/rpm.git
254 dmorgan 185007 Requires(pre): rpm-helper
255 tmb 343 Requires(pre): coreutils
256 dmorgan 185007 Requires(postun): rpm-helper
257 tmb 343
258 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
259 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
260 dmorgan 185007
261 tmb 343 %description
262     RPM is a powerful command line driven package management system capable of
263     installing, uninstalling, verifying, querying, and updating software packages.
264     Each software package consists of an archive of files along with information
265     about the package like its version, a description, etc.
266    
267 dmorgan 185191 %package -n %librpmbuild
268     Summary: Libraries for building and signing RPM packages
269     Group: System/Libraries
270     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
271     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
272    
273     %description -n %librpmbuild
274     This package contains the RPM shared libraries for building and signing
275     packages.
276    
277     %package -n %librpmsign
278     Summary: Libraries for building and signing RPM packages
279     Group: System/Libraries
280    
281     %description -n %librpmsign
282     This package contains the RPM shared libraries for building and signing
283     packages.
284    
285 tmb 343 %package -n %librpmname
286 tmb 345 Summary: Library used by rpm
287     Group: System/Libraries
288     Provides: librpm = %version-%release
289 tmb 343
290     %description -n %librpmname
291     RPM is a powerful command line driven package management system capable of
292     installing, uninstalling, verifying, querying, and updating software packages.
293     This package contains common files to all applications based on rpm.
294    
295     %package -n %librpmnamedevel
296     Summary: Development files for applications which will manipulate RPM packages
297     Group: Development/C
298     Requires: rpm = %epoch:%{version}-%{release}
299     Provides: librpm-devel = %version-%release
300     Provides: rpm-devel = %version-%release
301 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
302     Requires: %librpmbuild = %epoch:%version-%release
303     Requires: %librpmsign = %epoch:%version-%release
304 tmb 343
305     %description -n %librpmnamedevel
306     This package contains the RPM C library and header files. These
307     development files will simplify the process of writing programs
308     which manipulate RPM packages and databases and are intended to make
309     it easier to create graphical package managers or any other tools
310     that need an intimate knowledge of RPM packages in order to function.
311    
312     This package should be installed if you want to develop programs that
313     will manipulate RPM packages and databases.
314    
315     %package build
316     Summary: Scripts and executable programs used to build packages
317     Group: System/Configuration/Packaging
318     Requires: autoconf
319     Requires: automake
320     Requires: file
321     Requires: gcc-c++
322     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
323 dmorgan 185007 Requires: libtool-base
324     Requires: patch
325 tmb 343 Requires: make
326     Requires: tar
327     Requires: unzip
328     Requires: elfutils
329 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
330 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
331 dmorgan 185007 Requires: perl(YAML::Tiny)
332 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
333 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
334 tmb 343
335     %description build
336     This package contains scripts and executable programs that are used to
337     build packages using RPM.
338    
339 dmorgan 185007 %package sign
340     Summary: Package signing support
341     Group: System/Base
342    
343     %description sign
344     This package contains support for digitally signing RPM packages.
345    
346 tmb 343 %if %buildpython
347     %package -n python-rpm
348     Summary: Python bindings for apps which will manipulate RPM packages
349     Group: Development/Python
350     Requires: rpm = %epoch:%{version}-%{release}
351    
352     %description -n python-rpm
353     The rpm-python package contains a module which permits applications
354     written in the Python programming language to use the interface
355     supplied by RPM (RPM Package Manager) libraries.
356    
357     This package should be installed if you want to develop Python
358     programs that will manipulate RPM packages and databases.
359     %endif
360    
361     %prep
362     %setup -q -n %name-%srcver
363 dmorgan 186388 %apply_patches
364 tmb 343
365     %build
366     autoreconf
367    
368     %if %builddebug
369     RPM_OPT_FLAGS=-g
370     %endif
371 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
372 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
373 fwang 215771 %configure2_5x \
374 tmb 343 --enable-nls \
375     --enable-python \
376     --enable-sqlite3 \
377     --without-javaglue \
378     %if %builddebug
379     --enable-debug \
380     %endif
381 dmorgan 185007 --with-external-db \
382 tmb 343 %if %buildpython
383     --with-python=%{pyver} \
384     %else
385     --without-python \
386     %endif
387 dmorgan 185007 %if ! %buildplugins
388     --disable-plugins \
389     %endif
390 tmb 343 --with-glob \
391     --without-selinux \
392 dmorgan 185007 --without-apidocs \
393     --with-cap
394 tmb 343
395     %make
396    
397     %install
398 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
399 tmb 343
400     make DESTDIR=%buildroot install
401    
402 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
403    
404 tmb 343 # Save list of packages through cron
405     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
406     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
407    
408     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
409     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
410    
411     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
412     for dbi in \
413     Basenames Conflictname Dirnames Group Installtid Name Providename \
414     Provideversion Removetid Requirename Requireversion Triggername \
415 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
416     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
417 tmb 343 do
418     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
419     done
420    
421     test -d doc-copy || mkdir doc-copy
422     rm -rf doc-copy/*
423     ln -f doc/manual/* doc-copy/
424     rm -f doc-copy/Makefile*
425    
426     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
427    
428     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
429     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
430     # Put your own system macros here
431     # usually contains
432    
433     # Set this one according your locales
434     # %%_install_langs
435    
436     EOF
437    
438     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
439    
440 tv 206214 %check
441     make check
442    
443 tmb 343 %pre
444     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
445    
446     rm -rf /usr/lib/rpm/*-mandrake-*
447 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
448 tmb 343
449 tmb 345
450 tmb 343 %post
451     # nuke __db.00? when updating to this rpm
452     rm -f /var/lib/rpm/__db.00?
453    
454 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
455 tmb 343 /bin/rpm --initdb
456     fi
457    
458     %postun
459     /usr/share/rpm-helper/del-user rpm $1 rpm
460    
461     %define rpmattr %attr(0755, rpm, rpm)
462    
463     %files -f %{name}.lang
464     %defattr(-,root,root)
465     %doc GROUPS CHANGES doc/manual/[a-z]*
466     %attr(0755,rpm,rpm) /bin/rpm
467     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
468     %attr(0755, rpm, rpm) %{_bindir}/gendiff
469     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
470 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
471 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
472     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
473     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
474    
475     %dir %{_localstatedir}/spool/repackage
476     %dir %{rpmdir}
477     %dir /etc/rpm
478     %config(noreplace) /etc/rpm/macros
479     %dir /etc/rpm/macros.d
480     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
481     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
482     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
483     %attr(0644, rpm, rpm) %{rpmdir}/macros
484     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
485     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
486     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
487     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
488 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
489     %attr(0755, rpm, rpm) %{rpmdir}/script.req
490 tv 256610 %exclude %{rpmdir}/tcl.req
491 tmb 343
492     %rpmattr %{rpmdir}/rpm2cpio.sh
493     %rpmattr %{rpmdir}/tgpg
494    
495 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
496     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
497    
498 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
499     %ifarch %{ix86} x86_64
500     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
501     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
503     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
504 rtp 267694 %else
505     %exclude %{rpmdir}/platform/i*86-linux/macros
506     %exclude %{rpmdir}/platform/athlon-linux/macros
507     %exclude %{rpmdir}/platform/pentium*-linux/macros
508     %exclude %{rpmdir}/platform/geode-linux/macros
509 tmb 343 %endif
510     %ifarch x86_64
511     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
513     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
514 rtp 267694 %else
515     %exclude %{rpmdir}/platform/amd64-linux/macros
516     %exclude %{rpmdir}/platform/ia32e-linux/macros
517     %exclude %{rpmdir}/platform/x86_64-linux/macros
518 tmb 343 %endif
519     %ifarch %arm
520 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
521 tv 256613 %else
522     %exclude %{rpmdir}/platform/arm*/macros
523 tmb 343 %endif
524     %ifarch %mips
525     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
526     %endif
527     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
528 tv 256613 # new in 4.10.0:
529     %exclude %{rpmdir}/platform/alpha*-linux/macros
530     %exclude %{rpmdir}/platform/sparc*-linux/macros
531     %exclude %{rpmdir}/platform/ia64*-linux/macros
532     %exclude %{rpmdir}/platform/ppc*-linux/macros
533     %exclude %{rpmdir}/platform/s390*-linux/macros
534     %exclude %{rpmdir}/platform/sh*-linux/macros
535 tmb 343
536 tv 256613
537    
538 tmb 343 %{_mandir}/man[18]/*.[18]*
539     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
540     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
541     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
542     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
543     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
544     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
545    
546     %config(noreplace,missingok) /etc/cron.daily/rpm
547     %config(noreplace,missingok) /etc/logrotate.d/rpm
548    
549     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
550    
551     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
552    
553     %rpmdbattr /var/lib/rpm/Basenames
554     %rpmdbattr /var/lib/rpm/Conflictname
555     %rpmdbattr /var/lib/rpm/__db.0*
556     %rpmdbattr /var/lib/rpm/Dirnames
557     %rpmdbattr /var/lib/rpm/Group
558     %rpmdbattr /var/lib/rpm/Installtid
559     %rpmdbattr /var/lib/rpm/Name
560 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
561 tmb 343 %rpmdbattr /var/lib/rpm/Packages
562     %rpmdbattr /var/lib/rpm/Providename
563     %rpmdbattr /var/lib/rpm/Provideversion
564     %rpmdbattr /var/lib/rpm/Removetid
565     %rpmdbattr /var/lib/rpm/Requirename
566     %rpmdbattr /var/lib/rpm/Requireversion
567 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
568     %rpmdbattr /var/lib/rpm/Sigmd5
569 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
570    
571     %files build
572     %defattr(-,root,root)
573     %doc CHANGES
574     %doc doc-copy/*
575     %rpmattr %{_bindir}/rpmbuild
576 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
577 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
578     %rpmattr %{_prefix}/lib/rpm/check-files
579     %rpmattr %{_prefix}/lib/rpm/debugedit
580 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
581 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
582     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
583     %rpmattr %{_prefix}/lib/rpm/find-provides
584     %rpmattr %{_prefix}/lib/rpm/find-requires
585 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
586 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
587     %rpmattr %{_prefix}/lib/rpm/perl.prov
588     %rpmattr %{_prefix}/lib/rpm/perl.req
589    
590     %rpmattr %{_prefix}/lib/rpm/check-buildroot
591     %rpmattr %{_prefix}/lib/rpm/check-prereqs
592     %rpmattr %{_prefix}/lib/rpm/check-rpaths
593     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
594     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
595     %rpmattr %{_prefix}/lib/rpm/macros.perl
596     %rpmattr %{_prefix}/lib/rpm/macros.php
597     %rpmattr %{_prefix}/lib/rpm/macros.python
598     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
599     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
600 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
601     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
602 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
603     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
604    
605     %rpmattr %{_prefix}/lib/rpm/rpmdeps
606 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
607 tmb 343
608 tv 255921
609 tmb 343 %{_mandir}/man8/rpmbuild.8*
610     %{_mandir}/man8/rpmdeps.8*
611    
612     %if %buildpython
613     %files -n python-rpm
614     %defattr(-,root,root)
615     %{_libdir}/python*/site-packages/rpm
616     %endif
617    
618     %files -n %librpmname
619     %defattr(-,root,root)
620 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
621     %{_libdir}/librpmio.so.%{libmajor}*
622 dmorgan 185007 %if %{with plugins}
623     %{_libdir}/rpm-plugins
624     %endif
625    
626     %files -n %librpmbuild
627 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
628 tmb 343
629 dmorgan 185007 %files -n %librpmsign
630     %{_libdir}/librpmsign.so.%{libmajorsign}*
631    
632     %files sign
633     %defattr(-,root,root)
634     %{_bindir}/rpmsign
635     %{_mandir}/man8/rpmsign.8*
636    
637 tmb 343 %files -n %librpmnamedevel
638     %defattr(-,root,root)
639     %{_includedir}/rpm
640     %{_libdir}/librpm.so
641     %{_libdir}/librpmio.so
642     %{_libdir}/librpmbuild.so
643 dmorgan 185007 %{_libdir}/librpmsign.so
644 tmb 343 %{_libdir}/pkgconfig/rpm.pc
645 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30