/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 389213 - (hide annotations) (download)
Thu Jan 17 21:29:26 2013 UTC (11 years, 3 months ago) by pterjan
Original Path: obsolete/cauldron/rpm/current/SPECS/rpm.spec
File size: 20513 byte(s)
Drop 
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 332065 %define snapver beta1
51     %define rpmversion 4.11.0
52 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
53 tv 264614 %define libver 4.10
54 tv 255921 %define libmajor 3
55     %define libmajorsign 1
56 umeabot 380447 %define release %mkrel %{?snapver:0.%{snapver}.}8
57 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
58 tmb 345 %define librpmnamedevel %mklibname -d rpm
59 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
60     %define librpmbuild %mklibname rpmbuild %{libmajor}
61 tmb 343
62     %define buildpython 1
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71 dmorgan 186381 # disable plugins initially
72 dmorgan 185007 %define buildplugins 0
73     %{?_with_plugins:%define buildplugins 1}
74    
75 tmb 343 Summary: The RPM package management system
76     Name: rpm
77     Epoch: 1
78 dmorgan 185007 Version: %{rpmversion}
79 dmorgan 49378 Release: %{release}
80 tmb 343 Group: System/Configuration/Packaging
81     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
82 dmorgan 185007 # Add some undocumented feature to gendiff
83     # Send upstream ? drop ?
84     Patch17: rpm-4.4.2.2-gendiff-improved.patch
85 tmb 343
86     # if %post of foo-2 fails,
87     # or if %preun of foo-1 fails,
88     # or if %postun of foo-1 fails,
89     # => foo-1 is not removed, so we end up with both packages in rpmdb
90     # this patch makes rpm ignore the error in those cases
91 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
92 tmb 343 #
93     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
94     # scripts is ignored with or without this patch)
95 tv 262316 # Needed for urpmi testsuite:
96 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
97 tmb 343
98 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
99 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
100 tmb 343
101 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
102     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
103 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
104     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
105 blino 25212
106 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
107     # From popular request, we allow to do this
108 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
109     Patch70: rpm-4.9.1-bb-shortcircuit.patch
110 tmb 343
111     # don't conflict for doc files
112     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
113 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
114 tmb 343
115     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
116     # (is this working??)
117     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
118    
119     # Fix diff issue when buildroot contains some "//"
120 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
121 tmb 343
122     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
123 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
124 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
125 tmb 343
126     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
127     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
128     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
129     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
130     # but this is bad design anyway
131 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
132 tmb 343
133     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
134 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
135 tv 215854 Patch134: extcond.diff
136 tmb 343
137 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
138 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
139     # implementation: as long as debugedit can just overwrite data in the elf
140     # sections things keep relatively easy, but if dest_dir is longer than the
141     # original directory, debugedit would have to expand the whole elf file. Which
142     # might be technically possible but debugedit currently does not even try to."
143 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
144 dmorgan 49378
145 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
146     # with this patch, "#%define foo bar" is a fatal error
147 dmorgan 185007 # Bug still valid => Send upstream for review.
148 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
149 tmb 343
150     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
151 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
152     Patch146: rpm-4.9.1.1-filetriggers.patch
153 tmb 343
154     # add two fatal errors (during package build)
155 dmorgan 185007 # Useful ? to drop ?
156     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
157 tmb 343
158     # (nb: see the patch for more info about this issue)
159 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
160 tmb 343
161 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
162 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
163 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
164 tmb 343
165     Patch1007: rpm-4.6.0-rc3-xz-support.patch
166    
167     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
168     # as this breaks stuff that installs files to $DOCDIR during %%install
169 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
170 tmb 343
171     # Turbolinux patches
172     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
173     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
174    
175 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
176 dmorgan 49378
177 tv 262316 # (tv) fix tests:
178     Patch2100: rpm-4.10.0-fix-testsuite.diff
179 tv 255921
180 tmb 343 Patch3000: mips_macros.patch
181 tv 256616 Patch3002: mips_define_isa_macros.patch
182     Patch3003: rpm_arm_mips_isa_macros.patch
183     Patch3004: rpm_add_armv5tl.patch
184 tmb 343
185 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
186     # and not full path
187     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
188 tv 223198 #
189 dmorgan 185007 # Fedora patches
190 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
191     #
192 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
193     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
194 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
195 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
196 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
197 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
198 dmorgan 185007
199 tv 276795 # (tv) merge mga stuff from rpm-setup:
200     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
201 tv 332643 # (tv) fix unknow macro option error message (UPSTREAM):
202 tv 332065 Patch4004: 0001-display-the-actual-unknown-option-instead-of.patch
203 tv 332323 # (tv) fix aborting when ordering empty transactions:
204     Patch4006: fix-order-on-empty-transactions.diff
205 tv 327195
206    
207 dmorgan 185007 License: GPLv2+
208     BuildRequires: autoconf
209 tmb 343 BuildRequires: zlib-devel
210     BuildRequires: bzip2-devel
211 tv 276213 BuildRequires: liblzma-devel >= 5
212 dmorgan 185007 BuildRequires: automake
213 tmb 343 BuildRequires: elfutils-devel
214     BuildRequires: libbeecrypt-devel
215 dmorgan 185007 BuildRequires: ed
216     BuildRequires: gettext-devel
217 tmb 343 BuildRequires: libsqlite3-devel
218 tv 276213 BuildRequires: db5.3-devel
219 tmb 343 BuildRequires: neon-devel
220     BuildRequires: popt-devel
221     BuildRequires: nss-devel
222     BuildRequires: magic-devel
223 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
224 tmb 343 BuildRequires: readline-devel
225     BuildRequires: ncurses-devel
226 dmorgan 185007 BuildRequires: openssl-devel
227 tv 256683 BuildRequires: lua5.1-devel
228 dmorgan 185007 BuildRequires: libcap-devel
229     # Needed for doc
230 tmb 343 #BuildRequires: graphviz
231 dmorgan 185007 BuildRequires: tetex
232 tmb 343 %if %buildpython
233     BuildRequires: python-devel
234     %endif
235 tv 223263 # for testsuite:
236     BuildRequires: fakechroot
237 tmb 343
238     Requires: bzip2 >= 0.9.0c-2
239 tv 302008 Requires: xz
240 tmb 343 Requires: cpio
241     Requires: gawk
242     Requires: glibc >= 2.1.92
243     Requires: mktemp
244 tmb 345 Requires: setup >= 2.2.0-8
245 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
246 tmb 343 Requires: update-alternatives
247     Requires: %librpmname = %epoch:%version-%release
248     URL: http://rpm.org/
249     %define git_url http://rpm.org/git/rpm.git
250 dmorgan 185007 Requires(pre): rpm-helper
251 tmb 343 Requires(pre): coreutils
252 dmorgan 185007 Requires(postun): rpm-helper
253 tmb 343
254 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
255 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
256 dmorgan 185007
257 tmb 343 %description
258     RPM is a powerful command line driven package management system capable of
259     installing, uninstalling, verifying, querying, and updating software packages.
260     Each software package consists of an archive of files along with information
261     about the package like its version, a description, etc.
262    
263 dmorgan 185191 %package -n %librpmbuild
264     Summary: Libraries for building and signing RPM packages
265     Group: System/Libraries
266 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
267 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
268    
269     %description -n %librpmbuild
270     This package contains the RPM shared libraries for building and signing
271     packages.
272    
273     %package -n %librpmsign
274     Summary: Libraries for building and signing RPM packages
275     Group: System/Libraries
276    
277     %description -n %librpmsign
278     This package contains the RPM shared libraries for building and signing
279     packages.
280    
281 tmb 343 %package -n %librpmname
282 tmb 345 Summary: Library used by rpm
283     Group: System/Libraries
284     Provides: librpm = %version-%release
285 tmb 343
286     %description -n %librpmname
287     RPM is a powerful command line driven package management system capable of
288     installing, uninstalling, verifying, querying, and updating software packages.
289     This package contains common files to all applications based on rpm.
290    
291     %package -n %librpmnamedevel
292     Summary: Development files for applications which will manipulate RPM packages
293     Group: Development/C
294     Requires: rpm = %epoch:%{version}-%{release}
295     Provides: librpm-devel = %version-%release
296     Provides: rpm-devel = %version-%release
297 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
298     Requires: %librpmbuild = %epoch:%version-%release
299     Requires: %librpmsign = %epoch:%version-%release
300 tmb 343
301     %description -n %librpmnamedevel
302     This package contains the RPM C library and header files. These
303     development files will simplify the process of writing programs
304     which manipulate RPM packages and databases and are intended to make
305     it easier to create graphical package managers or any other tools
306     that need an intimate knowledge of RPM packages in order to function.
307    
308     This package should be installed if you want to develop programs that
309     will manipulate RPM packages and databases.
310    
311     %package build
312     Summary: Scripts and executable programs used to build packages
313     Group: System/Configuration/Packaging
314     Requires: autoconf
315     Requires: automake
316     Requires: file
317     Requires: gcc-c++
318     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
319 dmorgan 185007 Requires: libtool-base
320     Requires: patch
321 tmb 343 Requires: make
322     Requires: tar
323     Requires: unzip
324     Requires: elfutils
325 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
326 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
327 dmorgan 185007 Requires: perl(YAML::Tiny)
328 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
329 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
330 tmb 343
331     %description build
332     This package contains scripts and executable programs that are used to
333     build packages using RPM.
334    
335 dmorgan 185007 %package sign
336     Summary: Package signing support
337     Group: System/Base
338    
339     %description sign
340     This package contains support for digitally signing RPM packages.
341    
342 tmb 343 %if %buildpython
343     %package -n python-rpm
344     Summary: Python bindings for apps which will manipulate RPM packages
345     Group: Development/Python
346     Requires: rpm = %epoch:%{version}-%{release}
347    
348     %description -n python-rpm
349     The rpm-python package contains a module which permits applications
350     written in the Python programming language to use the interface
351     supplied by RPM (RPM Package Manager) libraries.
352    
353     This package should be installed if you want to develop Python
354     programs that will manipulate RPM packages and databases.
355     %endif
356    
357     %prep
358     %setup -q -n %name-%srcver
359 dmorgan 186388 %apply_patches
360 tmb 343
361     %build
362     autoreconf
363    
364     %if %builddebug
365     RPM_OPT_FLAGS=-g
366     %endif
367 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
368 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
369 fwang 215771 %configure2_5x \
370 tmb 343 --enable-nls \
371     --enable-python \
372     --enable-sqlite3 \
373     --without-javaglue \
374     %if %builddebug
375     --enable-debug \
376     %endif
377 dmorgan 185007 --with-external-db \
378 tmb 343 %if %buildpython
379     --with-python=%{pyver} \
380     %else
381     --without-python \
382     %endif
383 dmorgan 185007 %if ! %buildplugins
384     --disable-plugins \
385     %endif
386 tmb 343 --with-glob \
387     --without-selinux \
388 dmorgan 185007 --without-apidocs \
389     --with-cap
390 tmb 343
391     %make
392    
393     %install
394 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
395 tmb 343
396     make DESTDIR=%buildroot install
397    
398 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
399    
400 tmb 343 # Save list of packages through cron
401     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
402     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
403    
404     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
405     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
406    
407     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
408     for dbi in \
409     Basenames Conflictname Dirnames Group Installtid Name Providename \
410     Provideversion Removetid Requirename Requireversion Triggername \
411 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
412     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
413 tmb 343 do
414     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
415     done
416    
417     test -d doc-copy || mkdir doc-copy
418     rm -rf doc-copy/*
419     ln -f doc/manual/* doc-copy/
420     rm -f doc-copy/Makefile*
421    
422     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
423    
424     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
425     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
426     # Put your own system macros here
427     # usually contains
428    
429     # Set this one according your locales
430     # %%_install_langs
431    
432     EOF
433    
434     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
435    
436 tv 206214 %check
437     make check
438    
439 tmb 343 %pre
440     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
441    
442     rm -rf /usr/lib/rpm/*-mandrake-*
443 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
444 tmb 343
445 tmb 345
446 tmb 343 %post
447     # nuke __db.00? when updating to this rpm
448     rm -f /var/lib/rpm/__db.00?
449    
450 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
451 tmb 343 /bin/rpm --initdb
452     fi
453    
454     %postun
455     /usr/share/rpm-helper/del-user rpm $1 rpm
456    
457     %define rpmattr %attr(0755, rpm, rpm)
458    
459     %files -f %{name}.lang
460     %defattr(-,root,root)
461     %doc GROUPS CHANGES doc/manual/[a-z]*
462     %attr(0755,rpm,rpm) /bin/rpm
463     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
464     %attr(0755, rpm, rpm) %{_bindir}/gendiff
465     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
466 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
467 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
468     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
469     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
470    
471     %dir %{_localstatedir}/spool/repackage
472     %dir %{rpmdir}
473     %dir /etc/rpm
474     %config(noreplace) /etc/rpm/macros
475     %dir /etc/rpm/macros.d
476     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
477     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
478     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
479     %attr(0644, rpm, rpm) %{rpmdir}/macros
480     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
481     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
482     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
483     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
484 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
485     %attr(0755, rpm, rpm) %{rpmdir}/script.req
486 tv 256610 %exclude %{rpmdir}/tcl.req
487 tmb 343
488     %rpmattr %{rpmdir}/rpm2cpio.sh
489     %rpmattr %{rpmdir}/tgpg
490    
491 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
492     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
493    
494 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
495     %ifarch %{ix86} x86_64
496     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
497     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
498     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
499     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
500 rtp 267694 %else
501     %exclude %{rpmdir}/platform/i*86-linux/macros
502     %exclude %{rpmdir}/platform/athlon-linux/macros
503     %exclude %{rpmdir}/platform/pentium*-linux/macros
504     %exclude %{rpmdir}/platform/geode-linux/macros
505 tmb 343 %endif
506     %ifarch x86_64
507     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
508     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
509     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
510 rtp 267694 %else
511     %exclude %{rpmdir}/platform/amd64-linux/macros
512     %exclude %{rpmdir}/platform/ia32e-linux/macros
513     %exclude %{rpmdir}/platform/x86_64-linux/macros
514 tmb 343 %endif
515     %ifarch %arm
516 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
517 tv 256613 %else
518     %exclude %{rpmdir}/platform/arm*/macros
519 tmb 343 %endif
520     %ifarch %mips
521     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
522     %endif
523     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
524 tv 256613 # new in 4.10.0:
525     %exclude %{rpmdir}/platform/alpha*-linux/macros
526     %exclude %{rpmdir}/platform/sparc*-linux/macros
527     %exclude %{rpmdir}/platform/ia64*-linux/macros
528     %exclude %{rpmdir}/platform/ppc*-linux/macros
529     %exclude %{rpmdir}/platform/s390*-linux/macros
530     %exclude %{rpmdir}/platform/sh*-linux/macros
531 tmb 343
532 tv 256613
533    
534 tmb 343 %{_mandir}/man[18]/*.[18]*
535     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
536     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
537     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
538     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
539     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
540     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
541    
542     %config(noreplace,missingok) /etc/cron.daily/rpm
543     %config(noreplace,missingok) /etc/logrotate.d/rpm
544    
545     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
546    
547     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
548    
549     %rpmdbattr /var/lib/rpm/Basenames
550     %rpmdbattr /var/lib/rpm/Conflictname
551     %rpmdbattr /var/lib/rpm/__db.0*
552     %rpmdbattr /var/lib/rpm/Dirnames
553     %rpmdbattr /var/lib/rpm/Group
554     %rpmdbattr /var/lib/rpm/Installtid
555     %rpmdbattr /var/lib/rpm/Name
556 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
557 tmb 343 %rpmdbattr /var/lib/rpm/Packages
558     %rpmdbattr /var/lib/rpm/Providename
559     %rpmdbattr /var/lib/rpm/Provideversion
560     %rpmdbattr /var/lib/rpm/Removetid
561     %rpmdbattr /var/lib/rpm/Requirename
562     %rpmdbattr /var/lib/rpm/Requireversion
563 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
564     %rpmdbattr /var/lib/rpm/Sigmd5
565 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
566    
567     %files build
568     %defattr(-,root,root)
569     %doc CHANGES
570     %doc doc-copy/*
571     %rpmattr %{_bindir}/rpmbuild
572 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
573 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
574     %rpmattr %{_prefix}/lib/rpm/check-files
575     %rpmattr %{_prefix}/lib/rpm/debugedit
576 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
577 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
578     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
579     %rpmattr %{_prefix}/lib/rpm/find-provides
580     %rpmattr %{_prefix}/lib/rpm/find-requires
581 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
582 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
583     %rpmattr %{_prefix}/lib/rpm/perl.prov
584     %rpmattr %{_prefix}/lib/rpm/perl.req
585    
586     %rpmattr %{_prefix}/lib/rpm/check-buildroot
587     %rpmattr %{_prefix}/lib/rpm/check-prereqs
588     %rpmattr %{_prefix}/lib/rpm/check-rpaths
589     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
590     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
591     %rpmattr %{_prefix}/lib/rpm/macros.perl
592     %rpmattr %{_prefix}/lib/rpm/macros.php
593     %rpmattr %{_prefix}/lib/rpm/macros.python
594     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
595     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
596 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
597     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
598 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
599     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
600    
601     %rpmattr %{_prefix}/lib/rpm/rpmdeps
602 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
603 tmb 343
604 tv 255921
605 tmb 343 %{_mandir}/man8/rpmbuild.8*
606     %{_mandir}/man8/rpmdeps.8*
607    
608     %if %buildpython
609     %files -n python-rpm
610     %defattr(-,root,root)
611     %{_libdir}/python*/site-packages/rpm
612     %endif
613    
614     %files -n %librpmname
615     %defattr(-,root,root)
616 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
617     %{_libdir}/librpmio.so.%{libmajor}*
618 dmorgan 185007 %if %{with plugins}
619     %{_libdir}/rpm-plugins
620     %endif
621    
622     %files -n %librpmbuild
623 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
624 tmb 343
625 dmorgan 185007 %files -n %librpmsign
626     %{_libdir}/librpmsign.so.%{libmajorsign}*
627    
628     %files sign
629     %defattr(-,root,root)
630     %{_bindir}/rpmsign
631     %{_mandir}/man8/rpmsign.8*
632    
633 tmb 343 %files -n %librpmnamedevel
634     %defattr(-,root,root)
635     %{_includedir}/rpm
636     %{_libdir}/librpm.so
637     %{_libdir}/librpmio.so
638     %{_libdir}/librpmbuild.so
639 dmorgan 185007 %{_libdir}/librpmsign.so
640 tmb 343 %{_libdir}/pkgconfig/rpm.pc
641 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30