/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 441933 - (hide annotations) (download)
Tue Jun 11 10:03:07 2013 UTC (10 years, 9 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20627 byte(s)
patch 1000: fix an upstream regression
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 441832 %define snapver rc1
51     %define rpmversion 4.11.1
52 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
53 tv 264614 %define libver 4.10
54 tv 255921 %define libmajor 3
55     %define libmajorsign 1
56 tv 441933 %define release %mkrel %{?snapver:0.%{snapver}.}3
57 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
58 tmb 345 %define librpmnamedevel %mklibname -d rpm
59 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
60     %define librpmbuild %mklibname rpmbuild %{libmajor}
61 tmb 343
62     %define buildpython 1
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71 dmorgan 186381 # disable plugins initially
72 dmorgan 185007 %define buildplugins 0
73     %{?_with_plugins:%define buildplugins 1}
74    
75 tmb 343 Summary: The RPM package management system
76     Name: rpm
77     Epoch: 1
78 dmorgan 185007 Version: %{rpmversion}
79 dmorgan 49378 Release: %{release}
80 fwang 390713 Group: System/Packaging
81 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
82 dmorgan 185007 # Add some undocumented feature to gendiff
83     # Send upstream ? drop ?
84     Patch17: rpm-4.4.2.2-gendiff-improved.patch
85 tmb 343
86     # if %post of foo-2 fails,
87     # or if %preun of foo-1 fails,
88     # or if %postun of foo-1 fails,
89     # => foo-1 is not removed, so we end up with both packages in rpmdb
90     # this patch makes rpm ignore the error in those cases
91 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
92 tmb 343 #
93     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
94     # scripts is ignored with or without this patch)
95 tv 262316 # Needed for urpmi testsuite:
96 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
97 tmb 343
98 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
99 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
100 tmb 343
101 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
102     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
103 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
104     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
105 blino 25212
106 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
107     # From popular request, we allow to do this
108 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
109     Patch70: rpm-4.9.1-bb-shortcircuit.patch
110 tmb 343
111     # don't conflict for doc files
112     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
113 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
114 tmb 343
115     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
116     # (is this working??)
117     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
118    
119     # Fix diff issue when buildroot contains some "//"
120 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
121 tmb 343
122     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
123 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
124 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
125 tmb 343
126     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
127     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
128     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
129     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
130     # but this is bad design anyway
131 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
132 tmb 343
133     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
134 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
135 tv 215854 Patch134: extcond.diff
136 tmb 343
137 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
138 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
139     # implementation: as long as debugedit can just overwrite data in the elf
140     # sections things keep relatively easy, but if dest_dir is longer than the
141     # original directory, debugedit would have to expand the whole elf file. Which
142     # might be technically possible but debugedit currently does not even try to."
143 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
144 dmorgan 49378
145 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
146     # with this patch, "#%define foo bar" is a fatal error
147 dmorgan 185007 # Bug still valid => Send upstream for review.
148 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
149 tmb 343
150     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
151 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
152     Patch146: rpm-4.9.1.1-filetriggers.patch
153 tmb 343
154     # add two fatal errors (during package build)
155 dmorgan 185007 # Useful ? to drop ?
156     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
157 tmb 343
158     # (nb: see the patch for more info about this issue)
159 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
160 tmb 343
161 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
162 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
163 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
164 tmb 343
165     Patch1007: rpm-4.6.0-rc3-xz-support.patch
166    
167     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
168     # as this breaks stuff that installs files to $DOCDIR during %%install
169 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
170 tmb 343
171 tv 441933 # Fedora patches
172     # Fix 4.11.1~rc1 regression (UPSTREAM):
173     Patch1000: rpm-4.11.1-rc1-lookup-mainpkg.patch
174    
175 tmb 343 # Turbolinux patches
176     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
177     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
178    
179 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
180 dmorgan 49378
181 tv 262316 # (tv) fix tests:
182 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
183 tv 255921
184 tmb 343 Patch3000: mips_macros.patch
185 tv 256616 Patch3002: mips_define_isa_macros.patch
186     Patch3003: rpm_arm_mips_isa_macros.patch
187     Patch3004: rpm_add_armv5tl.patch
188 tmb 343
189 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
190     # and not full path
191 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
192 tv 223198 #
193 dmorgan 185007 # Fedora patches
194 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
195     #
196 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
197     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
198 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
199 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
200 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
201 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
202 dmorgan 185007
203 tv 276795 # (tv) merge mga stuff from rpm-setup:
204     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
205 tv 332323 # (tv) fix aborting when ordering empty transactions:
206     Patch4006: fix-order-on-empty-transactions.diff
207 tv 327195
208    
209 dmorgan 185007 License: GPLv2+
210     BuildRequires: autoconf
211 tmb 343 BuildRequires: zlib-devel
212     BuildRequires: bzip2-devel
213 tv 276213 BuildRequires: liblzma-devel >= 5
214 dmorgan 185007 BuildRequires: automake
215 tmb 343 BuildRequires: elfutils-devel
216     BuildRequires: libbeecrypt-devel
217 dmorgan 185007 BuildRequires: ed
218     BuildRequires: gettext-devel
219 tmb 343 BuildRequires: libsqlite3-devel
220 tv 276213 BuildRequires: db5.3-devel
221 tmb 343 BuildRequires: neon-devel
222     BuildRequires: popt-devel
223     BuildRequires: nss-devel
224     BuildRequires: magic-devel
225 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
226 tmb 343 BuildRequires: readline-devel
227     BuildRequires: ncurses-devel
228 dmorgan 185007 BuildRequires: openssl-devel
229 tv 256683 BuildRequires: lua5.1-devel
230 dmorgan 185007 BuildRequires: libcap-devel
231     # Needed for doc
232 tmb 343 #BuildRequires: graphviz
233 dmorgan 185007 BuildRequires: tetex
234 tmb 343 %if %buildpython
235     BuildRequires: python-devel
236     %endif
237 tv 223263 # for testsuite:
238     BuildRequires: fakechroot
239 tmb 343
240     Requires: bzip2 >= 0.9.0c-2
241 tv 302008 Requires: xz
242 tmb 343 Requires: cpio
243     Requires: gawk
244     Requires: glibc >= 2.1.92
245     Requires: mktemp
246 tmb 345 Requires: setup >= 2.2.0-8
247 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
248 tmb 343 Requires: update-alternatives
249     Requires: %librpmname = %epoch:%version-%release
250     URL: http://rpm.org/
251     %define git_url http://rpm.org/git/rpm.git
252 dmorgan 185007 Requires(pre): rpm-helper
253 tmb 343 Requires(pre): coreutils
254 dmorgan 185007 Requires(postun): rpm-helper
255 tmb 343
256 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
257 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
258 dmorgan 185007
259 tmb 343 %description
260     RPM is a powerful command line driven package management system capable of
261     installing, uninstalling, verifying, querying, and updating software packages.
262     Each software package consists of an archive of files along with information
263     about the package like its version, a description, etc.
264    
265 dmorgan 185191 %package -n %librpmbuild
266     Summary: Libraries for building and signing RPM packages
267     Group: System/Libraries
268 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
269 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
270    
271     %description -n %librpmbuild
272     This package contains the RPM shared libraries for building and signing
273     packages.
274    
275     %package -n %librpmsign
276     Summary: Libraries for building and signing RPM packages
277     Group: System/Libraries
278    
279     %description -n %librpmsign
280     This package contains the RPM shared libraries for building and signing
281     packages.
282    
283 tmb 343 %package -n %librpmname
284 tmb 345 Summary: Library used by rpm
285     Group: System/Libraries
286     Provides: librpm = %version-%release
287 tmb 343
288     %description -n %librpmname
289     RPM is a powerful command line driven package management system capable of
290     installing, uninstalling, verifying, querying, and updating software packages.
291     This package contains common files to all applications based on rpm.
292    
293     %package -n %librpmnamedevel
294     Summary: Development files for applications which will manipulate RPM packages
295     Group: Development/C
296     Requires: rpm = %epoch:%{version}-%{release}
297     Provides: librpm-devel = %version-%release
298     Provides: rpm-devel = %version-%release
299 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
300     Requires: %librpmbuild = %epoch:%version-%release
301     Requires: %librpmsign = %epoch:%version-%release
302 tmb 343
303     %description -n %librpmnamedevel
304     This package contains the RPM C library and header files. These
305     development files will simplify the process of writing programs
306     which manipulate RPM packages and databases and are intended to make
307     it easier to create graphical package managers or any other tools
308     that need an intimate knowledge of RPM packages in order to function.
309    
310     This package should be installed if you want to develop programs that
311     will manipulate RPM packages and databases.
312    
313     %package build
314     Summary: Scripts and executable programs used to build packages
315 fwang 390713 Group: System/Packaging
316 tmb 343 Requires: autoconf
317     Requires: automake
318     Requires: file
319     Requires: gcc-c++
320     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
321 dmorgan 185007 Requires: libtool-base
322     Requires: patch
323 tmb 343 Requires: make
324     Requires: tar
325     Requires: unzip
326     Requires: elfutils
327 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
328 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
329 dmorgan 185007 Requires: perl(YAML::Tiny)
330 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
331 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
332 tmb 343
333     %description build
334     This package contains scripts and executable programs that are used to
335     build packages using RPM.
336    
337 dmorgan 185007 %package sign
338     Summary: Package signing support
339     Group: System/Base
340    
341     %description sign
342     This package contains support for digitally signing RPM packages.
343    
344 tmb 343 %if %buildpython
345     %package -n python-rpm
346     Summary: Python bindings for apps which will manipulate RPM packages
347     Group: Development/Python
348     Requires: rpm = %epoch:%{version}-%{release}
349    
350     %description -n python-rpm
351     The rpm-python package contains a module which permits applications
352     written in the Python programming language to use the interface
353     supplied by RPM (RPM Package Manager) libraries.
354    
355     This package should be installed if you want to develop Python
356     programs that will manipulate RPM packages and databases.
357     %endif
358    
359     %prep
360     %setup -q -n %name-%srcver
361 dmorgan 186388 %apply_patches
362 tmb 343
363     %build
364     autoreconf
365    
366     %if %builddebug
367     RPM_OPT_FLAGS=-g
368     %endif
369 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
370 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
371 fwang 215771 %configure2_5x \
372 tmb 343 --enable-nls \
373     --enable-python \
374     --enable-sqlite3 \
375     --without-javaglue \
376     %if %builddebug
377     --enable-debug \
378     %endif
379 dmorgan 185007 --with-external-db \
380 tmb 343 %if %buildpython
381     --with-python=%{pyver} \
382     %else
383     --without-python \
384     %endif
385 dmorgan 185007 %if ! %buildplugins
386     --disable-plugins \
387     %endif
388 tmb 343 --with-glob \
389     --without-selinux \
390 dmorgan 185007 --without-apidocs \
391     --with-cap
392 tmb 343
393     %make
394    
395     %install
396 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
397 tmb 343
398     make DESTDIR=%buildroot install
399    
400 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
401    
402 tmb 343 # Save list of packages through cron
403     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
404     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
405    
406     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
407     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
408    
409     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
410     for dbi in \
411     Basenames Conflictname Dirnames Group Installtid Name Providename \
412     Provideversion Removetid Requirename Requireversion Triggername \
413 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
414     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
415 tmb 343 do
416     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
417     done
418    
419     test -d doc-copy || mkdir doc-copy
420     rm -rf doc-copy/*
421     ln -f doc/manual/* doc-copy/
422     rm -f doc-copy/Makefile*
423    
424     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
425    
426     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
427     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
428     # Put your own system macros here
429     # usually contains
430    
431     # Set this one according your locales
432     # %%_install_langs
433    
434     EOF
435    
436     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
437    
438 tv 206214 %check
439     make check
440 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
441 tv 206214
442 tmb 343 %pre
443     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
444    
445     rm -rf /usr/lib/rpm/*-mandrake-*
446 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
447 tmb 343
448 tmb 345
449 tmb 343 %post
450     # nuke __db.00? when updating to this rpm
451     rm -f /var/lib/rpm/__db.00?
452    
453 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
454 tmb 343 /bin/rpm --initdb
455     fi
456    
457     %postun
458     /usr/share/rpm-helper/del-user rpm $1 rpm
459    
460     %define rpmattr %attr(0755, rpm, rpm)
461    
462     %files -f %{name}.lang
463     %defattr(-,root,root)
464     %doc GROUPS CHANGES doc/manual/[a-z]*
465     %attr(0755,rpm,rpm) /bin/rpm
466     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
467     %attr(0755, rpm, rpm) %{_bindir}/gendiff
468     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
469 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
470 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
471     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
472     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
473    
474     %dir %{_localstatedir}/spool/repackage
475     %dir %{rpmdir}
476     %dir /etc/rpm
477     %config(noreplace) /etc/rpm/macros
478     %dir /etc/rpm/macros.d
479     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
480     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
481     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
482     %attr(0644, rpm, rpm) %{rpmdir}/macros
483     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
484     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
485     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
486     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
487 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
488     %attr(0755, rpm, rpm) %{rpmdir}/script.req
489 tv 256610 %exclude %{rpmdir}/tcl.req
490 tmb 343
491     %rpmattr %{rpmdir}/rpm2cpio.sh
492     %rpmattr %{rpmdir}/tgpg
493    
494 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
495     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
496    
497 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
498     %ifarch %{ix86} x86_64
499     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
500     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
501     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
503 rtp 267694 %else
504     %exclude %{rpmdir}/platform/i*86-linux/macros
505     %exclude %{rpmdir}/platform/athlon-linux/macros
506     %exclude %{rpmdir}/platform/pentium*-linux/macros
507     %exclude %{rpmdir}/platform/geode-linux/macros
508 tmb 343 %endif
509     %ifarch x86_64
510     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
511     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
513 rtp 267694 %else
514     %exclude %{rpmdir}/platform/amd64-linux/macros
515     %exclude %{rpmdir}/platform/ia32e-linux/macros
516     %exclude %{rpmdir}/platform/x86_64-linux/macros
517 tmb 343 %endif
518     %ifarch %arm
519 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
520 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
521 tv 256613 %else
522     %exclude %{rpmdir}/platform/arm*/macros
523 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
524 tmb 343 %endif
525     %ifarch %mips
526     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
527     %endif
528     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
529 tv 256613 # new in 4.10.0:
530     %exclude %{rpmdir}/platform/alpha*-linux/macros
531     %exclude %{rpmdir}/platform/sparc*-linux/macros
532     %exclude %{rpmdir}/platform/ia64*-linux/macros
533     %exclude %{rpmdir}/platform/ppc*-linux/macros
534     %exclude %{rpmdir}/platform/s390*-linux/macros
535     %exclude %{rpmdir}/platform/sh*-linux/macros
536 tmb 343
537 tv 256613
538    
539 tmb 343 %{_mandir}/man[18]/*.[18]*
540     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
541     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
542     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
543     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
544     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
545     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
546    
547     %config(noreplace,missingok) /etc/cron.daily/rpm
548     %config(noreplace,missingok) /etc/logrotate.d/rpm
549    
550     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
551    
552     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
553    
554     %rpmdbattr /var/lib/rpm/Basenames
555     %rpmdbattr /var/lib/rpm/Conflictname
556     %rpmdbattr /var/lib/rpm/__db.0*
557     %rpmdbattr /var/lib/rpm/Dirnames
558     %rpmdbattr /var/lib/rpm/Group
559     %rpmdbattr /var/lib/rpm/Installtid
560     %rpmdbattr /var/lib/rpm/Name
561 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
562 tmb 343 %rpmdbattr /var/lib/rpm/Packages
563     %rpmdbattr /var/lib/rpm/Providename
564     %rpmdbattr /var/lib/rpm/Provideversion
565     %rpmdbattr /var/lib/rpm/Removetid
566     %rpmdbattr /var/lib/rpm/Requirename
567     %rpmdbattr /var/lib/rpm/Requireversion
568 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
569     %rpmdbattr /var/lib/rpm/Sigmd5
570 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
571    
572     %files build
573     %defattr(-,root,root)
574     %doc CHANGES
575     %doc doc-copy/*
576     %rpmattr %{_bindir}/rpmbuild
577 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
578 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
579     %rpmattr %{_prefix}/lib/rpm/check-files
580     %rpmattr %{_prefix}/lib/rpm/debugedit
581 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
582 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
583     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
584     %rpmattr %{_prefix}/lib/rpm/find-provides
585     %rpmattr %{_prefix}/lib/rpm/find-requires
586 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
587 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
588     %rpmattr %{_prefix}/lib/rpm/perl.prov
589     %rpmattr %{_prefix}/lib/rpm/perl.req
590    
591     %rpmattr %{_prefix}/lib/rpm/check-buildroot
592     %rpmattr %{_prefix}/lib/rpm/check-prereqs
593     %rpmattr %{_prefix}/lib/rpm/check-rpaths
594     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
595     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
596     %rpmattr %{_prefix}/lib/rpm/macros.perl
597     %rpmattr %{_prefix}/lib/rpm/macros.php
598     %rpmattr %{_prefix}/lib/rpm/macros.python
599     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
600     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
601 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
602     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
603 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
604     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
605    
606     %rpmattr %{_prefix}/lib/rpm/rpmdeps
607 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
608 tmb 343
609 tv 255921
610 tmb 343 %{_mandir}/man8/rpmbuild.8*
611     %{_mandir}/man8/rpmdeps.8*
612    
613     %if %buildpython
614     %files -n python-rpm
615     %defattr(-,root,root)
616     %{_libdir}/python*/site-packages/rpm
617     %endif
618    
619     %files -n %librpmname
620     %defattr(-,root,root)
621 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
622     %{_libdir}/librpmio.so.%{libmajor}*
623 dmorgan 185007 %if %{with plugins}
624     %{_libdir}/rpm-plugins
625     %endif
626    
627     %files -n %librpmbuild
628 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
629 tmb 343
630 dmorgan 185007 %files -n %librpmsign
631     %{_libdir}/librpmsign.so.%{libmajorsign}*
632    
633     %files sign
634     %defattr(-,root,root)
635     %{_bindir}/rpmsign
636     %{_mandir}/man8/rpmsign.8*
637    
638 tmb 343 %files -n %librpmnamedevel
639     %defattr(-,root,root)
640     %{_includedir}/rpm
641     %{_libdir}/librpm.so
642     %{_libdir}/librpmio.so
643     %{_libdir}/librpmbuild.so
644 dmorgan 185007 %{_libdir}/librpmsign.so
645 tmb 343 %{_libdir}/pkgconfig/rpm.pc
646 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30