/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 447560 - (hide annotations) (download)
Thu Jun 27 12:30:11 2013 UTC (10 years, 9 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 20585 byte(s)
fix build (SILENT)
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 447559 #define snapver rc2
51 tv 441832 %define rpmversion 4.11.1
52 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
53 tv 264614 %define libver 4.10
54 tv 255921 %define libmajor 3
55     %define libmajorsign 1
56 tv 445226 %define release %mkrel %{?snapver:0.%{snapver}.}1
57 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
58 tmb 345 %define librpmnamedevel %mklibname -d rpm
59 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
60     %define librpmbuild %mklibname rpmbuild %{libmajor}
61 tmb 343
62     %define buildpython 1
63     %define rpmsetup_version 1.34
64    
65     %define builddebug 0
66     %{?_with_debug:%define builddebug 1}
67    
68     %{?_with_python:%define buildpython 1}
69     %{?_without_python:%define buildpython 0}
70    
71 dmorgan 186381 # disable plugins initially
72 dmorgan 185007 %define buildplugins 0
73     %{?_with_plugins:%define buildplugins 1}
74    
75 tmb 343 Summary: The RPM package management system
76     Name: rpm
77     Epoch: 1
78 dmorgan 185007 Version: %{rpmversion}
79 dmorgan 49378 Release: %{release}
80 fwang 390713 Group: System/Packaging
81 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
82 dmorgan 185007 # Add some undocumented feature to gendiff
83     # Send upstream ? drop ?
84     Patch17: rpm-4.4.2.2-gendiff-improved.patch
85 tmb 343
86     # if %post of foo-2 fails,
87     # or if %preun of foo-1 fails,
88     # or if %postun of foo-1 fails,
89     # => foo-1 is not removed, so we end up with both packages in rpmdb
90     # this patch makes rpm ignore the error in those cases
91 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
92 tmb 343 #
93     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
94     # scripts is ignored with or without this patch)
95 tv 262316 # Needed for urpmi testsuite:
96 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
97 tmb 343
98 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
99 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
100 tmb 343
101 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
102     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
103 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
104     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
105 blino 25212
106 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
107     # From popular request, we allow to do this
108 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
109     Patch70: rpm-4.9.1-bb-shortcircuit.patch
110 tmb 343
111     # don't conflict for doc files
112     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
113 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
114 tmb 343
115     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
116     # (is this working??)
117     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
118    
119     # Fix diff issue when buildroot contains some "//"
120 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
121 tmb 343
122     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
123 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
124 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
125 tmb 343
126     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
127     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
128     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
129     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
130     # but this is bad design anyway
131 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
132 tmb 343
133     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
134 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
135 tv 215854 Patch134: extcond.diff
136 tmb 343
137 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
138 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
139     # implementation: as long as debugedit can just overwrite data in the elf
140     # sections things keep relatively easy, but if dest_dir is longer than the
141     # original directory, debugedit would have to expand the whole elf file. Which
142     # might be technically possible but debugedit currently does not even try to."
143 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
144 dmorgan 49378
145 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
146     # with this patch, "#%define foo bar" is a fatal error
147 dmorgan 185007 # Bug still valid => Send upstream for review.
148 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
149 tmb 343
150     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
151 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
152     Patch146: rpm-4.9.1.1-filetriggers.patch
153 tmb 343
154     # add two fatal errors (during package build)
155 dmorgan 185007 # Useful ? to drop ?
156     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
157 tmb 343
158     # (nb: see the patch for more info about this issue)
159 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
160 tmb 343
161 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
162 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
163 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
164 tmb 343
165     Patch1007: rpm-4.6.0-rc3-xz-support.patch
166    
167     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
168     # as this breaks stuff that installs files to $DOCDIR during %%install
169 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
170 tmb 343
171 tv 441933 # Fedora patches
172    
173 tmb 343 # Turbolinux patches
174     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
175     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
176    
177 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
178 dmorgan 49378
179 tv 262316 # (tv) fix tests:
180 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
181 tv 255921
182 tmb 343 Patch3000: mips_macros.patch
183 tv 256616 Patch3002: mips_define_isa_macros.patch
184     Patch3003: rpm_arm_mips_isa_macros.patch
185     Patch3004: rpm_add_armv5tl.patch
186 tmb 343
187 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
188     # and not full path
189 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
190 tv 223198 #
191 dmorgan 185007 # Fedora patches
192 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
193     #
194 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
195     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
196 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
197 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
198 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
199 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
200 dmorgan 185007
201 tv 276795 # (tv) merge mga stuff from rpm-setup:
202     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
203 tv 332323 # (tv) fix aborting when ordering empty transactions:
204     Patch4006: fix-order-on-empty-transactions.diff
205 tv 327195
206    
207 dmorgan 185007 License: GPLv2+
208     BuildRequires: autoconf
209 tmb 343 BuildRequires: zlib-devel
210     BuildRequires: bzip2-devel
211 tv 276213 BuildRequires: liblzma-devel >= 5
212 dmorgan 185007 BuildRequires: automake
213 tmb 343 BuildRequires: elfutils-devel
214     BuildRequires: libbeecrypt-devel
215 dmorgan 185007 BuildRequires: ed
216     BuildRequires: gettext-devel
217 tmb 343 BuildRequires: libsqlite3-devel
218 tv 276213 BuildRequires: db5.3-devel
219 tmb 343 BuildRequires: neon-devel
220     BuildRequires: popt-devel
221     BuildRequires: nss-devel
222     BuildRequires: magic-devel
223 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
224 tmb 343 BuildRequires: readline-devel
225     BuildRequires: ncurses-devel
226 dmorgan 185007 BuildRequires: openssl-devel
227 tv 256683 BuildRequires: lua5.1-devel
228 dmorgan 185007 BuildRequires: libcap-devel
229     # Needed for doc
230 tmb 343 #BuildRequires: graphviz
231 dmorgan 185007 BuildRequires: tetex
232 tmb 343 %if %buildpython
233     BuildRequires: python-devel
234     %endif
235 tv 223263 # for testsuite:
236     BuildRequires: fakechroot
237 tmb 343
238     Requires: bzip2 >= 0.9.0c-2
239 tv 302008 Requires: xz
240 tmb 343 Requires: cpio
241     Requires: gawk
242     Requires: glibc >= 2.1.92
243     Requires: mktemp
244 tmb 345 Requires: setup >= 2.2.0-8
245 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
246 tmb 343 Requires: update-alternatives
247     Requires: %librpmname = %epoch:%version-%release
248     URL: http://rpm.org/
249     %define git_url http://rpm.org/git/rpm.git
250 dmorgan 185007 Requires(pre): rpm-helper
251 tmb 343 Requires(pre): coreutils
252 dmorgan 185007 Requires(postun): rpm-helper
253 tmb 343
254 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
255 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
256 dmorgan 185007
257 tmb 343 %description
258     RPM is a powerful command line driven package management system capable of
259     installing, uninstalling, verifying, querying, and updating software packages.
260     Each software package consists of an archive of files along with information
261     about the package like its version, a description, etc.
262    
263 dmorgan 185191 %package -n %librpmbuild
264     Summary: Libraries for building and signing RPM packages
265     Group: System/Libraries
266 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
267 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
268    
269     %description -n %librpmbuild
270     This package contains the RPM shared libraries for building and signing
271     packages.
272    
273     %package -n %librpmsign
274     Summary: Libraries for building and signing RPM packages
275     Group: System/Libraries
276    
277     %description -n %librpmsign
278     This package contains the RPM shared libraries for building and signing
279     packages.
280    
281 tmb 343 %package -n %librpmname
282 tmb 345 Summary: Library used by rpm
283     Group: System/Libraries
284     Provides: librpm = %version-%release
285 tmb 343
286     %description -n %librpmname
287     RPM is a powerful command line driven package management system capable of
288     installing, uninstalling, verifying, querying, and updating software packages.
289     This package contains common files to all applications based on rpm.
290    
291     %package -n %librpmnamedevel
292     Summary: Development files for applications which will manipulate RPM packages
293     Group: Development/C
294     Requires: rpm = %epoch:%{version}-%{release}
295     Provides: librpm-devel = %version-%release
296     Provides: rpm-devel = %version-%release
297 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
298     Requires: %librpmbuild = %epoch:%version-%release
299     Requires: %librpmsign = %epoch:%version-%release
300 tmb 343
301     %description -n %librpmnamedevel
302     This package contains the RPM C library and header files. These
303     development files will simplify the process of writing programs
304     which manipulate RPM packages and databases and are intended to make
305     it easier to create graphical package managers or any other tools
306     that need an intimate knowledge of RPM packages in order to function.
307    
308     This package should be installed if you want to develop programs that
309     will manipulate RPM packages and databases.
310    
311     %package build
312     Summary: Scripts and executable programs used to build packages
313 fwang 390713 Group: System/Packaging
314 tmb 343 Requires: autoconf
315     Requires: automake
316     Requires: file
317     Requires: gcc-c++
318     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
319 dmorgan 185007 Requires: libtool-base
320     Requires: patch
321 tmb 343 Requires: make
322     Requires: tar
323     Requires: unzip
324     Requires: elfutils
325 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
326 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
327 dmorgan 185007 Requires: perl(YAML::Tiny)
328 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
329 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
330 tmb 343
331     %description build
332     This package contains scripts and executable programs that are used to
333     build packages using RPM.
334    
335 dmorgan 185007 %package sign
336     Summary: Package signing support
337     Group: System/Base
338    
339     %description sign
340     This package contains support for digitally signing RPM packages.
341    
342 tmb 343 %if %buildpython
343     %package -n python-rpm
344     Summary: Python bindings for apps which will manipulate RPM packages
345     Group: Development/Python
346     Requires: rpm = %epoch:%{version}-%{release}
347    
348     %description -n python-rpm
349     The rpm-python package contains a module which permits applications
350     written in the Python programming language to use the interface
351     supplied by RPM (RPM Package Manager) libraries.
352    
353     This package should be installed if you want to develop Python
354     programs that will manipulate RPM packages and databases.
355     %endif
356    
357     %prep
358     %setup -q -n %name-%srcver
359 dmorgan 186388 %apply_patches
360 tmb 343
361     %build
362 tv 447560 aclocal
363     automake-1.14 --add-missing
364     automake
365 tmb 343 autoreconf
366    
367     %if %builddebug
368     RPM_OPT_FLAGS=-g
369     %endif
370 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
371 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
372 fwang 215771 %configure2_5x \
373 tmb 343 --enable-nls \
374     --enable-python \
375     --enable-sqlite3 \
376     --without-javaglue \
377     %if %builddebug
378     --enable-debug \
379     %endif
380 dmorgan 185007 --with-external-db \
381 tmb 343 %if %buildpython
382     --with-python=%{pyver} \
383     %else
384     --without-python \
385     %endif
386 dmorgan 185007 %if ! %buildplugins
387     --disable-plugins \
388     %endif
389 tmb 343 --with-glob \
390     --without-selinux \
391 dmorgan 185007 --without-apidocs \
392     --with-cap
393 tmb 343
394     %make
395    
396     %install
397 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
398 tmb 343
399     make DESTDIR=%buildroot install
400    
401 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
402    
403 tmb 343 # Save list of packages through cron
404     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
405     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
406    
407     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
408     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
409    
410     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
411     for dbi in \
412     Basenames Conflictname Dirnames Group Installtid Name Providename \
413     Provideversion Removetid Requirename Requireversion Triggername \
414 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
415     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
416 tmb 343 do
417     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
418     done
419    
420     test -d doc-copy || mkdir doc-copy
421     rm -rf doc-copy/*
422     ln -f doc/manual/* doc-copy/
423     rm -f doc-copy/Makefile*
424    
425     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
426    
427     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
428     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
429     # Put your own system macros here
430     # usually contains
431    
432     # Set this one according your locales
433     # %%_install_langs
434    
435     EOF
436    
437     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
438    
439 tv 206214 %check
440     make check
441 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
442 tv 206214
443 tmb 343 %pre
444     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
445    
446     rm -rf /usr/lib/rpm/*-mandrake-*
447 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
448 tmb 343
449 tmb 345
450 tmb 343 %post
451     # nuke __db.00? when updating to this rpm
452     rm -f /var/lib/rpm/__db.00?
453    
454 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
455 tmb 343 /bin/rpm --initdb
456     fi
457    
458     %postun
459     /usr/share/rpm-helper/del-user rpm $1 rpm
460    
461     %define rpmattr %attr(0755, rpm, rpm)
462    
463     %files -f %{name}.lang
464     %defattr(-,root,root)
465     %doc GROUPS CHANGES doc/manual/[a-z]*
466     %attr(0755,rpm,rpm) /bin/rpm
467     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
468     %attr(0755, rpm, rpm) %{_bindir}/gendiff
469     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
470 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
471 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
472     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
473     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
474    
475     %dir %{_localstatedir}/spool/repackage
476     %dir %{rpmdir}
477     %dir /etc/rpm
478     %config(noreplace) /etc/rpm/macros
479     %dir /etc/rpm/macros.d
480     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
481     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
482     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
483     %attr(0644, rpm, rpm) %{rpmdir}/macros
484     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
485     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
486     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
487     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
488 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
489     %attr(0755, rpm, rpm) %{rpmdir}/script.req
490 tv 256610 %exclude %{rpmdir}/tcl.req
491 tmb 343
492     %rpmattr %{rpmdir}/rpm2cpio.sh
493     %rpmattr %{rpmdir}/tgpg
494    
495 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
496     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
497    
498 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
499     %ifarch %{ix86} x86_64
500     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
501     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
503     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
504 rtp 267694 %else
505     %exclude %{rpmdir}/platform/i*86-linux/macros
506     %exclude %{rpmdir}/platform/athlon-linux/macros
507     %exclude %{rpmdir}/platform/pentium*-linux/macros
508     %exclude %{rpmdir}/platform/geode-linux/macros
509 tmb 343 %endif
510     %ifarch x86_64
511     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
513     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
514 rtp 267694 %else
515     %exclude %{rpmdir}/platform/amd64-linux/macros
516     %exclude %{rpmdir}/platform/ia32e-linux/macros
517     %exclude %{rpmdir}/platform/x86_64-linux/macros
518 tmb 343 %endif
519     %ifarch %arm
520 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
521 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
522 tv 256613 %else
523     %exclude %{rpmdir}/platform/arm*/macros
524 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
525 tmb 343 %endif
526     %ifarch %mips
527     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
528     %endif
529     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
530 tv 256613 # new in 4.10.0:
531     %exclude %{rpmdir}/platform/alpha*-linux/macros
532     %exclude %{rpmdir}/platform/sparc*-linux/macros
533     %exclude %{rpmdir}/platform/ia64*-linux/macros
534     %exclude %{rpmdir}/platform/ppc*-linux/macros
535     %exclude %{rpmdir}/platform/s390*-linux/macros
536     %exclude %{rpmdir}/platform/sh*-linux/macros
537 tmb 343
538 tv 256613
539    
540 tmb 343 %{_mandir}/man[18]/*.[18]*
541     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
542     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
543     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
544     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
545     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
546     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
547    
548     %config(noreplace,missingok) /etc/cron.daily/rpm
549     %config(noreplace,missingok) /etc/logrotate.d/rpm
550    
551     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
552    
553     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
554    
555     %rpmdbattr /var/lib/rpm/Basenames
556     %rpmdbattr /var/lib/rpm/Conflictname
557     %rpmdbattr /var/lib/rpm/__db.0*
558     %rpmdbattr /var/lib/rpm/Dirnames
559     %rpmdbattr /var/lib/rpm/Group
560     %rpmdbattr /var/lib/rpm/Installtid
561     %rpmdbattr /var/lib/rpm/Name
562 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
563 tmb 343 %rpmdbattr /var/lib/rpm/Packages
564     %rpmdbattr /var/lib/rpm/Providename
565     %rpmdbattr /var/lib/rpm/Provideversion
566     %rpmdbattr /var/lib/rpm/Removetid
567     %rpmdbattr /var/lib/rpm/Requirename
568     %rpmdbattr /var/lib/rpm/Requireversion
569 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
570     %rpmdbattr /var/lib/rpm/Sigmd5
571 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
572    
573     %files build
574     %defattr(-,root,root)
575     %doc CHANGES
576     %doc doc-copy/*
577     %rpmattr %{_bindir}/rpmbuild
578 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
579 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
580     %rpmattr %{_prefix}/lib/rpm/check-files
581     %rpmattr %{_prefix}/lib/rpm/debugedit
582 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
583 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
584     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
585     %rpmattr %{_prefix}/lib/rpm/find-provides
586     %rpmattr %{_prefix}/lib/rpm/find-requires
587 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
588 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
589     %rpmattr %{_prefix}/lib/rpm/perl.prov
590     %rpmattr %{_prefix}/lib/rpm/perl.req
591    
592     %rpmattr %{_prefix}/lib/rpm/check-buildroot
593     %rpmattr %{_prefix}/lib/rpm/check-prereqs
594     %rpmattr %{_prefix}/lib/rpm/check-rpaths
595     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
596     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
597     %rpmattr %{_prefix}/lib/rpm/macros.perl
598     %rpmattr %{_prefix}/lib/rpm/macros.php
599     %rpmattr %{_prefix}/lib/rpm/macros.python
600     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
601     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
602 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
603     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
604 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
605     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
606    
607     %rpmattr %{_prefix}/lib/rpm/rpmdeps
608 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
609 tmb 343
610 tv 255921
611 tmb 343 %{_mandir}/man8/rpmbuild.8*
612     %{_mandir}/man8/rpmdeps.8*
613    
614     %if %buildpython
615     %files -n python-rpm
616     %defattr(-,root,root)
617     %{_libdir}/python*/site-packages/rpm
618     %endif
619    
620     %files -n %librpmname
621     %defattr(-,root,root)
622 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
623     %{_libdir}/librpmio.so.%{libmajor}*
624 dmorgan 185007 %if %{with plugins}
625     %{_libdir}/rpm-plugins
626     %endif
627    
628     %files -n %librpmbuild
629 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
630 tmb 343
631 dmorgan 185007 %files -n %librpmsign
632     %{_libdir}/librpmsign.so.%{libmajorsign}*
633    
634     %files sign
635     %defattr(-,root,root)
636     %{_bindir}/rpmsign
637     %{_mandir}/man8/rpmsign.8*
638    
639 tmb 343 %files -n %librpmnamedevel
640     %defattr(-,root,root)
641     %{_includedir}/rpm
642     %{_libdir}/librpm.so
643     %{_libdir}/librpmio.so
644     %{_libdir}/librpmbuild.so
645 dmorgan 185007 %{_libdir}/librpmsign.so
646 tmb 343 %{_libdir}/pkgconfig/rpm.pc
647 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30