/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 490405 - (hide annotations) (download)
Wed Oct 2 13:19:04 2013 UTC (10 years, 6 months ago) by colin
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21142 byte(s)
Do not use %%attr on symlinks

1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 447559 #define snapver rc2
56 tv 441832 %define rpmversion 4.11.1
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 colin 487636 %define release %mkrel %{?snapver:0.%{snapver}.}3
62 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
63 tmb 345 %define librpmnamedevel %mklibname -d rpm
64 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
65     %define librpmbuild %mklibname rpmbuild %{libmajor}
66 tmb 343
67     %define buildpython 1
68     %define rpmsetup_version 1.34
69    
70     %define builddebug 0
71     %{?_with_debug:%define builddebug 1}
72    
73     %{?_with_python:%define buildpython 1}
74     %{?_without_python:%define buildpython 0}
75    
76 dmorgan 186381 # disable plugins initially
77 dmorgan 185007 %define buildplugins 0
78     %{?_with_plugins:%define buildplugins 1}
79    
80 tmb 343 Summary: The RPM package management system
81     Name: rpm
82     Epoch: 1
83 dmorgan 185007 Version: %{rpmversion}
84 dmorgan 49378 Release: %{release}
85 fwang 390713 Group: System/Packaging
86 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
87 dmorgan 185007 # Add some undocumented feature to gendiff
88     # Send upstream ? drop ?
89     Patch17: rpm-4.4.2.2-gendiff-improved.patch
90 tmb 343
91     # if %post of foo-2 fails,
92     # or if %preun of foo-1 fails,
93     # or if %postun of foo-1 fails,
94     # => foo-1 is not removed, so we end up with both packages in rpmdb
95     # this patch makes rpm ignore the error in those cases
96 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
97 tmb 343 #
98     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
99     # scripts is ignored with or without this patch)
100 tv 262316 # Needed for urpmi testsuite:
101 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
102 tmb 343
103 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
104 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
105 tmb 343
106 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
107     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
108 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
109     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
110 blino 25212
111 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
112     # From popular request, we allow to do this
113 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
114     Patch70: rpm-4.9.1-bb-shortcircuit.patch
115 tmb 343
116     # don't conflict for doc files
117     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
118 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
119 tmb 343
120     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
121     # (is this working??)
122     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
123    
124     # Fix diff issue when buildroot contains some "//"
125 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
126 tmb 343
127     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
128 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
129 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
130 tmb 343
131     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
132     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
133     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
134     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
135     # but this is bad design anyway
136 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
137 tmb 343
138     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
139 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
140 tv 215854 Patch134: extcond.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
157     Patch146: rpm-4.9.1.1-filetriggers.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 tv 332323 # (tv) fix aborting when ordering empty transactions:
209     Patch4006: fix-order-on-empty-transactions.diff
210 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
211     # extraction of debuginfo can fail. This happens if you have a shared build dir
212     # which contains lots of subfolders for different packages (i.e. the default
213     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
214     # This fix simply uses the real build dir passed in as an argument to the script
215     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
216     Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
217 tv 327195
218 dmorgan 185007 License: GPLv2+
219     BuildRequires: autoconf
220 tmb 343 BuildRequires: zlib-devel
221     BuildRequires: bzip2-devel
222 tv 276213 BuildRequires: liblzma-devel >= 5
223 dmorgan 185007 BuildRequires: automake
224 tmb 343 BuildRequires: elfutils-devel
225     BuildRequires: libbeecrypt-devel
226 dmorgan 185007 BuildRequires: ed
227     BuildRequires: gettext-devel
228 tmb 343 BuildRequires: libsqlite3-devel
229 tv 276213 BuildRequires: db5.3-devel
230 tmb 343 BuildRequires: neon-devel
231     BuildRequires: popt-devel
232     BuildRequires: nss-devel
233     BuildRequires: magic-devel
234 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
235 tmb 343 BuildRequires: readline-devel
236     BuildRequires: ncurses-devel
237 dmorgan 185007 BuildRequires: openssl-devel
238 tv 256683 BuildRequires: lua5.1-devel
239 dmorgan 185007 BuildRequires: libcap-devel
240     # Needed for doc
241 tmb 343 #BuildRequires: graphviz
242 dmorgan 185007 BuildRequires: tetex
243 tmb 343 %if %buildpython
244     BuildRequires: python-devel
245     %endif
246 tv 223263 # for testsuite:
247     BuildRequires: fakechroot
248 tmb 343
249     Requires: bzip2 >= 0.9.0c-2
250 tv 302008 Requires: xz
251 tmb 343 Requires: cpio
252     Requires: gawk
253     Requires: glibc >= 2.1.92
254     Requires: mktemp
255 tmb 345 Requires: setup >= 2.2.0-8
256 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
257 tmb 343 Requires: update-alternatives
258     Requires: %librpmname = %epoch:%version-%release
259     URL: http://rpm.org/
260     %define git_url http://rpm.org/git/rpm.git
261 dmorgan 185007 Requires(pre): rpm-helper
262 tmb 343 Requires(pre): coreutils
263 dmorgan 185007 Requires(postun): rpm-helper
264 tmb 343
265 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
266 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
267 dmorgan 185007
268 tmb 343 %description
269     RPM is a powerful command line driven package management system capable of
270     installing, uninstalling, verifying, querying, and updating software packages.
271     Each software package consists of an archive of files along with information
272     about the package like its version, a description, etc.
273    
274 dmorgan 185191 %package -n %librpmbuild
275     Summary: Libraries for building and signing RPM packages
276     Group: System/Libraries
277 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
278 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
279    
280     %description -n %librpmbuild
281     This package contains the RPM shared libraries for building and signing
282     packages.
283    
284     %package -n %librpmsign
285     Summary: Libraries for building and signing RPM packages
286     Group: System/Libraries
287    
288     %description -n %librpmsign
289     This package contains the RPM shared libraries for building and signing
290     packages.
291    
292 tmb 343 %package -n %librpmname
293 tmb 345 Summary: Library used by rpm
294     Group: System/Libraries
295     Provides: librpm = %version-%release
296 tmb 343
297     %description -n %librpmname
298     RPM is a powerful command line driven package management system capable of
299     installing, uninstalling, verifying, querying, and updating software packages.
300     This package contains common files to all applications based on rpm.
301    
302     %package -n %librpmnamedevel
303     Summary: Development files for applications which will manipulate RPM packages
304     Group: Development/C
305     Requires: rpm = %epoch:%{version}-%{release}
306     Provides: librpm-devel = %version-%release
307     Provides: rpm-devel = %version-%release
308 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
309     Requires: %librpmbuild = %epoch:%version-%release
310     Requires: %librpmsign = %epoch:%version-%release
311 tmb 343
312     %description -n %librpmnamedevel
313     This package contains the RPM C library and header files. These
314     development files will simplify the process of writing programs
315     which manipulate RPM packages and databases and are intended to make
316     it easier to create graphical package managers or any other tools
317     that need an intimate knowledge of RPM packages in order to function.
318    
319     This package should be installed if you want to develop programs that
320     will manipulate RPM packages and databases.
321    
322     %package build
323     Summary: Scripts and executable programs used to build packages
324 fwang 390713 Group: System/Packaging
325 tmb 343 Requires: autoconf
326     Requires: automake
327     Requires: file
328     Requires: gcc-c++
329     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
330 dmorgan 185007 Requires: libtool-base
331     Requires: patch
332 tmb 343 Requires: make
333     Requires: tar
334     Requires: unzip
335     Requires: elfutils
336 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
337 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
338 dmorgan 185007 Requires: perl(YAML::Tiny)
339 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
340 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
341 tmb 343
342     %description build
343     This package contains scripts and executable programs that are used to
344     build packages using RPM.
345    
346 dmorgan 185007 %package sign
347     Summary: Package signing support
348     Group: System/Base
349    
350     %description sign
351     This package contains support for digitally signing RPM packages.
352    
353 tmb 343 %if %buildpython
354     %package -n python-rpm
355     Summary: Python bindings for apps which will manipulate RPM packages
356     Group: Development/Python
357     Requires: rpm = %epoch:%{version}-%{release}
358    
359     %description -n python-rpm
360     The rpm-python package contains a module which permits applications
361     written in the Python programming language to use the interface
362     supplied by RPM (RPM Package Manager) libraries.
363    
364     This package should be installed if you want to develop Python
365     programs that will manipulate RPM packages and databases.
366     %endif
367    
368     %prep
369     %setup -q -n %name-%srcver
370 dmorgan 186388 %apply_patches
371 tmb 343
372     %build
373 tv 447560 aclocal
374     automake-1.14 --add-missing
375     automake
376 tmb 343 autoreconf
377    
378     %if %builddebug
379     RPM_OPT_FLAGS=-g
380     %endif
381 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
382 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
383 fwang 215771 %configure2_5x \
384 tmb 343 --enable-nls \
385     --enable-python \
386     --enable-sqlite3 \
387     --without-javaglue \
388     %if %builddebug
389     --enable-debug \
390     %endif
391 dmorgan 185007 --with-external-db \
392 tmb 343 %if %buildpython
393     --with-python=%{pyver} \
394     %else
395     --without-python \
396     %endif
397 dmorgan 185007 %if ! %buildplugins
398     --disable-plugins \
399     %endif
400 tmb 343 --with-glob \
401     --without-selinux \
402 dmorgan 185007 --without-apidocs \
403     --with-cap
404 tmb 343
405     %make
406    
407     %install
408 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
409 tmb 343
410     make DESTDIR=%buildroot install
411    
412 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
413    
414 tmb 343 # Save list of packages through cron
415     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
416     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
417    
418     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
419     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
420    
421     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
422     for dbi in \
423     Basenames Conflictname Dirnames Group Installtid Name Providename \
424     Provideversion Removetid Requirename Requireversion Triggername \
425 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
426     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
427 tmb 343 do
428     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
429     done
430    
431     test -d doc-copy || mkdir doc-copy
432     rm -rf doc-copy/*
433     ln -f doc/manual/* doc-copy/
434     rm -f doc-copy/Makefile*
435    
436     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
437    
438     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
439     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
440     # Put your own system macros here
441     # usually contains
442    
443     # Set this one according your locales
444     # %%_install_langs
445    
446     EOF
447    
448     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
449    
450 tv 206214 %check
451     make check
452 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
453 tv 206214
454 tmb 343 %pre
455     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
456    
457     rm -rf /usr/lib/rpm/*-mandrake-*
458 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
459 tmb 343
460 tmb 345
461 tmb 343 %post
462     # nuke __db.00? when updating to this rpm
463     rm -f /var/lib/rpm/__db.00?
464    
465 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
466 tmb 343 /bin/rpm --initdb
467     fi
468    
469     %postun
470     /usr/share/rpm-helper/del-user rpm $1 rpm
471    
472     %define rpmattr %attr(0755, rpm, rpm)
473    
474     %files -f %{name}.lang
475     %defattr(-,root,root)
476     %doc GROUPS CHANGES doc/manual/[a-z]*
477     %attr(0755,rpm,rpm) /bin/rpm
478     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
479     %attr(0755, rpm, rpm) %{_bindir}/gendiff
480     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
481 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
482 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
483 colin 490405 %{_bindir}/rpmquery
484     %{_bindir}/rpmverify
485 tmb 343
486     %dir %{_localstatedir}/spool/repackage
487     %dir %{rpmdir}
488     %dir /etc/rpm
489     %config(noreplace) /etc/rpm/macros
490     %dir /etc/rpm/macros.d
491     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
492     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
493     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
494     %attr(0644, rpm, rpm) %{rpmdir}/macros
495     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
496     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
497     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
498     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
499 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
500     %attr(0755, rpm, rpm) %{rpmdir}/script.req
501 tv 256610 %exclude %{rpmdir}/tcl.req
502 tmb 343
503     %rpmattr %{rpmdir}/rpm2cpio.sh
504     %rpmattr %{rpmdir}/tgpg
505    
506 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
507     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
508    
509 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
510     %ifarch %{ix86} x86_64
511     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
513     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
514     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
515 rtp 267694 %else
516 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
517     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
518     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
519     %exclude %{rpmdir}/platform/geode-%{_os}/macros
520 tmb 343 %endif
521     %ifarch x86_64
522     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
523     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
524     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
525 rtp 267694 %else
526 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
527     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
528     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
529 tmb 343 %endif
530     %ifarch %arm
531 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
532 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
533 tv 256613 %else
534     %exclude %{rpmdir}/platform/arm*/macros
535 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
536 tmb 343 %endif
537     %ifarch %mips
538     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
539     %endif
540     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
541 tv 256613 # new in 4.10.0:
542 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
543     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
544     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
545     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
546     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
547     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
548 tmb 343
549 tv 256613
550    
551 tmb 343 %{_mandir}/man[18]/*.[18]*
552     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
553     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
554     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
555     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
556     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
557     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
558    
559     %config(noreplace,missingok) /etc/cron.daily/rpm
560     %config(noreplace,missingok) /etc/logrotate.d/rpm
561    
562     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
563    
564     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
565    
566     %rpmdbattr /var/lib/rpm/Basenames
567     %rpmdbattr /var/lib/rpm/Conflictname
568     %rpmdbattr /var/lib/rpm/__db.0*
569     %rpmdbattr /var/lib/rpm/Dirnames
570     %rpmdbattr /var/lib/rpm/Group
571     %rpmdbattr /var/lib/rpm/Installtid
572     %rpmdbattr /var/lib/rpm/Name
573 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
574 tmb 343 %rpmdbattr /var/lib/rpm/Packages
575     %rpmdbattr /var/lib/rpm/Providename
576     %rpmdbattr /var/lib/rpm/Provideversion
577     %rpmdbattr /var/lib/rpm/Removetid
578     %rpmdbattr /var/lib/rpm/Requirename
579     %rpmdbattr /var/lib/rpm/Requireversion
580 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
581     %rpmdbattr /var/lib/rpm/Sigmd5
582 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
583    
584     %files build
585     %defattr(-,root,root)
586     %doc CHANGES
587     %doc doc-copy/*
588     %rpmattr %{_bindir}/rpmbuild
589 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
590 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
591     %rpmattr %{_prefix}/lib/rpm/check-files
592     %rpmattr %{_prefix}/lib/rpm/debugedit
593 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
594 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
595     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
596     %rpmattr %{_prefix}/lib/rpm/find-provides
597     %rpmattr %{_prefix}/lib/rpm/find-requires
598 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
599 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
600     %rpmattr %{_prefix}/lib/rpm/perl.prov
601     %rpmattr %{_prefix}/lib/rpm/perl.req
602    
603     %rpmattr %{_prefix}/lib/rpm/check-buildroot
604     %rpmattr %{_prefix}/lib/rpm/check-prereqs
605     %rpmattr %{_prefix}/lib/rpm/check-rpaths
606     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
607     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
608     %rpmattr %{_prefix}/lib/rpm/macros.perl
609     %rpmattr %{_prefix}/lib/rpm/macros.php
610     %rpmattr %{_prefix}/lib/rpm/macros.python
611     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
612     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
613 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
614     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
615 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
616     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
617    
618     %rpmattr %{_prefix}/lib/rpm/rpmdeps
619 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
620 tmb 343
621 tv 255921
622 tmb 343 %{_mandir}/man8/rpmbuild.8*
623     %{_mandir}/man8/rpmdeps.8*
624    
625     %if %buildpython
626     %files -n python-rpm
627     %defattr(-,root,root)
628     %{_libdir}/python*/site-packages/rpm
629     %endif
630    
631     %files -n %librpmname
632     %defattr(-,root,root)
633 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
634     %{_libdir}/librpmio.so.%{libmajor}*
635 dmorgan 185007 %if %{with plugins}
636     %{_libdir}/rpm-plugins
637     %endif
638    
639     %files -n %librpmbuild
640 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
641 tmb 343
642 dmorgan 185007 %files -n %librpmsign
643     %{_libdir}/librpmsign.so.%{libmajorsign}*
644    
645     %files sign
646     %defattr(-,root,root)
647     %{_bindir}/rpmsign
648     %{_mandir}/man8/rpmsign.8*
649    
650 tmb 343 %files -n %librpmnamedevel
651     %defattr(-,root,root)
652     %{_includedir}/rpm
653     %{_libdir}/librpm.so
654     %{_libdir}/librpmio.so
655     %{_libdir}/librpmbuild.so
656 dmorgan 185007 %{_libdir}/librpmsign.so
657 tmb 343 %{_libdir}/pkgconfig/rpm.pc
658 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30