/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 629134 - (hide annotations) (download)
Sat May 31 15:52:02 2014 UTC (9 years, 10 months ago) by pterjan
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21497 byte(s)
Rebuild for new Python
1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 581966 %define rpmversion 4.11.2
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 pterjan 629134 %define release %mkrel %{?snapver:0.%{snapver}.}4
62 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
63 tmb 345 %define librpmnamedevel %mklibname -d rpm
64 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
65     %define librpmbuild %mklibname rpmbuild %{libmajor}
66 tmb 343
67     %define buildpython 1
68     %define rpmsetup_version 1.34
69    
70     %define builddebug 0
71     %{?_with_debug:%define builddebug 1}
72    
73     %{?_with_python:%define buildpython 1}
74     %{?_without_python:%define buildpython 0}
75    
76 dmorgan 186381 # disable plugins initially
77 dmorgan 185007 %define buildplugins 0
78     %{?_with_plugins:%define buildplugins 1}
79    
80 tmb 343 Summary: The RPM package management system
81     Name: rpm
82     Epoch: 1
83 dmorgan 185007 Version: %{rpmversion}
84 dmorgan 49378 Release: %{release}
85 fwang 390713 Group: System/Packaging
86 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
87 dmorgan 185007 # Add some undocumented feature to gendiff
88     # Send upstream ? drop ?
89     Patch17: rpm-4.4.2.2-gendiff-improved.patch
90 tmb 343
91     # if %post of foo-2 fails,
92     # or if %preun of foo-1 fails,
93     # or if %postun of foo-1 fails,
94     # => foo-1 is not removed, so we end up with both packages in rpmdb
95     # this patch makes rpm ignore the error in those cases
96 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
97 tmb 343 #
98     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
99     # scripts is ignored with or without this patch)
100 tv 262316 # Needed for urpmi testsuite:
101 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
102 tmb 343
103 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
104 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
105 tmb 343
106 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
107     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
108 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
109     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
110 blino 25212
111 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
112     # From popular request, we allow to do this
113 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
114     Patch70: rpm-4.9.1-bb-shortcircuit.patch
115 tmb 343
116     # don't conflict for doc files
117     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
118 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
119 tmb 343
120     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
121     # (is this working??)
122     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
123    
124     # Fix diff issue when buildroot contains some "//"
125 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
126 tmb 343
127     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
128 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
129 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
130 tmb 343
131     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
132     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
133     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
134     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
135     # but this is bad design anyway
136 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
137 tmb 343
138     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
139 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
140 tv 215854 Patch134: extcond.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
157 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
209     # extraction of debuginfo can fail. This happens if you have a shared build dir
210     # which contains lots of subfolders for different packages (i.e. the default
211     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
212     # This fix simply uses the real build dir passed in as an argument to the script
213     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
214 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
215     # I suspect the real problem lies in the debugedit binary which I will debug further.
216     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
217     # still here after any reasonable length of time!)
218     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
219 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
220     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
221 tv 327195
222 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
223    
224 dmorgan 185007 License: GPLv2+
225     BuildRequires: autoconf
226 tmb 343 BuildRequires: zlib-devel
227     BuildRequires: bzip2-devel
228 tv 276213 BuildRequires: liblzma-devel >= 5
229 dmorgan 185007 BuildRequires: automake
230 tmb 343 BuildRequires: elfutils-devel
231     BuildRequires: libbeecrypt-devel
232 dmorgan 185007 BuildRequires: ed
233     BuildRequires: gettext-devel
234 tmb 343 BuildRequires: libsqlite3-devel
235 tv 276213 BuildRequires: db5.3-devel
236 tmb 343 BuildRequires: neon-devel
237     BuildRequires: popt-devel
238     BuildRequires: nss-devel
239     BuildRequires: magic-devel
240 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
241 tmb 343 BuildRequires: readline-devel
242     BuildRequires: ncurses-devel
243 dmorgan 185007 BuildRequires: openssl-devel
244 tv 256683 BuildRequires: lua5.1-devel
245 dmorgan 185007 BuildRequires: libcap-devel
246     # Needed for doc
247 tmb 343 #BuildRequires: graphviz
248 dmorgan 185007 BuildRequires: tetex
249 tmb 343 %if %buildpython
250     BuildRequires: python-devel
251     %endif
252 tv 223263 # for testsuite:
253     BuildRequires: fakechroot
254 tmb 343
255     Requires: bzip2 >= 0.9.0c-2
256 tv 302008 Requires: xz
257 tmb 343 Requires: cpio
258     Requires: gawk
259     Requires: glibc >= 2.1.92
260     Requires: mktemp
261 tmb 345 Requires: setup >= 2.2.0-8
262 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
263 tmb 343 Requires: update-alternatives
264     Requires: %librpmname = %epoch:%version-%release
265     URL: http://rpm.org/
266     %define git_url http://rpm.org/git/rpm.git
267 dmorgan 185007 Requires(pre): rpm-helper
268 tmb 343 Requires(pre): coreutils
269 dmorgan 185007 Requires(postun): rpm-helper
270 tmb 343
271 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
272 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
273 dmorgan 185007
274 tmb 343 %description
275     RPM is a powerful command line driven package management system capable of
276     installing, uninstalling, verifying, querying, and updating software packages.
277     Each software package consists of an archive of files along with information
278     about the package like its version, a description, etc.
279    
280 dmorgan 185191 %package -n %librpmbuild
281     Summary: Libraries for building and signing RPM packages
282     Group: System/Libraries
283 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
284 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
285    
286     %description -n %librpmbuild
287     This package contains the RPM shared libraries for building and signing
288     packages.
289    
290     %package -n %librpmsign
291     Summary: Libraries for building and signing RPM packages
292     Group: System/Libraries
293    
294     %description -n %librpmsign
295     This package contains the RPM shared libraries for building and signing
296     packages.
297    
298 tmb 343 %package -n %librpmname
299 tmb 345 Summary: Library used by rpm
300     Group: System/Libraries
301     Provides: librpm = %version-%release
302 tmb 343
303     %description -n %librpmname
304     RPM is a powerful command line driven package management system capable of
305     installing, uninstalling, verifying, querying, and updating software packages.
306     This package contains common files to all applications based on rpm.
307    
308     %package -n %librpmnamedevel
309     Summary: Development files for applications which will manipulate RPM packages
310     Group: Development/C
311     Requires: rpm = %epoch:%{version}-%{release}
312     Provides: librpm-devel = %version-%release
313     Provides: rpm-devel = %version-%release
314 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
315     Requires: %librpmbuild = %epoch:%version-%release
316     Requires: %librpmsign = %epoch:%version-%release
317 tmb 343
318     %description -n %librpmnamedevel
319     This package contains the RPM C library and header files. These
320     development files will simplify the process of writing programs
321     which manipulate RPM packages and databases and are intended to make
322     it easier to create graphical package managers or any other tools
323     that need an intimate knowledge of RPM packages in order to function.
324    
325     This package should be installed if you want to develop programs that
326     will manipulate RPM packages and databases.
327    
328     %package build
329     Summary: Scripts and executable programs used to build packages
330 fwang 390713 Group: System/Packaging
331 tmb 343 Requires: autoconf
332     Requires: automake
333     Requires: file
334     Requires: gcc-c++
335     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
336 dmorgan 185007 Requires: libtool-base
337     Requires: patch
338 tmb 343 Requires: make
339     Requires: tar
340     Requires: unzip
341     Requires: elfutils
342 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
343 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
344 dmorgan 185007 Requires: perl(YAML::Tiny)
345 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
346 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
347 tmb 343
348     %description build
349     This package contains scripts and executable programs that are used to
350     build packages using RPM.
351    
352 dmorgan 185007 %package sign
353     Summary: Package signing support
354     Group: System/Base
355    
356     %description sign
357     This package contains support for digitally signing RPM packages.
358    
359 tmb 343 %if %buildpython
360     %package -n python-rpm
361     Summary: Python bindings for apps which will manipulate RPM packages
362     Group: Development/Python
363     Requires: rpm = %epoch:%{version}-%{release}
364    
365     %description -n python-rpm
366     The rpm-python package contains a module which permits applications
367     written in the Python programming language to use the interface
368     supplied by RPM (RPM Package Manager) libraries.
369    
370     This package should be installed if you want to develop Python
371     programs that will manipulate RPM packages and databases.
372     %endif
373    
374     %prep
375     %setup -q -n %name-%srcver
376 dmorgan 186388 %apply_patches
377 tmb 343
378     %build
379 tv 447560 aclocal
380     automake-1.14 --add-missing
381     automake
382 tmb 343 autoreconf
383    
384     %if %builddebug
385     RPM_OPT_FLAGS=-g
386     %endif
387 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
388 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
389 fwang 215771 %configure2_5x \
390 tmb 343 --enable-nls \
391     --enable-python \
392     --enable-sqlite3 \
393     --without-javaglue \
394     %if %builddebug
395     --enable-debug \
396     %endif
397 dmorgan 185007 --with-external-db \
398 tmb 343 %if %buildpython
399     --with-python=%{pyver} \
400     %else
401     --without-python \
402     %endif
403 dmorgan 185007 %if ! %buildplugins
404     --disable-plugins \
405     %endif
406 tmb 343 --with-glob \
407     --without-selinux \
408 dmorgan 185007 --without-apidocs \
409     --with-cap
410 tmb 343
411     %make
412    
413     %install
414 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
415 tmb 343
416     make DESTDIR=%buildroot install
417    
418 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
419    
420 tmb 343 # Save list of packages through cron
421     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
422     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
423    
424     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
425     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
426    
427     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
428     for dbi in \
429     Basenames Conflictname Dirnames Group Installtid Name Providename \
430     Provideversion Removetid Requirename Requireversion Triggername \
431 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
432     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
433 tmb 343 do
434     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
435     done
436    
437     test -d doc-copy || mkdir doc-copy
438     rm -rf doc-copy/*
439     ln -f doc/manual/* doc-copy/
440     rm -f doc-copy/Makefile*
441    
442     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
443    
444     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
445     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
446     # Put your own system macros here
447     # usually contains
448    
449     # Set this one according your locales
450     # %%_install_langs
451    
452     EOF
453    
454     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
455    
456 tv 206214 %check
457     make check
458 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
459 tv 206214
460 tmb 343 %pre
461     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
462    
463     rm -rf /usr/lib/rpm/*-mandrake-*
464 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
465 tmb 343
466 tmb 345
467 tmb 343 %post
468     # nuke __db.00? when updating to this rpm
469     rm -f /var/lib/rpm/__db.00?
470    
471 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
472 tmb 343 /bin/rpm --initdb
473     fi
474    
475     %postun
476     /usr/share/rpm-helper/del-user rpm $1 rpm
477    
478     %define rpmattr %attr(0755, rpm, rpm)
479    
480     %files -f %{name}.lang
481     %defattr(-,root,root)
482     %doc GROUPS CHANGES doc/manual/[a-z]*
483     %attr(0755,rpm,rpm) /bin/rpm
484     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
485     %attr(0755, rpm, rpm) %{_bindir}/gendiff
486     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
487 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
488 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
489 colin 490405 %{_bindir}/rpmquery
490     %{_bindir}/rpmverify
491 tmb 343
492     %dir %{_localstatedir}/spool/repackage
493     %dir %{rpmdir}
494     %dir /etc/rpm
495     %config(noreplace) /etc/rpm/macros
496     %dir /etc/rpm/macros.d
497     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
498     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
499     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
500     %attr(0644, rpm, rpm) %{rpmdir}/macros
501     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
502     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
503     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
504     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
505 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
506     %attr(0755, rpm, rpm) %{rpmdir}/script.req
507 tv 256610 %exclude %{rpmdir}/tcl.req
508 tmb 343
509     %rpmattr %{rpmdir}/rpm2cpio.sh
510     %rpmattr %{rpmdir}/tgpg
511    
512 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
513     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
514    
515 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
516     %ifarch %{ix86} x86_64
517     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
518     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
519     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
520     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
521 rtp 267694 %else
522 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
523     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
524     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
525     %exclude %{rpmdir}/platform/geode-%{_os}/macros
526 tmb 343 %endif
527     %ifarch x86_64
528     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
529     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
531 rtp 267694 %else
532 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
533     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
534     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
535 tmb 343 %endif
536     %ifarch %arm
537 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
538 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
539 tv 256613 %else
540     %exclude %{rpmdir}/platform/arm*/macros
541 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
542 tmb 343 %endif
543     %ifarch %mips
544     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
545     %endif
546     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
547 tv 256613 # new in 4.10.0:
548 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
549     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
550     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
551     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
552     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
553     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
554 tmb 343
555 tv 256613
556    
557 tmb 343 %{_mandir}/man[18]/*.[18]*
558     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
559     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
560     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
561     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
562     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
563     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
564    
565     %config(noreplace,missingok) /etc/cron.daily/rpm
566     %config(noreplace,missingok) /etc/logrotate.d/rpm
567    
568     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
569    
570     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
571    
572     %rpmdbattr /var/lib/rpm/Basenames
573     %rpmdbattr /var/lib/rpm/Conflictname
574     %rpmdbattr /var/lib/rpm/__db.0*
575     %rpmdbattr /var/lib/rpm/Dirnames
576     %rpmdbattr /var/lib/rpm/Group
577     %rpmdbattr /var/lib/rpm/Installtid
578     %rpmdbattr /var/lib/rpm/Name
579 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
580 tmb 343 %rpmdbattr /var/lib/rpm/Packages
581     %rpmdbattr /var/lib/rpm/Providename
582     %rpmdbattr /var/lib/rpm/Provideversion
583     %rpmdbattr /var/lib/rpm/Removetid
584     %rpmdbattr /var/lib/rpm/Requirename
585     %rpmdbattr /var/lib/rpm/Requireversion
586 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
587     %rpmdbattr /var/lib/rpm/Sigmd5
588 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
589    
590     %files build
591     %defattr(-,root,root)
592     %doc CHANGES
593     %doc doc-copy/*
594     %rpmattr %{_bindir}/rpmbuild
595 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
596 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
597     %rpmattr %{_prefix}/lib/rpm/check-files
598     %rpmattr %{_prefix}/lib/rpm/debugedit
599 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
600 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
601     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
602     %rpmattr %{_prefix}/lib/rpm/find-provides
603     %rpmattr %{_prefix}/lib/rpm/find-requires
604 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
605 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
606     %rpmattr %{_prefix}/lib/rpm/perl.prov
607     %rpmattr %{_prefix}/lib/rpm/perl.req
608    
609     %rpmattr %{_prefix}/lib/rpm/check-buildroot
610     %rpmattr %{_prefix}/lib/rpm/check-prereqs
611     %rpmattr %{_prefix}/lib/rpm/check-rpaths
612     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
613     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
614     %rpmattr %{_prefix}/lib/rpm/macros.perl
615     %rpmattr %{_prefix}/lib/rpm/macros.php
616     %rpmattr %{_prefix}/lib/rpm/macros.python
617     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
618     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
619 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
620     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
621 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
622     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
623    
624     %rpmattr %{_prefix}/lib/rpm/rpmdeps
625 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
626 tmb 343
627 tv 255921
628 tmb 343 %{_mandir}/man8/rpmbuild.8*
629     %{_mandir}/man8/rpmdeps.8*
630    
631     %if %buildpython
632     %files -n python-rpm
633     %defattr(-,root,root)
634     %{_libdir}/python*/site-packages/rpm
635     %endif
636    
637     %files -n %librpmname
638     %defattr(-,root,root)
639 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
640     %{_libdir}/librpmio.so.%{libmajor}*
641 dmorgan 185007 %if %{with plugins}
642     %{_libdir}/rpm-plugins
643     %endif
644    
645     %files -n %librpmbuild
646 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
647 tmb 343
648 dmorgan 185007 %files -n %librpmsign
649     %{_libdir}/librpmsign.so.%{libmajorsign}*
650    
651     %files sign
652     %defattr(-,root,root)
653     %{_bindir}/rpmsign
654     %{_mandir}/man8/rpmsign.8*
655    
656 tmb 343 %files -n %librpmnamedevel
657     %defattr(-,root,root)
658     %{_includedir}/rpm
659     %{_libdir}/librpm.so
660     %{_libdir}/librpmio.so
661     %{_libdir}/librpmbuild.so
662 dmorgan 185007 %{_libdir}/librpmsign.so
663 tmb 343 %{_libdir}/pkgconfig/rpm.pc
664 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30