/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 657571 - (hide annotations) (download)
Sun Jul 27 14:12:55 2014 UTC (9 years, 8 months ago) by colin
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21527 byte(s)
Implement support for prioritised filetriggers
1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 581966 %define rpmversion 4.11.2
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 colin 657571 Release: %mkrel %{?snapver:0.%{snapver}.}7
84 fwang 390713 Group: System/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
138 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
139 tv 215854 Patch134: extcond.diff
140 tmb 343
141 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
142 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
143     # implementation: as long as debugedit can just overwrite data in the elf
144     # sections things keep relatively easy, but if dest_dir is longer than the
145     # original directory, debugedit would have to expand the whole elf file. Which
146     # might be technically possible but debugedit currently does not even try to."
147 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
148 dmorgan 49378
149 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
150     # with this patch, "#%define foo bar" is a fatal error
151 dmorgan 185007 # Bug still valid => Send upstream for review.
152 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
153 tmb 343
154     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
155 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
156 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
157 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
158     Patch148: rpm-4.11.1-filetriggers-warnings.patch
159 tmb 343
160     # add two fatal errors (during package build)
161 dmorgan 185007 # Useful ? to drop ?
162 colin 657571 #Patch149: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
163 tmb 343
164     # (nb: see the patch for more info about this issue)
165 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
166 tmb 343
167 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
168 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
169 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
170 tmb 343
171     Patch1007: rpm-4.6.0-rc3-xz-support.patch
172    
173     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
174     # as this breaks stuff that installs files to $DOCDIR during %%install
175 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
176 tmb 343
177 tv 441933 # Fedora patches
178    
179 tmb 343 # Turbolinux patches
180     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
181     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
182    
183 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
184 dmorgan 49378
185 tv 262316 # (tv) fix tests:
186 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
187 tv 255921
188 tmb 343 Patch3000: mips_macros.patch
189 tv 256616 Patch3002: mips_define_isa_macros.patch
190     Patch3003: rpm_arm_mips_isa_macros.patch
191     Patch3004: rpm_add_armv5tl.patch
192 tmb 343
193 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
194     # and not full path
195 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
196 tv 223198 #
197 dmorgan 185007 # Fedora patches
198 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
199     #
200 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
201     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
202 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
203 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
204 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
205 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
206 dmorgan 185007
207 tv 276795 # (tv) merge mga stuff from rpm-setup:
208     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
209 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
210     # extraction of debuginfo can fail. This happens if you have a shared build dir
211     # which contains lots of subfolders for different packages (i.e. the default
212     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
213     # This fix simply uses the real build dir passed in as an argument to the script
214     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
215 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
216     # I suspect the real problem lies in the debugedit binary which I will debug further.
217     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
218     # still here after any reasonable length of time!)
219     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
220 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
221     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
222 tv 327195
223 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
224    
225 dmorgan 185007 License: GPLv2+
226     BuildRequires: autoconf
227 tmb 343 BuildRequires: zlib-devel
228     BuildRequires: bzip2-devel
229 tv 276213 BuildRequires: liblzma-devel >= 5
230 dmorgan 185007 BuildRequires: automake
231 tmb 343 BuildRequires: elfutils-devel
232     BuildRequires: libbeecrypt-devel
233 dmorgan 185007 BuildRequires: ed
234     BuildRequires: gettext-devel
235 tmb 343 BuildRequires: libsqlite3-devel
236 tv 276213 BuildRequires: db5.3-devel
237 tmb 343 BuildRequires: neon-devel
238     BuildRequires: popt-devel
239     BuildRequires: nss-devel
240     BuildRequires: magic-devel
241 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
242 tmb 343 BuildRequires: readline-devel
243     BuildRequires: ncurses-devel
244 dmorgan 185007 BuildRequires: openssl-devel
245 tv 641668 BuildRequires: lua5.2-devel >= 5.2.3-3.mga5
246 dmorgan 185007 BuildRequires: libcap-devel
247     # Needed for doc
248 tmb 343 #BuildRequires: graphviz
249 dmorgan 185007 BuildRequires: tetex
250 tmb 343 %if %buildpython
251     BuildRequires: python-devel
252     %endif
253 tv 223263 # for testsuite:
254 tv 641033 BuildRequires: eatmydata
255 tv 223263 BuildRequires: fakechroot
256 tmb 343
257     Requires: bzip2 >= 0.9.0c-2
258 tv 302008 Requires: xz
259 tmb 343 Requires: cpio
260     Requires: gawk
261     Requires: glibc >= 2.1.92
262     Requires: mktemp
263 tmb 345 Requires: setup >= 2.2.0-8
264 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
265 tmb 343 Requires: update-alternatives
266     Requires: %librpmname = %epoch:%version-%release
267     URL: http://rpm.org/
268     %define git_url http://rpm.org/git/rpm.git
269 dmorgan 185007 Requires(pre): rpm-helper
270 tmb 343 Requires(pre): coreutils
271 dmorgan 185007 Requires(postun): rpm-helper
272 tmb 343
273 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
274 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
275 dmorgan 185007
276 tmb 343 %description
277     RPM is a powerful command line driven package management system capable of
278     installing, uninstalling, verifying, querying, and updating software packages.
279     Each software package consists of an archive of files along with information
280     about the package like its version, a description, etc.
281    
282 dmorgan 185191 %package -n %librpmbuild
283     Summary: Libraries for building and signing RPM packages
284     Group: System/Libraries
285 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
286 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
287    
288     %description -n %librpmbuild
289     This package contains the RPM shared libraries for building and signing
290     packages.
291    
292     %package -n %librpmsign
293     Summary: Libraries for building and signing RPM packages
294     Group: System/Libraries
295    
296     %description -n %librpmsign
297     This package contains the RPM shared libraries for building and signing
298     packages.
299    
300 tmb 343 %package -n %librpmname
301 tmb 345 Summary: Library used by rpm
302     Group: System/Libraries
303     Provides: librpm = %version-%release
304 tv 641727 # for fixed lua:
305     Requires: %{mklibname lua 5.2} >= 5.2.3-3.mga5
306 tmb 343
307     %description -n %librpmname
308     RPM is a powerful command line driven package management system capable of
309     installing, uninstalling, verifying, querying, and updating software packages.
310     This package contains common files to all applications based on rpm.
311    
312     %package -n %librpmnamedevel
313     Summary: Development files for applications which will manipulate RPM packages
314     Group: Development/C
315     Requires: rpm = %epoch:%{version}-%{release}
316     Provides: librpm-devel = %version-%release
317     Provides: rpm-devel = %version-%release
318 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
319     Requires: %librpmbuild = %epoch:%version-%release
320     Requires: %librpmsign = %epoch:%version-%release
321 tmb 343
322     %description -n %librpmnamedevel
323     This package contains the RPM C library and header files. These
324     development files will simplify the process of writing programs
325     which manipulate RPM packages and databases and are intended to make
326     it easier to create graphical package managers or any other tools
327     that need an intimate knowledge of RPM packages in order to function.
328    
329     This package should be installed if you want to develop programs that
330     will manipulate RPM packages and databases.
331    
332     %package build
333     Summary: Scripts and executable programs used to build packages
334 fwang 390713 Group: System/Packaging
335 tmb 343 Requires: autoconf
336     Requires: automake
337     Requires: file
338     Requires: gcc-c++
339     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
340 dmorgan 185007 Requires: libtool-base
341     Requires: patch
342 tmb 343 Requires: make
343     Requires: tar
344     Requires: unzip
345     Requires: elfutils
346 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
347 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
348 dmorgan 185007 Requires: perl(YAML::Tiny)
349 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
350 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
351 tmb 343
352     %description build
353     This package contains scripts and executable programs that are used to
354     build packages using RPM.
355    
356 dmorgan 185007 %package sign
357     Summary: Package signing support
358     Group: System/Base
359    
360     %description sign
361     This package contains support for digitally signing RPM packages.
362    
363 tmb 343 %if %buildpython
364     %package -n python-rpm
365     Summary: Python bindings for apps which will manipulate RPM packages
366     Group: Development/Python
367     Requires: rpm = %epoch:%{version}-%{release}
368    
369     %description -n python-rpm
370     The rpm-python package contains a module which permits applications
371     written in the Python programming language to use the interface
372     supplied by RPM (RPM Package Manager) libraries.
373    
374     This package should be installed if you want to develop Python
375     programs that will manipulate RPM packages and databases.
376     %endif
377    
378     %prep
379     %setup -q -n %name-%srcver
380 dmorgan 186388 %apply_patches
381 tmb 343
382     %build
383 tv 447560 aclocal
384     automake-1.14 --add-missing
385     automake
386 tmb 343 autoreconf
387    
388     %if %builddebug
389     RPM_OPT_FLAGS=-g
390     %endif
391 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
392 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
393 fwang 215771 %configure2_5x \
394 tmb 343 --enable-nls \
395     --enable-python \
396     --enable-sqlite3 \
397     --without-javaglue \
398     %if %builddebug
399     --enable-debug \
400     %endif
401 dmorgan 185007 --with-external-db \
402 tmb 343 %if %buildpython
403     --with-python=%{pyver} \
404     %else
405     --without-python \
406     %endif
407 dmorgan 185007 %if ! %buildplugins
408     --disable-plugins \
409     %endif
410 tmb 343 --with-glob \
411     --without-selinux \
412 dmorgan 185007 --without-apidocs \
413     --with-cap
414 tmb 343
415     %make
416    
417     %install
418     make DESTDIR=%buildroot install
419    
420 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
421    
422 tmb 343 # Save list of packages through cron
423     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
424     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
425    
426     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
427     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
428    
429     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
430     for dbi in \
431     Basenames Conflictname Dirnames Group Installtid Name Providename \
432     Provideversion Removetid Requirename Requireversion Triggername \
433 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
434     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
435 tmb 343 do
436     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
437     done
438    
439     test -d doc-copy || mkdir doc-copy
440     rm -rf doc-copy/*
441     ln -f doc/manual/* doc-copy/
442     rm -f doc-copy/Makefile*
443    
444     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
445    
446     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
447     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
448     # Put your own system macros here
449     # usually contains
450    
451     # Set this one according your locales
452     # %%_install_langs
453    
454     EOF
455    
456     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
457    
458 tv 206214 %check
459 tv 641033 eatmydata make check
460 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
461 tv 206214
462 tmb 343 %pre
463     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
464    
465     rm -rf /usr/lib/rpm/*-mandrake-*
466 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
467 tmb 343
468 tmb 345
469 tmb 343 %post
470     # nuke __db.00? when updating to this rpm
471     rm -f /var/lib/rpm/__db.00?
472    
473 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
474 tmb 343 /bin/rpm --initdb
475     fi
476    
477     %postun
478     /usr/share/rpm-helper/del-user rpm $1 rpm
479    
480     %define rpmattr %attr(0755, rpm, rpm)
481    
482     %files -f %{name}.lang
483     %doc GROUPS CHANGES doc/manual/[a-z]*
484     %attr(0755,rpm,rpm) /bin/rpm
485     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
486     %attr(0755, rpm, rpm) %{_bindir}/gendiff
487     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
488 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
489 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
490 colin 490405 %{_bindir}/rpmquery
491     %{_bindir}/rpmverify
492 tmb 343
493     %dir %{_localstatedir}/spool/repackage
494     %dir %{rpmdir}
495     %dir /etc/rpm
496     %config(noreplace) /etc/rpm/macros
497     %dir /etc/rpm/macros.d
498     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
499     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
500     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
501     %attr(0644, rpm, rpm) %{rpmdir}/macros
502     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
503     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
504     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
505     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
506 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
507     %attr(0755, rpm, rpm) %{rpmdir}/script.req
508 tv 256610 %exclude %{rpmdir}/tcl.req
509 tmb 343
510     %rpmattr %{rpmdir}/rpm2cpio.sh
511     %rpmattr %{rpmdir}/tgpg
512    
513 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
514     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
515    
516 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
517     %ifarch %{ix86} x86_64
518     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
519     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
520     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
521     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
522 rtp 267694 %else
523 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
524     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
525     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
526     %exclude %{rpmdir}/platform/geode-%{_os}/macros
527 tmb 343 %endif
528     %ifarch x86_64
529     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
531     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
532 rtp 267694 %else
533 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
534     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
535     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
536 tmb 343 %endif
537     %ifarch %arm
538 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
539 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
540 tv 256613 %else
541     %exclude %{rpmdir}/platform/arm*/macros
542 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
543 tmb 343 %endif
544     %ifarch %mips
545     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
546     %endif
547     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
548 tv 256613 # new in 4.10.0:
549 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
550     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
551     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
552     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
553     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
554     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
555 tmb 343
556 tv 256613
557    
558 tmb 343 %{_mandir}/man[18]/*.[18]*
559     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
560     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
561     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
562     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
563     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
564     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
565    
566     %config(noreplace,missingok) /etc/cron.daily/rpm
567     %config(noreplace,missingok) /etc/logrotate.d/rpm
568    
569     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
570    
571     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
572    
573     %rpmdbattr /var/lib/rpm/Basenames
574     %rpmdbattr /var/lib/rpm/Conflictname
575     %rpmdbattr /var/lib/rpm/__db.0*
576     %rpmdbattr /var/lib/rpm/Dirnames
577     %rpmdbattr /var/lib/rpm/Group
578     %rpmdbattr /var/lib/rpm/Installtid
579     %rpmdbattr /var/lib/rpm/Name
580 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
581 tmb 343 %rpmdbattr /var/lib/rpm/Packages
582     %rpmdbattr /var/lib/rpm/Providename
583     %rpmdbattr /var/lib/rpm/Provideversion
584     %rpmdbattr /var/lib/rpm/Removetid
585     %rpmdbattr /var/lib/rpm/Requirename
586     %rpmdbattr /var/lib/rpm/Requireversion
587 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
588     %rpmdbattr /var/lib/rpm/Sigmd5
589 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
590    
591     %files build
592     %doc CHANGES
593     %doc doc-copy/*
594     %rpmattr %{_bindir}/rpmbuild
595 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
596 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
597     %rpmattr %{_prefix}/lib/rpm/check-files
598     %rpmattr %{_prefix}/lib/rpm/debugedit
599 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
600 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
601     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
602     %rpmattr %{_prefix}/lib/rpm/find-provides
603     %rpmattr %{_prefix}/lib/rpm/find-requires
604 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
605 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
606     %rpmattr %{_prefix}/lib/rpm/perl.prov
607     %rpmattr %{_prefix}/lib/rpm/perl.req
608    
609     %rpmattr %{_prefix}/lib/rpm/check-buildroot
610     %rpmattr %{_prefix}/lib/rpm/check-prereqs
611     %rpmattr %{_prefix}/lib/rpm/check-rpaths
612     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
613     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
614     %rpmattr %{_prefix}/lib/rpm/macros.perl
615     %rpmattr %{_prefix}/lib/rpm/macros.php
616     %rpmattr %{_prefix}/lib/rpm/macros.python
617     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
618     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
619 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
620     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
621 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
622     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
623    
624     %rpmattr %{_prefix}/lib/rpm/rpmdeps
625 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
626 tmb 343
627 tv 255921
628 tmb 343 %{_mandir}/man8/rpmbuild.8*
629     %{_mandir}/man8/rpmdeps.8*
630    
631     %if %buildpython
632     %files -n python-rpm
633     %{_libdir}/python*/site-packages/rpm
634     %endif
635    
636     %files -n %librpmname
637 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
638     %{_libdir}/librpmio.so.%{libmajor}*
639 dmorgan 185007 %if %{with plugins}
640     %{_libdir}/rpm-plugins
641     %endif
642    
643     %files -n %librpmbuild
644 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
645 tmb 343
646 dmorgan 185007 %files -n %librpmsign
647     %{_libdir}/librpmsign.so.%{libmajorsign}*
648    
649     %files sign
650     %{_bindir}/rpmsign
651     %{_mandir}/man8/rpmsign.8*
652    
653 tmb 343 %files -n %librpmnamedevel
654     %{_includedir}/rpm
655     %{_libdir}/librpm.so
656     %{_libdir}/librpmio.so
657     %{_libdir}/librpmbuild.so
658 dmorgan 185007 %{_libdir}/librpmsign.so
659 tmb 343 %{_libdir}/pkgconfig/rpm.pc
660 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30