/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 657813 - (hide annotations) (download)
Mon Jul 28 21:12:11 2014 UTC (9 years, 8 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21446 byte(s)
kill bogus comment (collections were removed upstream anyway) [SILENT]

1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 581966 %define rpmversion 4.11.2
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 colin 657571 Release: %mkrel %{?snapver:0.%{snapver}.}7
84 fwang 390713 Group: System/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
138 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
139 tv 215854 Patch134: extcond.diff
140 tmb 343
141 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
142 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
143     # implementation: as long as debugedit can just overwrite data in the elf
144     # sections things keep relatively easy, but if dest_dir is longer than the
145     # original directory, debugedit would have to expand the whole elf file. Which
146     # might be technically possible but debugedit currently does not even try to."
147 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
148 dmorgan 49378
149 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
150     # with this patch, "#%define foo bar" is a fatal error
151 dmorgan 185007 # Bug still valid => Send upstream for review.
152 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
153 tmb 343
154     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
155 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
156 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
157     Patch148: rpm-4.11.1-filetriggers-warnings.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161 colin 657571 #Patch149: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
209     # extraction of debuginfo can fail. This happens if you have a shared build dir
210     # which contains lots of subfolders for different packages (i.e. the default
211     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
212     # This fix simply uses the real build dir passed in as an argument to the script
213     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
214 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
215     # I suspect the real problem lies in the debugedit binary which I will debug further.
216     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
217     # still here after any reasonable length of time!)
218     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
219 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
220     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
221 tv 327195
222 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
223    
224 dmorgan 185007 License: GPLv2+
225     BuildRequires: autoconf
226 tmb 343 BuildRequires: zlib-devel
227     BuildRequires: bzip2-devel
228 tv 276213 BuildRequires: liblzma-devel >= 5
229 dmorgan 185007 BuildRequires: automake
230 tmb 343 BuildRequires: elfutils-devel
231     BuildRequires: libbeecrypt-devel
232 dmorgan 185007 BuildRequires: ed
233     BuildRequires: gettext-devel
234 tmb 343 BuildRequires: libsqlite3-devel
235 tv 276213 BuildRequires: db5.3-devel
236 tmb 343 BuildRequires: neon-devel
237     BuildRequires: popt-devel
238     BuildRequires: nss-devel
239     BuildRequires: magic-devel
240 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
241 tmb 343 BuildRequires: readline-devel
242     BuildRequires: ncurses-devel
243 dmorgan 185007 BuildRequires: openssl-devel
244 tv 641668 BuildRequires: lua5.2-devel >= 5.2.3-3.mga5
245 dmorgan 185007 BuildRequires: libcap-devel
246     # Needed for doc
247 tmb 343 #BuildRequires: graphviz
248 dmorgan 185007 BuildRequires: tetex
249 tmb 343 %if %buildpython
250     BuildRequires: python-devel
251     %endif
252 tv 223263 # for testsuite:
253 tv 641033 BuildRequires: eatmydata
254 tv 223263 BuildRequires: fakechroot
255 tmb 343
256     Requires: bzip2 >= 0.9.0c-2
257 tv 302008 Requires: xz
258 tmb 343 Requires: cpio
259     Requires: gawk
260     Requires: glibc >= 2.1.92
261     Requires: mktemp
262 tmb 345 Requires: setup >= 2.2.0-8
263 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
264 tmb 343 Requires: update-alternatives
265     Requires: %librpmname = %epoch:%version-%release
266     URL: http://rpm.org/
267     %define git_url http://rpm.org/git/rpm.git
268 dmorgan 185007 Requires(pre): rpm-helper
269 tmb 343 Requires(pre): coreutils
270 dmorgan 185007 Requires(postun): rpm-helper
271 tmb 343
272 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
273 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
274 dmorgan 185007
275 tmb 343 %description
276     RPM is a powerful command line driven package management system capable of
277     installing, uninstalling, verifying, querying, and updating software packages.
278     Each software package consists of an archive of files along with information
279     about the package like its version, a description, etc.
280    
281 dmorgan 185191 %package -n %librpmbuild
282     Summary: Libraries for building and signing RPM packages
283     Group: System/Libraries
284 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
285 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
286    
287     %description -n %librpmbuild
288     This package contains the RPM shared libraries for building and signing
289     packages.
290    
291     %package -n %librpmsign
292     Summary: Libraries for building and signing RPM packages
293     Group: System/Libraries
294    
295     %description -n %librpmsign
296     This package contains the RPM shared libraries for building and signing
297     packages.
298    
299 tmb 343 %package -n %librpmname
300 tmb 345 Summary: Library used by rpm
301     Group: System/Libraries
302     Provides: librpm = %version-%release
303 tv 641727 # for fixed lua:
304     Requires: %{mklibname lua 5.2} >= 5.2.3-3.mga5
305 tmb 343
306     %description -n %librpmname
307     RPM is a powerful command line driven package management system capable of
308     installing, uninstalling, verifying, querying, and updating software packages.
309     This package contains common files to all applications based on rpm.
310    
311     %package -n %librpmnamedevel
312     Summary: Development files for applications which will manipulate RPM packages
313     Group: Development/C
314     Requires: rpm = %epoch:%{version}-%{release}
315     Provides: librpm-devel = %version-%release
316     Provides: rpm-devel = %version-%release
317 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
318     Requires: %librpmbuild = %epoch:%version-%release
319     Requires: %librpmsign = %epoch:%version-%release
320 tmb 343
321     %description -n %librpmnamedevel
322     This package contains the RPM C library and header files. These
323     development files will simplify the process of writing programs
324     which manipulate RPM packages and databases and are intended to make
325     it easier to create graphical package managers or any other tools
326     that need an intimate knowledge of RPM packages in order to function.
327    
328     This package should be installed if you want to develop programs that
329     will manipulate RPM packages and databases.
330    
331     %package build
332     Summary: Scripts and executable programs used to build packages
333 fwang 390713 Group: System/Packaging
334 tmb 343 Requires: autoconf
335     Requires: automake
336     Requires: file
337     Requires: gcc-c++
338     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
339 dmorgan 185007 Requires: libtool-base
340     Requires: patch
341 tmb 343 Requires: make
342     Requires: tar
343     Requires: unzip
344     Requires: elfutils
345 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
346 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
347 dmorgan 185007 Requires: perl(YAML::Tiny)
348 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
349 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
350 tmb 343
351     %description build
352     This package contains scripts and executable programs that are used to
353     build packages using RPM.
354    
355 dmorgan 185007 %package sign
356     Summary: Package signing support
357     Group: System/Base
358    
359     %description sign
360     This package contains support for digitally signing RPM packages.
361    
362 tmb 343 %if %buildpython
363     %package -n python-rpm
364     Summary: Python bindings for apps which will manipulate RPM packages
365     Group: Development/Python
366     Requires: rpm = %epoch:%{version}-%{release}
367    
368     %description -n python-rpm
369     The rpm-python package contains a module which permits applications
370     written in the Python programming language to use the interface
371     supplied by RPM (RPM Package Manager) libraries.
372    
373     This package should be installed if you want to develop Python
374     programs that will manipulate RPM packages and databases.
375     %endif
376    
377     %prep
378     %setup -q -n %name-%srcver
379 dmorgan 186388 %apply_patches
380 tmb 343
381     %build
382 tv 447560 aclocal
383     automake-1.14 --add-missing
384     automake
385 tmb 343 autoreconf
386    
387     %if %builddebug
388     RPM_OPT_FLAGS=-g
389     %endif
390 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
391 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
392 fwang 215771 %configure2_5x \
393 tmb 343 --enable-nls \
394     --enable-python \
395     --enable-sqlite3 \
396     --without-javaglue \
397     %if %builddebug
398     --enable-debug \
399     %endif
400 dmorgan 185007 --with-external-db \
401 tmb 343 %if %buildpython
402     --with-python=%{pyver} \
403     %else
404     --without-python \
405     %endif
406 dmorgan 185007 %if ! %buildplugins
407     --disable-plugins \
408     %endif
409 tmb 343 --with-glob \
410     --without-selinux \
411 dmorgan 185007 --without-apidocs \
412     --with-cap
413 tmb 343
414     %make
415    
416     %install
417     make DESTDIR=%buildroot install
418    
419 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
420    
421 tmb 343 # Save list of packages through cron
422     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
423     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
424    
425     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
426     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
427    
428     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
429     for dbi in \
430     Basenames Conflictname Dirnames Group Installtid Name Providename \
431     Provideversion Removetid Requirename Requireversion Triggername \
432 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
433     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
434 tmb 343 do
435     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
436     done
437    
438     test -d doc-copy || mkdir doc-copy
439     rm -rf doc-copy/*
440     ln -f doc/manual/* doc-copy/
441     rm -f doc-copy/Makefile*
442    
443     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
444    
445     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
446     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
447     # Put your own system macros here
448     # usually contains
449    
450     # Set this one according your locales
451     # %%_install_langs
452    
453     EOF
454    
455     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
456    
457 tv 206214 %check
458 tv 641033 eatmydata make check
459 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
460 tv 206214
461 tmb 343 %pre
462     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
463    
464     rm -rf /usr/lib/rpm/*-mandrake-*
465 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
466 tmb 343
467 tmb 345
468 tmb 343 %post
469     # nuke __db.00? when updating to this rpm
470     rm -f /var/lib/rpm/__db.00?
471    
472 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
473 tmb 343 /bin/rpm --initdb
474     fi
475    
476     %postun
477     /usr/share/rpm-helper/del-user rpm $1 rpm
478    
479     %define rpmattr %attr(0755, rpm, rpm)
480    
481     %files -f %{name}.lang
482     %doc GROUPS CHANGES doc/manual/[a-z]*
483     %attr(0755,rpm,rpm) /bin/rpm
484     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
485     %attr(0755, rpm, rpm) %{_bindir}/gendiff
486     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
487 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
488 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
489 colin 490405 %{_bindir}/rpmquery
490     %{_bindir}/rpmverify
491 tmb 343
492     %dir %{_localstatedir}/spool/repackage
493     %dir %{rpmdir}
494     %dir /etc/rpm
495     %config(noreplace) /etc/rpm/macros
496     %dir /etc/rpm/macros.d
497     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
498     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
499     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
500     %attr(0644, rpm, rpm) %{rpmdir}/macros
501     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
502     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
503     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
504     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
505 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
506     %attr(0755, rpm, rpm) %{rpmdir}/script.req
507 tv 256610 %exclude %{rpmdir}/tcl.req
508 tmb 343
509     %rpmattr %{rpmdir}/rpm2cpio.sh
510     %rpmattr %{rpmdir}/tgpg
511    
512 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
513     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
514    
515 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
516     %ifarch %{ix86} x86_64
517     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
518     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
519     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
520     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
521 rtp 267694 %else
522 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
523     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
524     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
525     %exclude %{rpmdir}/platform/geode-%{_os}/macros
526 tmb 343 %endif
527     %ifarch x86_64
528     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
529     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
530     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
531 rtp 267694 %else
532 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
533     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
534     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
535 tmb 343 %endif
536     %ifarch %arm
537 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
538 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
539 tv 256613 %else
540     %exclude %{rpmdir}/platform/arm*/macros
541 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
542 tmb 343 %endif
543     %ifarch %mips
544     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
545     %endif
546     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
547 tv 256613 # new in 4.10.0:
548 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
549     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
550     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
551     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
552     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
553     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
554 tmb 343
555 tv 256613
556    
557 tmb 343 %{_mandir}/man[18]/*.[18]*
558     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
559     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
560     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
561     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
562     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
563     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
564    
565     %config(noreplace,missingok) /etc/cron.daily/rpm
566     %config(noreplace,missingok) /etc/logrotate.d/rpm
567    
568     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
569    
570     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
571    
572     %rpmdbattr /var/lib/rpm/Basenames
573     %rpmdbattr /var/lib/rpm/Conflictname
574     %rpmdbattr /var/lib/rpm/__db.0*
575     %rpmdbattr /var/lib/rpm/Dirnames
576     %rpmdbattr /var/lib/rpm/Group
577     %rpmdbattr /var/lib/rpm/Installtid
578     %rpmdbattr /var/lib/rpm/Name
579 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
580 tmb 343 %rpmdbattr /var/lib/rpm/Packages
581     %rpmdbattr /var/lib/rpm/Providename
582     %rpmdbattr /var/lib/rpm/Provideversion
583     %rpmdbattr /var/lib/rpm/Removetid
584     %rpmdbattr /var/lib/rpm/Requirename
585     %rpmdbattr /var/lib/rpm/Requireversion
586 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
587     %rpmdbattr /var/lib/rpm/Sigmd5
588 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
589    
590     %files build
591     %doc CHANGES
592     %doc doc-copy/*
593     %rpmattr %{_bindir}/rpmbuild
594 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
595 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
596     %rpmattr %{_prefix}/lib/rpm/check-files
597     %rpmattr %{_prefix}/lib/rpm/debugedit
598 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
599 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
600     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
601     %rpmattr %{_prefix}/lib/rpm/find-provides
602     %rpmattr %{_prefix}/lib/rpm/find-requires
603 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
604 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
605     %rpmattr %{_prefix}/lib/rpm/perl.prov
606     %rpmattr %{_prefix}/lib/rpm/perl.req
607    
608     %rpmattr %{_prefix}/lib/rpm/check-buildroot
609     %rpmattr %{_prefix}/lib/rpm/check-prereqs
610     %rpmattr %{_prefix}/lib/rpm/check-rpaths
611     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
612     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
613     %rpmattr %{_prefix}/lib/rpm/macros.perl
614     %rpmattr %{_prefix}/lib/rpm/macros.php
615     %rpmattr %{_prefix}/lib/rpm/macros.python
616     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
617     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
618 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
619     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
620 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
621     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
622    
623     %rpmattr %{_prefix}/lib/rpm/rpmdeps
624 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
625 tmb 343
626 tv 255921
627 tmb 343 %{_mandir}/man8/rpmbuild.8*
628     %{_mandir}/man8/rpmdeps.8*
629    
630     %if %buildpython
631     %files -n python-rpm
632     %{_libdir}/python*/site-packages/rpm
633     %endif
634    
635     %files -n %librpmname
636 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
637     %{_libdir}/librpmio.so.%{libmajor}*
638 dmorgan 185007 %if %{with plugins}
639     %{_libdir}/rpm-plugins
640     %endif
641    
642     %files -n %librpmbuild
643 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
644 tmb 343
645 dmorgan 185007 %files -n %librpmsign
646     %{_libdir}/librpmsign.so.%{libmajorsign}*
647    
648     %files sign
649     %{_bindir}/rpmsign
650     %{_mandir}/man8/rpmsign.8*
651    
652 tmb 343 %files -n %librpmnamedevel
653     %{_includedir}/rpm
654     %{_libdir}/librpm.so
655     %{_libdir}/librpmio.so
656     %{_libdir}/librpmbuild.so
657 dmorgan 185007 %{_libdir}/librpmsign.so
658 tmb 343 %{_libdir}/pkgconfig/rpm.pc
659 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30