/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 668829 - (hide annotations) (download)
Wed Aug 27 16:35:46 2014 UTC (9 years, 7 months ago) by tv
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 21419 byte(s)
drop "Requires: glibc >= 2.1.92" (mga has newer & glibc is autorequired)

1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 581966 %define rpmversion 4.11.2
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 colin 657571 Release: %mkrel %{?snapver:0.%{snapver}.}7
84 fwang 390713 Group: System/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 668828 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm plugin in 4.12):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
138 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
139 tv 215854 Patch134: extcond.diff
140 tmb 343
141 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
142 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
143     # implementation: as long as debugedit can just overwrite data in the elf
144     # sections things keep relatively easy, but if dest_dir is longer than the
145     # original directory, debugedit would have to expand the whole elf file. Which
146     # might be technically possible but debugedit currently does not even try to."
147 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
148 dmorgan 49378
149 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
150     # with this patch, "#%define foo bar" is a fatal error
151 dmorgan 185007 # Bug still valid => Send upstream for review.
152 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
153 tmb 343
154     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
155 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
156 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
157     Patch148: rpm-4.11.1-filetriggers-warnings.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161 colin 657571 #Patch149: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
209     # extraction of debuginfo can fail. This happens if you have a shared build dir
210     # which contains lots of subfolders for different packages (i.e. the default
211     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
212     # This fix simply uses the real build dir passed in as an argument to the script
213     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
214 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
215     # I suspect the real problem lies in the debugedit binary which I will debug further.
216     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
217     # still here after any reasonable length of time!)
218     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
219 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
220     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
221 tv 327195
222 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
223    
224 dmorgan 185007 License: GPLv2+
225     BuildRequires: autoconf
226 tmb 343 BuildRequires: zlib-devel
227     BuildRequires: bzip2-devel
228 tv 276213 BuildRequires: liblzma-devel >= 5
229 dmorgan 185007 BuildRequires: automake
230 tmb 343 BuildRequires: elfutils-devel
231     BuildRequires: libbeecrypt-devel
232 dmorgan 185007 BuildRequires: ed
233     BuildRequires: gettext-devel
234 tmb 343 BuildRequires: libsqlite3-devel
235 tv 276213 BuildRequires: db5.3-devel
236 tmb 343 BuildRequires: neon-devel
237     BuildRequires: popt-devel
238     BuildRequires: nss-devel
239     BuildRequires: magic-devel
240 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
241 tmb 343 BuildRequires: readline-devel
242     BuildRequires: ncurses-devel
243 dmorgan 185007 BuildRequires: openssl-devel
244 tv 641668 BuildRequires: lua5.2-devel >= 5.2.3-3.mga5
245 dmorgan 185007 BuildRequires: libcap-devel
246     # Needed for doc
247 tmb 343 #BuildRequires: graphviz
248 dmorgan 185007 BuildRequires: tetex
249 tmb 343 %if %buildpython
250     BuildRequires: python-devel
251     %endif
252 tv 223263 # for testsuite:
253 tv 641033 BuildRequires: eatmydata
254 tv 223263 BuildRequires: fakechroot
255 tmb 343
256     Requires: bzip2 >= 0.9.0c-2
257 tv 302008 Requires: xz
258 tmb 343 Requires: cpio
259     Requires: gawk
260     Requires: mktemp
261 tmb 345 Requires: setup >= 2.2.0-8
262 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
263 tmb 343 Requires: update-alternatives
264     Requires: %librpmname = %epoch:%version-%release
265     URL: http://rpm.org/
266     %define git_url http://rpm.org/git/rpm.git
267 dmorgan 185007 Requires(pre): rpm-helper
268 tmb 343 Requires(pre): coreutils
269 dmorgan 185007 Requires(postun): rpm-helper
270 tmb 343
271 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
272 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
273 dmorgan 185007
274 tmb 343 %description
275     RPM is a powerful command line driven package management system capable of
276     installing, uninstalling, verifying, querying, and updating software packages.
277     Each software package consists of an archive of files along with information
278     about the package like its version, a description, etc.
279    
280 dmorgan 185191 %package -n %librpmbuild
281     Summary: Libraries for building and signing RPM packages
282     Group: System/Libraries
283 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
284 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
285    
286     %description -n %librpmbuild
287     This package contains the RPM shared libraries for building and signing
288     packages.
289    
290     %package -n %librpmsign
291     Summary: Libraries for building and signing RPM packages
292     Group: System/Libraries
293    
294     %description -n %librpmsign
295     This package contains the RPM shared libraries for building and signing
296     packages.
297    
298 tmb 343 %package -n %librpmname
299 tmb 345 Summary: Library used by rpm
300     Group: System/Libraries
301     Provides: librpm = %version-%release
302 tv 641727 # for fixed lua:
303     Requires: %{mklibname lua 5.2} >= 5.2.3-3.mga5
304 tmb 343
305     %description -n %librpmname
306     RPM is a powerful command line driven package management system capable of
307     installing, uninstalling, verifying, querying, and updating software packages.
308     This package contains common files to all applications based on rpm.
309    
310     %package -n %librpmnamedevel
311     Summary: Development files for applications which will manipulate RPM packages
312     Group: Development/C
313     Requires: rpm = %epoch:%{version}-%{release}
314     Provides: librpm-devel = %version-%release
315     Provides: rpm-devel = %version-%release
316 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
317     Requires: %librpmbuild = %epoch:%version-%release
318     Requires: %librpmsign = %epoch:%version-%release
319 tmb 343
320     %description -n %librpmnamedevel
321     This package contains the RPM C library and header files. These
322     development files will simplify the process of writing programs
323     which manipulate RPM packages and databases and are intended to make
324     it easier to create graphical package managers or any other tools
325     that need an intimate knowledge of RPM packages in order to function.
326    
327     This package should be installed if you want to develop programs that
328     will manipulate RPM packages and databases.
329    
330     %package build
331     Summary: Scripts and executable programs used to build packages
332 fwang 390713 Group: System/Packaging
333 tmb 343 Requires: autoconf
334     Requires: automake
335     Requires: file
336     Requires: gcc-c++
337     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
338 dmorgan 185007 Requires: libtool-base
339     Requires: patch
340 tmb 343 Requires: make
341     Requires: tar
342     Requires: unzip
343     Requires: elfutils
344 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
345 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
346 dmorgan 185007 Requires: perl(YAML::Tiny)
347 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
348 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
349 tmb 343
350     %description build
351     This package contains scripts and executable programs that are used to
352     build packages using RPM.
353    
354 dmorgan 185007 %package sign
355     Summary: Package signing support
356     Group: System/Base
357    
358     %description sign
359     This package contains support for digitally signing RPM packages.
360    
361 tmb 343 %if %buildpython
362     %package -n python-rpm
363     Summary: Python bindings for apps which will manipulate RPM packages
364     Group: Development/Python
365     Requires: rpm = %epoch:%{version}-%{release}
366    
367     %description -n python-rpm
368     The rpm-python package contains a module which permits applications
369     written in the Python programming language to use the interface
370     supplied by RPM (RPM Package Manager) libraries.
371    
372     This package should be installed if you want to develop Python
373     programs that will manipulate RPM packages and databases.
374     %endif
375    
376     %prep
377     %setup -q -n %name-%srcver
378 dmorgan 186388 %apply_patches
379 tmb 343
380     %build
381 tv 447560 aclocal
382     automake-1.14 --add-missing
383     automake
384 tmb 343 autoreconf
385    
386     %if %builddebug
387     RPM_OPT_FLAGS=-g
388     %endif
389 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
390 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
391 fwang 215771 %configure2_5x \
392 tmb 343 --enable-nls \
393     --enable-python \
394     --enable-sqlite3 \
395     --without-javaglue \
396     %if %builddebug
397     --enable-debug \
398     %endif
399 dmorgan 185007 --with-external-db \
400 tmb 343 %if %buildpython
401     --with-python=%{pyver} \
402     %else
403     --without-python \
404     %endif
405 dmorgan 185007 %if ! %buildplugins
406     --disable-plugins \
407     %endif
408 tmb 343 --with-glob \
409     --without-selinux \
410 dmorgan 185007 --without-apidocs \
411     --with-cap
412 tmb 343
413     %make
414    
415     %install
416     make DESTDIR=%buildroot install
417    
418 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
419    
420 tmb 343 # Save list of packages through cron
421     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
422     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
423    
424     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
425     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
426    
427     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
428     for dbi in \
429     Basenames Conflictname Dirnames Group Installtid Name Providename \
430     Provideversion Removetid Requirename Requireversion Triggername \
431 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
432     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
433 tmb 343 do
434     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
435     done
436    
437     test -d doc-copy || mkdir doc-copy
438     rm -rf doc-copy/*
439     ln -f doc/manual/* doc-copy/
440     rm -f doc-copy/Makefile*
441    
442     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
443    
444     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
445     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
446     # Put your own system macros here
447     # usually contains
448    
449     # Set this one according your locales
450     # %%_install_langs
451    
452     EOF
453    
454     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
455    
456 tv 206214 %check
457 tv 641033 eatmydata make check
458 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
459 tv 206214
460 tmb 343 %pre
461     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
462    
463     rm -rf /usr/lib/rpm/*-mandrake-*
464 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
465 tmb 343
466 tmb 345
467 tmb 343 %post
468     # nuke __db.00? when updating to this rpm
469     rm -f /var/lib/rpm/__db.00?
470    
471 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
472 tmb 343 /bin/rpm --initdb
473     fi
474    
475     %postun
476     /usr/share/rpm-helper/del-user rpm $1 rpm
477    
478     %define rpmattr %attr(0755, rpm, rpm)
479    
480     %files -f %{name}.lang
481     %doc GROUPS CHANGES doc/manual/[a-z]*
482     %attr(0755,rpm,rpm) /bin/rpm
483     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
484     %attr(0755, rpm, rpm) %{_bindir}/gendiff
485     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
486 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
487 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
488 colin 490405 %{_bindir}/rpmquery
489     %{_bindir}/rpmverify
490 tmb 343
491     %dir %{_localstatedir}/spool/repackage
492     %dir %{rpmdir}
493     %dir /etc/rpm
494     %config(noreplace) /etc/rpm/macros
495     %dir /etc/rpm/macros.d
496     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
497     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
498     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
499     %attr(0644, rpm, rpm) %{rpmdir}/macros
500     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
501     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
502     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
503     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
504 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
505     %attr(0755, rpm, rpm) %{rpmdir}/script.req
506 tv 256610 %exclude %{rpmdir}/tcl.req
507 tmb 343
508     %rpmattr %{rpmdir}/rpm2cpio.sh
509     %rpmattr %{rpmdir}/tgpg
510    
511 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
512     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
513    
514 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
515     %ifarch %{ix86} x86_64
516     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
517     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
518     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
519     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
520 rtp 267694 %else
521 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
522     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
523     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
524     %exclude %{rpmdir}/platform/geode-%{_os}/macros
525 tmb 343 %endif
526     %ifarch x86_64
527     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
528     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
529     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
530 rtp 267694 %else
531 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
532     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
533     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
534 tmb 343 %endif
535     %ifarch %arm
536 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
537 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
538 tv 256613 %else
539     %exclude %{rpmdir}/platform/arm*/macros
540 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
541 tmb 343 %endif
542     %ifarch %mips
543     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
544     %endif
545     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
546 tv 256613 # new in 4.10.0:
547 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
548     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
549     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
550     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
551     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
552     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
553 tmb 343
554 tv 256613
555    
556 tmb 343 %{_mandir}/man[18]/*.[18]*
557     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
558     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
559     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
560     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
561     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
562     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
563    
564     %config(noreplace,missingok) /etc/cron.daily/rpm
565     %config(noreplace,missingok) /etc/logrotate.d/rpm
566    
567     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
568    
569     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
570    
571     %rpmdbattr /var/lib/rpm/Basenames
572     %rpmdbattr /var/lib/rpm/Conflictname
573     %rpmdbattr /var/lib/rpm/__db.0*
574     %rpmdbattr /var/lib/rpm/Dirnames
575     %rpmdbattr /var/lib/rpm/Group
576     %rpmdbattr /var/lib/rpm/Installtid
577     %rpmdbattr /var/lib/rpm/Name
578 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
579 tmb 343 %rpmdbattr /var/lib/rpm/Packages
580     %rpmdbattr /var/lib/rpm/Providename
581     %rpmdbattr /var/lib/rpm/Provideversion
582     %rpmdbattr /var/lib/rpm/Removetid
583     %rpmdbattr /var/lib/rpm/Requirename
584     %rpmdbattr /var/lib/rpm/Requireversion
585 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
586     %rpmdbattr /var/lib/rpm/Sigmd5
587 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
588    
589     %files build
590     %doc CHANGES
591     %doc doc-copy/*
592     %rpmattr %{_bindir}/rpmbuild
593 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
594 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
595     %rpmattr %{_prefix}/lib/rpm/check-files
596     %rpmattr %{_prefix}/lib/rpm/debugedit
597 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
598 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
599     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
600     %rpmattr %{_prefix}/lib/rpm/find-provides
601     %rpmattr %{_prefix}/lib/rpm/find-requires
602 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
603 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
604     %rpmattr %{_prefix}/lib/rpm/perl.prov
605     %rpmattr %{_prefix}/lib/rpm/perl.req
606    
607     %rpmattr %{_prefix}/lib/rpm/check-buildroot
608     %rpmattr %{_prefix}/lib/rpm/check-prereqs
609     %rpmattr %{_prefix}/lib/rpm/check-rpaths
610     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
611     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
612     %rpmattr %{_prefix}/lib/rpm/macros.perl
613     %rpmattr %{_prefix}/lib/rpm/macros.php
614     %rpmattr %{_prefix}/lib/rpm/macros.python
615     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
616     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
617 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
618     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
619 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
620     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
621    
622     %rpmattr %{_prefix}/lib/rpm/rpmdeps
623 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
624 tmb 343
625 tv 255921
626 tmb 343 %{_mandir}/man8/rpmbuild.8*
627     %{_mandir}/man8/rpmdeps.8*
628    
629     %if %buildpython
630     %files -n python-rpm
631     %{_libdir}/python*/site-packages/rpm
632     %endif
633    
634     %files -n %librpmname
635 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
636     %{_libdir}/librpmio.so.%{libmajor}*
637 dmorgan 185007 %if %{with plugins}
638     %{_libdir}/rpm-plugins
639     %endif
640    
641     %files -n %librpmbuild
642 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
643 tmb 343
644 dmorgan 185007 %files -n %librpmsign
645     %{_libdir}/librpmsign.so.%{libmajorsign}*
646    
647     %files sign
648     %{_bindir}/rpmsign
649     %{_mandir}/man8/rpmsign.8*
650    
651 tmb 343 %files -n %librpmnamedevel
652     %{_includedir}/rpm
653     %{_libdir}/librpm.so
654     %{_libdir}/librpmio.so
655     %{_libdir}/librpmbuild.so
656 dmorgan 185007 %{_libdir}/librpmsign.so
657 tmb 343 %{_libdir}/pkgconfig/rpm.pc
658 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30