/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 672721 - (hide annotations) (download)
Sat Sep 6 14:58:54 2014 UTC (9 years, 7 months ago) by tv
Original Path: cauldron/rpm/branches/4.11.x-new-weakdeps/current/SPECS/rpm.spec
File size: 21333 byte(s)
branch

1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 672411 %define rpmversion 4.11.3
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 tv 672411 Release: %mkrel %{?snapver:0.%{snapver}.}1
84 fwang 390713 Group: System/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 668828 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm plugin in 4.12):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
138 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
139 tv 215854 Patch134: extcond.diff
140 tmb 343
141 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
142 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
143     # implementation: as long as debugedit can just overwrite data in the elf
144     # sections things keep relatively easy, but if dest_dir is longer than the
145     # original directory, debugedit would have to expand the whole elf file. Which
146     # might be technically possible but debugedit currently does not even try to."
147 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
148 dmorgan 49378
149 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
150     # with this patch, "#%define foo bar" is a fatal error
151 dmorgan 185007 # Bug still valid => Send upstream for review.
152 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
153 tmb 343
154     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
155 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
156 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
157     Patch148: rpm-4.11.1-filetriggers-warnings.patch
158 tmb 343
159     # (nb: see the patch for more info about this issue)
160 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
161 tmb 343
162 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
163 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
164 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
165 tmb 343
166     Patch1007: rpm-4.6.0-rc3-xz-support.patch
167    
168     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
169     # as this breaks stuff that installs files to $DOCDIR during %%install
170 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
171 tmb 343
172     # Turbolinux patches
173     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
174     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
175    
176 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
177 dmorgan 49378
178 tv 262316 # (tv) fix tests:
179 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
180 tv 255921
181 tmb 343 Patch3000: mips_macros.patch
182 tv 256616 Patch3002: mips_define_isa_macros.patch
183     Patch3003: rpm_arm_mips_isa_macros.patch
184     Patch3004: rpm_add_armv5tl.patch
185 tmb 343
186 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
187     # and not full path
188 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
189 tv 223198 #
190 dmorgan 185007 # Fedora patches
191 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
192     #
193 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
194     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
195 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
196 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
197 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
198 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
199 dmorgan 185007
200 tv 669980 # Mageia patches that are easier to rediff on top of FC patches:
201     #---------------------------------------------------------------
202 tv 276795 # (tv) merge mga stuff from rpm-setup:
203     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
204 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
205     # extraction of debuginfo can fail. This happens if you have a shared build dir
206     # which contains lots of subfolders for different packages (i.e. the default
207     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
208     # This fix simply uses the real build dir passed in as an argument to the script
209     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
210 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
211     # I suspect the real problem lies in the debugedit binary which I will debug further.
212     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
213     # still here after any reasonable length of time!)
214     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
215 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
216     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
217 tv 327195
218 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
219    
220 dmorgan 185007 License: GPLv2+
221     BuildRequires: autoconf
222 tmb 343 BuildRequires: zlib-devel
223     BuildRequires: bzip2-devel
224 tv 276213 BuildRequires: liblzma-devel >= 5
225 dmorgan 185007 BuildRequires: automake
226 tmb 343 BuildRequires: elfutils-devel
227     BuildRequires: libbeecrypt-devel
228 dmorgan 185007 BuildRequires: ed
229     BuildRequires: gettext-devel
230 tmb 343 BuildRequires: libsqlite3-devel
231 tv 276213 BuildRequires: db5.3-devel
232 tmb 343 BuildRequires: neon-devel
233     BuildRequires: popt-devel
234     BuildRequires: nss-devel
235     BuildRequires: magic-devel
236 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
237 tmb 343 BuildRequires: readline-devel
238     BuildRequires: ncurses-devel
239 dmorgan 185007 BuildRequires: openssl-devel
240 tv 641668 BuildRequires: lua5.2-devel >= 5.2.3-3.mga5
241 dmorgan 185007 BuildRequires: libcap-devel
242     # Needed for doc
243 tmb 343 #BuildRequires: graphviz
244 dmorgan 185007 BuildRequires: tetex
245 tmb 343 %if %buildpython
246     BuildRequires: python-devel
247     %endif
248 tv 223263 # for testsuite:
249 tv 641033 BuildRequires: eatmydata
250 tv 672609 BuildRequires: fakeroot
251 tmb 343
252     Requires: bzip2 >= 0.9.0c-2
253 tv 302008 Requires: xz
254 tmb 343 Requires: cpio
255     Requires: gawk
256     Requires: mktemp
257 tmb 345 Requires: setup >= 2.2.0-8
258 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
259 tmb 343 Requires: update-alternatives
260     Requires: %librpmname = %epoch:%version-%release
261     URL: http://rpm.org/
262     %define git_url http://rpm.org/git/rpm.git
263 dmorgan 185007 Requires(pre): rpm-helper
264 tmb 343 Requires(pre): coreutils
265 dmorgan 185007 Requires(postun): rpm-helper
266 tmb 343
267 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
268 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
269 dmorgan 185007
270 tmb 343 %description
271     RPM is a powerful command line driven package management system capable of
272     installing, uninstalling, verifying, querying, and updating software packages.
273     Each software package consists of an archive of files along with information
274     about the package like its version, a description, etc.
275    
276 dmorgan 185191 %package -n %librpmbuild
277     Summary: Libraries for building and signing RPM packages
278     Group: System/Libraries
279 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
280 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
281    
282     %description -n %librpmbuild
283     This package contains the RPM shared libraries for building and signing
284     packages.
285    
286     %package -n %librpmsign
287     Summary: Libraries for building and signing RPM packages
288     Group: System/Libraries
289    
290     %description -n %librpmsign
291     This package contains the RPM shared libraries for building and signing
292     packages.
293    
294 tmb 343 %package -n %librpmname
295 tmb 345 Summary: Library used by rpm
296     Group: System/Libraries
297     Provides: librpm = %version-%release
298 tv 641727 # for fixed lua:
299     Requires: %{mklibname lua 5.2} >= 5.2.3-3.mga5
300 tmb 343
301     %description -n %librpmname
302     RPM is a powerful command line driven package management system capable of
303     installing, uninstalling, verifying, querying, and updating software packages.
304     This package contains common files to all applications based on rpm.
305    
306     %package -n %librpmnamedevel
307     Summary: Development files for applications which will manipulate RPM packages
308     Group: Development/C
309     Requires: rpm = %epoch:%{version}-%{release}
310     Provides: librpm-devel = %version-%release
311     Provides: rpm-devel = %version-%release
312 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
313     Requires: %librpmbuild = %epoch:%version-%release
314     Requires: %librpmsign = %epoch:%version-%release
315 tmb 343
316     %description -n %librpmnamedevel
317     This package contains the RPM C library and header files. These
318     development files will simplify the process of writing programs
319     which manipulate RPM packages and databases and are intended to make
320     it easier to create graphical package managers or any other tools
321     that need an intimate knowledge of RPM packages in order to function.
322    
323     This package should be installed if you want to develop programs that
324     will manipulate RPM packages and databases.
325    
326     %package build
327     Summary: Scripts and executable programs used to build packages
328 fwang 390713 Group: System/Packaging
329 tmb 343 Requires: autoconf
330     Requires: automake
331     Requires: file
332     Requires: gcc-c++
333     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
334 dmorgan 185007 Requires: libtool-base
335     Requires: patch
336 tmb 343 Requires: make
337     Requires: tar
338     Requires: unzip
339     Requires: elfutils
340 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
341 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
342 dmorgan 185007 Requires: perl(YAML::Tiny)
343 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
344 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
345 tmb 343
346     %description build
347     This package contains scripts and executable programs that are used to
348     build packages using RPM.
349    
350 dmorgan 185007 %package sign
351     Summary: Package signing support
352     Group: System/Base
353    
354     %description sign
355     This package contains support for digitally signing RPM packages.
356    
357 tmb 343 %if %buildpython
358     %package -n python-rpm
359     Summary: Python bindings for apps which will manipulate RPM packages
360     Group: Development/Python
361     Requires: rpm = %epoch:%{version}-%{release}
362    
363     %description -n python-rpm
364     The rpm-python package contains a module which permits applications
365     written in the Python programming language to use the interface
366     supplied by RPM (RPM Package Manager) libraries.
367    
368     This package should be installed if you want to develop Python
369     programs that will manipulate RPM packages and databases.
370     %endif
371    
372     %prep
373     %setup -q -n %name-%srcver
374 dmorgan 186388 %apply_patches
375 tmb 343
376     %build
377 tv 447560 aclocal
378     automake-1.14 --add-missing
379     automake
380 tmb 343 autoreconf
381    
382     %if %builddebug
383     RPM_OPT_FLAGS=-g
384     %endif
385 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
386 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
387 fwang 215771 %configure2_5x \
388 tmb 343 --enable-nls \
389     --enable-python \
390     --enable-sqlite3 \
391     --without-javaglue \
392     %if %builddebug
393     --enable-debug \
394     %endif
395 dmorgan 185007 --with-external-db \
396 tmb 343 %if %buildpython
397     --with-python=%{pyver} \
398     %else
399     --without-python \
400     %endif
401 dmorgan 185007 %if ! %buildplugins
402     --disable-plugins \
403     %endif
404 tmb 343 --with-glob \
405     --without-selinux \
406 dmorgan 185007 --without-apidocs \
407     --with-cap
408 tmb 343
409     %make
410    
411     %install
412     make DESTDIR=%buildroot install
413    
414 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
415    
416 tmb 343 # Save list of packages through cron
417     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
418     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
419    
420     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
421     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
422    
423     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
424     for dbi in \
425     Basenames Conflictname Dirnames Group Installtid Name Providename \
426     Provideversion Removetid Requirename Requireversion Triggername \
427 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
428     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
429 tmb 343 do
430     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
431     done
432    
433     test -d doc-copy || mkdir doc-copy
434     rm -rf doc-copy/*
435     ln -f doc/manual/* doc-copy/
436     rm -f doc-copy/Makefile*
437    
438     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
439    
440     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
441     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
442     # Put your own system macros here
443     # usually contains
444    
445     # Set this one according your locales
446     # %%_install_langs
447    
448     EOF
449    
450     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
451    
452 tv 206214 %check
453 tv 641033 eatmydata make check
454 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
455 tv 206214
456 tmb 343 %pre
457     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
458    
459     rm -rf /usr/lib/rpm/*-mandrake-*
460 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
461 tmb 343
462 tmb 345
463 tmb 343 %post
464     # nuke __db.00? when updating to this rpm
465     rm -f /var/lib/rpm/__db.00?
466    
467 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
468 tmb 343 /bin/rpm --initdb
469     fi
470    
471     %postun
472     /usr/share/rpm-helper/del-user rpm $1 rpm
473    
474     %define rpmattr %attr(0755, rpm, rpm)
475    
476     %files -f %{name}.lang
477     %doc GROUPS CHANGES doc/manual/[a-z]*
478     %attr(0755,rpm,rpm) /bin/rpm
479     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
480     %attr(0755, rpm, rpm) %{_bindir}/gendiff
481     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
482 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
483 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
484 colin 490405 %{_bindir}/rpmquery
485     %{_bindir}/rpmverify
486 tmb 343
487     %dir %{_localstatedir}/spool/repackage
488     %dir %{rpmdir}
489     %dir /etc/rpm
490     %config(noreplace) /etc/rpm/macros
491     %dir /etc/rpm/macros.d
492     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
493     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
494     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
495     %attr(0644, rpm, rpm) %{rpmdir}/macros
496     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
497     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
498     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
499     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
500 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
501     %attr(0755, rpm, rpm) %{rpmdir}/script.req
502 tv 256610 %exclude %{rpmdir}/tcl.req
503 tmb 343
504     %rpmattr %{rpmdir}/rpm2cpio.sh
505     %rpmattr %{rpmdir}/tgpg
506    
507 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
508     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
509    
510 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
511     %ifarch %{ix86} x86_64
512     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
513     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
514     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
515     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
516 rtp 267694 %else
517 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
518     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
519     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
520     %exclude %{rpmdir}/platform/geode-%{_os}/macros
521 tmb 343 %endif
522     %ifarch x86_64
523     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
524     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
525     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
526 rtp 267694 %else
527 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
528     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
529     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
530 tmb 343 %endif
531     %ifarch %arm
532 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
533 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
534 tv 256613 %else
535     %exclude %{rpmdir}/platform/arm*/macros
536 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
537 tmb 343 %endif
538     %ifarch %mips
539     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
540     %endif
541     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
542 tv 256613 # new in 4.10.0:
543 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
544     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
545     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
546 tv 672469 %exclude %{rpmdir}/platform/m68k*-%{_os}/macros
547 kamil 469312 %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
548     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
549     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
550 tmb 343
551 tv 256613
552    
553 tmb 343 %{_mandir}/man[18]/*.[18]*
554     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
555     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
556     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
557     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
558     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
559     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
560    
561     %config(noreplace,missingok) /etc/cron.daily/rpm
562     %config(noreplace,missingok) /etc/logrotate.d/rpm
563    
564     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
565    
566     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
567    
568     %rpmdbattr /var/lib/rpm/Basenames
569     %rpmdbattr /var/lib/rpm/Conflictname
570     %rpmdbattr /var/lib/rpm/__db.0*
571     %rpmdbattr /var/lib/rpm/Dirnames
572     %rpmdbattr /var/lib/rpm/Group
573     %rpmdbattr /var/lib/rpm/Installtid
574     %rpmdbattr /var/lib/rpm/Name
575 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
576 tmb 343 %rpmdbattr /var/lib/rpm/Packages
577     %rpmdbattr /var/lib/rpm/Providename
578     %rpmdbattr /var/lib/rpm/Provideversion
579     %rpmdbattr /var/lib/rpm/Removetid
580     %rpmdbattr /var/lib/rpm/Requirename
581     %rpmdbattr /var/lib/rpm/Requireversion
582 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
583     %rpmdbattr /var/lib/rpm/Sigmd5
584 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
585    
586     %files build
587     %doc CHANGES
588     %doc doc-copy/*
589     %rpmattr %{_bindir}/rpmbuild
590 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
591 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
592     %rpmattr %{_prefix}/lib/rpm/check-files
593     %rpmattr %{_prefix}/lib/rpm/debugedit
594 tv 672469 %rpmattr %{_prefix}/lib/rpm/*.prov
595 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
596     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
597     %rpmattr %{_prefix}/lib/rpm/find-provides
598     %rpmattr %{_prefix}/lib/rpm/find-requires
599     %rpmattr %{_prefix}/lib/rpm/perldeps.pl
600     %rpmattr %{_prefix}/lib/rpm/perl.req
601    
602     %rpmattr %{_prefix}/lib/rpm/check-buildroot
603     %rpmattr %{_prefix}/lib/rpm/check-prereqs
604     %rpmattr %{_prefix}/lib/rpm/check-rpaths
605     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
606     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
607     %rpmattr %{_prefix}/lib/rpm/macros.perl
608     %rpmattr %{_prefix}/lib/rpm/macros.php
609     %rpmattr %{_prefix}/lib/rpm/macros.python
610     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
611     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
612 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
613     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
614 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
615     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
616    
617     %rpmattr %{_prefix}/lib/rpm/rpmdeps
618 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
619 tmb 343
620 tv 255921
621 tmb 343 %{_mandir}/man8/rpmbuild.8*
622     %{_mandir}/man8/rpmdeps.8*
623    
624     %if %buildpython
625     %files -n python-rpm
626     %{_libdir}/python*/site-packages/rpm
627     %endif
628    
629     %files -n %librpmname
630 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
631     %{_libdir}/librpmio.so.%{libmajor}*
632 tv 669979 %if %buildplugins
633 dmorgan 185007 %{_libdir}/rpm-plugins
634     %endif
635    
636     %files -n %librpmbuild
637 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
638 tmb 343
639 dmorgan 185007 %files -n %librpmsign
640     %{_libdir}/librpmsign.so.%{libmajorsign}*
641    
642     %files sign
643     %{_bindir}/rpmsign
644     %{_mandir}/man8/rpmsign.8*
645    
646 tmb 343 %files -n %librpmnamedevel
647     %{_includedir}/rpm
648     %{_libdir}/librpm.so
649     %{_libdir}/librpmio.so
650     %{_libdir}/librpmbuild.so
651 dmorgan 185007 %{_libdir}/librpmsign.so
652 tmb 343 %{_libdir}/pkgconfig/rpm.pc
653 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30