/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 675399 - (hide annotations) (download)
Sun Sep 14 13:39:19 2014 UTC (9 years, 7 months ago) by tv
File size: 21460 byte(s)
relax requires

1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 672411 %define rpmversion 4.11.3
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 tv 675214 Release: %mkrel %{?snapver:0.%{snapver}.}1.2
84 fwang 390713 Group: System/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 668828 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm plugin in 4.12):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137 tv 672732 # [from 4.12.0] handle "Suggests" via RPMTAG_SUGGESTNAME
138     Patch132: newweakdeps.diff
139     Patch133: exportoldtags.patch
140     Patch134: weakdepscompat.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
157 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
158     Patch148: rpm-4.11.1-filetriggers-warnings.patch
159 tmb 343
160     # (nb: see the patch for more info about this issue)
161 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
162 tmb 343
163 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
164 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
165 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
166 tmb 343
167     Patch1007: rpm-4.6.0-rc3-xz-support.patch
168    
169     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
170     # as this breaks stuff that installs files to $DOCDIR during %%install
171 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
172 tmb 343
173     # Turbolinux patches
174     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
175     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
176    
177 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
178 dmorgan 49378
179 tv 262316 # (tv) fix tests:
180 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
181 tv 255921
182 tmb 343 Patch3000: mips_macros.patch
183 tv 256616 Patch3002: mips_define_isa_macros.patch
184     Patch3003: rpm_arm_mips_isa_macros.patch
185     Patch3004: rpm_add_armv5tl.patch
186 tmb 343
187 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
188     # and not full path
189 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
190 tv 223198 #
191 dmorgan 185007 # Fedora patches
192 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
193     #
194 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
195     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
196 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
197 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
198 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
199 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
200 dmorgan 185007
201 tv 669980 # Mageia patches that are easier to rediff on top of FC patches:
202     #---------------------------------------------------------------
203 tv 276795 # (tv) merge mga stuff from rpm-setup:
204     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
205 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
206     # extraction of debuginfo can fail. This happens if you have a shared build dir
207     # which contains lots of subfolders for different packages (i.e. the default
208     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
209     # This fix simply uses the real build dir passed in as an argument to the script
210     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
211 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
212     # I suspect the real problem lies in the debugedit binary which I will debug further.
213     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
214     # still here after any reasonable length of time!)
215     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
216 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
217     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
218 tv 327195
219 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
220 tv 672732 # (tv) make old suggests be equivalent to recommends:
221     Patch4010: rpm-4.12.0-oldsuggest_equals_recommends.patch
222 tv 674935 Patch4012: rpm-mga-suggests.diff
223 dmorgan 621327
224 dmorgan 185007 License: GPLv2+
225     BuildRequires: autoconf
226 tmb 343 BuildRequires: zlib-devel
227     BuildRequires: bzip2-devel
228 tv 675399 BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
229 dmorgan 185007 BuildRequires: automake
230 tmb 343 BuildRequires: elfutils-devel
231     BuildRequires: libbeecrypt-devel
232 dmorgan 185007 BuildRequires: ed
233     BuildRequires: gettext-devel
234 tmb 343 BuildRequires: libsqlite3-devel
235 tv 675399 BuildRequires: db4.8-devel
236 tmb 343 BuildRequires: neon-devel
237     BuildRequires: popt-devel
238     BuildRequires: nss-devel
239     BuildRequires: magic-devel
240 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
241 tmb 343 BuildRequires: readline-devel
242     BuildRequires: ncurses-devel
243 dmorgan 185007 BuildRequires: openssl-devel
244 tv 675399 BuildRequires: lua-devel
245 dmorgan 185007 BuildRequires: libcap-devel
246     # Needed for doc
247 tmb 343 #BuildRequires: graphviz
248 dmorgan 185007 BuildRequires: tetex
249 tmb 343 %if %buildpython
250     BuildRequires: python-devel
251     %endif
252 tv 223263 # for testsuite:
253 tv 641033 BuildRequires: eatmydata
254 tv 674498 BuildRequires: fakechroot
255 tmb 343
256     Requires: bzip2 >= 0.9.0c-2
257 tv 675399 Requires: lzma
258 tmb 343 Requires: cpio
259     Requires: gawk
260     Requires: mktemp
261 tmb 345 Requires: setup >= 2.2.0-8
262 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
263 tmb 343 Requires: update-alternatives
264     Requires: %librpmname = %epoch:%version-%release
265     URL: http://rpm.org/
266     %define git_url http://rpm.org/git/rpm.git
267 dmorgan 185007 Requires(pre): rpm-helper
268 tmb 343 Requires(pre): coreutils
269 dmorgan 185007 Requires(postun): rpm-helper
270 tmb 343
271 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
272 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
273 dmorgan 185007
274 tmb 343 %description
275     RPM is a powerful command line driven package management system capable of
276     installing, uninstalling, verifying, querying, and updating software packages.
277     Each software package consists of an archive of files along with information
278     about the package like its version, a description, etc.
279    
280 dmorgan 185191 %package -n %librpmbuild
281     Summary: Libraries for building and signing RPM packages
282     Group: System/Libraries
283 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
284 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
285    
286     %description -n %librpmbuild
287     This package contains the RPM shared libraries for building and signing
288     packages.
289    
290     %package -n %librpmsign
291     Summary: Libraries for building and signing RPM packages
292     Group: System/Libraries
293    
294     %description -n %librpmsign
295     This package contains the RPM shared libraries for building and signing
296     packages.
297    
298 tmb 343 %package -n %librpmname
299 tmb 345 Summary: Library used by rpm
300     Group: System/Libraries
301     Provides: librpm = %version-%release
302 tmb 343
303     %description -n %librpmname
304     RPM is a powerful command line driven package management system capable of
305     installing, uninstalling, verifying, querying, and updating software packages.
306     This package contains common files to all applications based on rpm.
307    
308     %package -n %librpmnamedevel
309     Summary: Development files for applications which will manipulate RPM packages
310     Group: Development/C
311     Requires: rpm = %epoch:%{version}-%{release}
312     Provides: librpm-devel = %version-%release
313     Provides: rpm-devel = %version-%release
314 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
315     Requires: %librpmbuild = %epoch:%version-%release
316     Requires: %librpmsign = %epoch:%version-%release
317 tmb 343
318     %description -n %librpmnamedevel
319     This package contains the RPM C library and header files. These
320     development files will simplify the process of writing programs
321     which manipulate RPM packages and databases and are intended to make
322     it easier to create graphical package managers or any other tools
323     that need an intimate knowledge of RPM packages in order to function.
324    
325     This package should be installed if you want to develop programs that
326     will manipulate RPM packages and databases.
327    
328     %package build
329     Summary: Scripts and executable programs used to build packages
330 fwang 390713 Group: System/Packaging
331 tmb 343 Requires: autoconf
332     Requires: automake
333     Requires: file
334     Requires: gcc-c++
335     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
336 dmorgan 185007 Requires: libtool-base
337     Requires: patch
338 tmb 343 Requires: make
339     Requires: tar
340     Requires: unzip
341     Requires: elfutils
342 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
343 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
344 dmorgan 185007 Requires: perl(YAML::Tiny)
345 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
346 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
347 tmb 343
348     %description build
349     This package contains scripts and executable programs that are used to
350     build packages using RPM.
351    
352 dmorgan 185007 %package sign
353     Summary: Package signing support
354     Group: System/Base
355    
356     %description sign
357     This package contains support for digitally signing RPM packages.
358    
359 tmb 343 %if %buildpython
360     %package -n python-rpm
361     Summary: Python bindings for apps which will manipulate RPM packages
362     Group: Development/Python
363     Requires: rpm = %epoch:%{version}-%{release}
364    
365     %description -n python-rpm
366     The rpm-python package contains a module which permits applications
367     written in the Python programming language to use the interface
368     supplied by RPM (RPM Package Manager) libraries.
369    
370     This package should be installed if you want to develop Python
371     programs that will manipulate RPM packages and databases.
372     %endif
373    
374     %prep
375     %setup -q -n %name-%srcver
376 dmorgan 186388 %apply_patches
377 tmb 343
378     %build
379 tv 447560 aclocal
380 tv 675399 automake --add-missing
381 tv 447560 automake
382 tmb 343 autoreconf
383    
384     %if %builddebug
385     RPM_OPT_FLAGS=-g
386     %endif
387 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
388 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
389 fwang 215771 %configure2_5x \
390 tmb 343 --enable-nls \
391     --enable-python \
392     --enable-sqlite3 \
393     --without-javaglue \
394     %if %builddebug
395     --enable-debug \
396     %endif
397 dmorgan 185007 --with-external-db \
398 tmb 343 %if %buildpython
399     --with-python=%{pyver} \
400     %else
401     --without-python \
402     %endif
403 dmorgan 185007 %if ! %buildplugins
404     --disable-plugins \
405     %endif
406 tmb 343 --with-glob \
407     --without-selinux \
408 dmorgan 185007 --without-apidocs \
409     --with-cap
410 tmb 343
411     %make
412    
413     %install
414     make DESTDIR=%buildroot install
415    
416 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
417    
418 tmb 343 # Save list of packages through cron
419     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
420     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
421    
422     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
423     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
424    
425     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
426     for dbi in \
427     Basenames Conflictname Dirnames Group Installtid Name Providename \
428     Provideversion Removetid Requirename Requireversion Triggername \
429 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
430     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
431 tmb 343 do
432     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
433     done
434    
435     test -d doc-copy || mkdir doc-copy
436     rm -rf doc-copy/*
437     ln -f doc/manual/* doc-copy/
438     rm -f doc-copy/Makefile*
439    
440     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
441    
442     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
443     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
444     # Put your own system macros here
445     # usually contains
446    
447     # Set this one according your locales
448     # %%_install_langs
449    
450     EOF
451    
452     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
453    
454 tv 206214 %check
455 tv 641033 eatmydata make check
456 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
457 tv 206214
458 tmb 343 %pre
459     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
460    
461     rm -rf /usr/lib/rpm/*-mandrake-*
462 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
463 tmb 343
464 tmb 345
465 tmb 343 %post
466     # nuke __db.00? when updating to this rpm
467     rm -f /var/lib/rpm/__db.00?
468    
469 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
470 tmb 343 /bin/rpm --initdb
471     fi
472    
473     %postun
474     /usr/share/rpm-helper/del-user rpm $1 rpm
475    
476     %define rpmattr %attr(0755, rpm, rpm)
477    
478     %files -f %{name}.lang
479     %doc GROUPS CHANGES doc/manual/[a-z]*
480     %attr(0755,rpm,rpm) /bin/rpm
481     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
482     %attr(0755, rpm, rpm) %{_bindir}/gendiff
483     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
484 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
485 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
486 colin 490405 %{_bindir}/rpmquery
487     %{_bindir}/rpmverify
488 tmb 343
489     %dir %{_localstatedir}/spool/repackage
490     %dir %{rpmdir}
491     %dir /etc/rpm
492     %config(noreplace) /etc/rpm/macros
493     %dir /etc/rpm/macros.d
494     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
495     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
496     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
497     %attr(0644, rpm, rpm) %{rpmdir}/macros
498     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
499     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
500     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
501     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
502 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
503     %attr(0755, rpm, rpm) %{rpmdir}/script.req
504 tv 256610 %exclude %{rpmdir}/tcl.req
505 tmb 343
506     %rpmattr %{rpmdir}/rpm2cpio.sh
507     %rpmattr %{rpmdir}/tgpg
508    
509 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
510     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
511    
512 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
513     %ifarch %{ix86} x86_64
514     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
515     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
516     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
517     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
518 rtp 267694 %else
519 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
520     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
521     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
522     %exclude %{rpmdir}/platform/geode-%{_os}/macros
523 tmb 343 %endif
524     %ifarch x86_64
525     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
526     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
527     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
528 rtp 267694 %else
529 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
530     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
531     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
532 tmb 343 %endif
533     %ifarch %arm
534 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
535 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
536 tv 256613 %else
537     %exclude %{rpmdir}/platform/arm*/macros
538 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
539 tmb 343 %endif
540     %ifarch %mips
541     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
542     %endif
543     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
544 tv 256613 # new in 4.10.0:
545 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
546     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
547     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
548 tv 672469 %exclude %{rpmdir}/platform/m68k*-%{_os}/macros
549 kamil 469312 %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
550     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
551     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
552 tmb 343
553 tv 256613
554    
555 tmb 343 %{_mandir}/man[18]/*.[18]*
556     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
557     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
558     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
559     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
560     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
561     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
562    
563     %config(noreplace,missingok) /etc/cron.daily/rpm
564     %config(noreplace,missingok) /etc/logrotate.d/rpm
565    
566     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
567    
568     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
569    
570     %rpmdbattr /var/lib/rpm/Basenames
571     %rpmdbattr /var/lib/rpm/Conflictname
572     %rpmdbattr /var/lib/rpm/__db.0*
573     %rpmdbattr /var/lib/rpm/Dirnames
574     %rpmdbattr /var/lib/rpm/Group
575     %rpmdbattr /var/lib/rpm/Installtid
576     %rpmdbattr /var/lib/rpm/Name
577 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
578 tmb 343 %rpmdbattr /var/lib/rpm/Packages
579     %rpmdbattr /var/lib/rpm/Providename
580     %rpmdbattr /var/lib/rpm/Provideversion
581     %rpmdbattr /var/lib/rpm/Removetid
582     %rpmdbattr /var/lib/rpm/Requirename
583     %rpmdbattr /var/lib/rpm/Requireversion
584 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
585     %rpmdbattr /var/lib/rpm/Sigmd5
586 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
587    
588     %files build
589     %doc CHANGES
590     %doc doc-copy/*
591     %rpmattr %{_bindir}/rpmbuild
592 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
593 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
594     %rpmattr %{_prefix}/lib/rpm/check-files
595     %rpmattr %{_prefix}/lib/rpm/debugedit
596 tv 672469 %rpmattr %{_prefix}/lib/rpm/*.prov
597 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
598     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
599     %rpmattr %{_prefix}/lib/rpm/find-provides
600     %rpmattr %{_prefix}/lib/rpm/find-requires
601     %rpmattr %{_prefix}/lib/rpm/perldeps.pl
602     %rpmattr %{_prefix}/lib/rpm/perl.req
603    
604     %rpmattr %{_prefix}/lib/rpm/check-buildroot
605     %rpmattr %{_prefix}/lib/rpm/check-prereqs
606     %rpmattr %{_prefix}/lib/rpm/check-rpaths
607     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
608     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
609     %rpmattr %{_prefix}/lib/rpm/macros.perl
610     %rpmattr %{_prefix}/lib/rpm/macros.php
611     %rpmattr %{_prefix}/lib/rpm/macros.python
612     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
613     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
614 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
615     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
616 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
617     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
618    
619     %rpmattr %{_prefix}/lib/rpm/rpmdeps
620 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
621 tmb 343
622 tv 255921
623 tmb 343 %{_mandir}/man8/rpmbuild.8*
624     %{_mandir}/man8/rpmdeps.8*
625    
626     %if %buildpython
627     %files -n python-rpm
628     %{_libdir}/python*/site-packages/rpm
629     %endif
630    
631     %files -n %librpmname
632 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
633     %{_libdir}/librpmio.so.%{libmajor}*
634 tv 669979 %if %buildplugins
635 dmorgan 185007 %{_libdir}/rpm-plugins
636     %endif
637    
638     %files -n %librpmbuild
639 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
640 tmb 343
641 dmorgan 185007 %files -n %librpmsign
642     %{_libdir}/librpmsign.so.%{libmajorsign}*
643    
644     %files sign
645     %{_bindir}/rpmsign
646     %{_mandir}/man8/rpmsign.8*
647    
648 tmb 343 %files -n %librpmnamedevel
649     %{_includedir}/rpm
650     %{_libdir}/librpm.so
651     %{_libdir}/librpmio.so
652     %{_libdir}/librpmbuild.so
653 dmorgan 185007 %{_libdir}/librpmsign.so
654 tmb 343 %{_libdir}/pkgconfig/rpm.pc
655 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30