/[packages]/updates/infra_2/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /updates/infra_2/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 675466 - (hide annotations) (download)
Sun Sep 14 18:52:54 2014 UTC (9 years, 7 months ago) by tv
File size: 21457 byte(s)
bump release (SILENT)
1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 591324 #define snapver rc2
56 tv 672411 %define rpmversion 4.11.3
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
62 tmb 345 %define librpmnamedevel %mklibname -d rpm
63 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
64     %define librpmbuild %mklibname rpmbuild %{libmajor}
65 tmb 343
66     %define buildpython 1
67     %define rpmsetup_version 1.34
68    
69     %define builddebug 0
70     %{?_with_debug:%define builddebug 1}
71    
72     %{?_with_python:%define buildpython 1}
73     %{?_without_python:%define buildpython 0}
74    
75 dmorgan 186381 # disable plugins initially
76 dmorgan 185007 %define buildplugins 0
77     %{?_with_plugins:%define buildplugins 1}
78    
79 tmb 343 Summary: The RPM package management system
80     Name: rpm
81     Epoch: 1
82 dmorgan 185007 Version: %{rpmversion}
83 tv 675466 Release: %mkrel %{?snapver:0.%{snapver}.}1.4
84 tv 675407 Group: System/Configuration/Packaging
85 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
86 dmorgan 185007 # Add some undocumented feature to gendiff
87     # Send upstream ? drop ?
88     Patch17: rpm-4.4.2.2-gendiff-improved.patch
89 tmb 343
90     # if %post of foo-2 fails,
91     # or if %preun of foo-1 fails,
92     # or if %postun of foo-1 fails,
93     # => foo-1 is not removed, so we end up with both packages in rpmdb
94     # this patch makes rpm ignore the error in those cases
95 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
96 tmb 343 #
97     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
98     # scripts is ignored with or without this patch)
99 tv 262316 # Needed for urpmi testsuite:
100 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
101 tmb 343
102 tv 668828 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm plugin in 4.12):
103 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
104 tmb 343
105 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
106     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
107 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
108     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
109 blino 25212
110 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
111     # From popular request, we allow to do this
112 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
113     Patch70: rpm-4.9.1-bb-shortcircuit.patch
114 tmb 343
115     # don't conflict for doc files
116     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
117 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
118 tmb 343
119     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
120     # (is this working??)
121     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
122    
123     # Fix diff issue when buildroot contains some "//"
124 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
125 tmb 343
126     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
127 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
128 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
129 tmb 343
130     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
131     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
132     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
133     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
134     # but this is bad design anyway
135 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
136 tmb 343
137 tv 672732 # [from 4.12.0] handle "Suggests" via RPMTAG_SUGGESTNAME
138     Patch132: newweakdeps.diff
139     Patch133: exportoldtags.patch
140     Patch134: weakdepscompat.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 tv 550966 Patch146: rpm-4.11.1-filetriggers.patch
157 colin 657571 Patch147: rpm-4.11.1-filetriggers-priority.patch
158     Patch148: rpm-4.11.1-filetriggers-warnings.patch
159 tmb 343
160     # (nb: see the patch for more info about this issue)
161 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
162 tmb 343
163 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
164 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
165 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
166 tmb 343
167     Patch1007: rpm-4.6.0-rc3-xz-support.patch
168    
169     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
170     # as this breaks stuff that installs files to $DOCDIR during %%install
171 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
172 tmb 343
173     # Turbolinux patches
174     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
175     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
176    
177 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
178 dmorgan 49378
179 tv 262316 # (tv) fix tests:
180 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
181 tv 255921
182 tmb 343 Patch3000: mips_macros.patch
183 tv 256616 Patch3002: mips_define_isa_macros.patch
184     Patch3003: rpm_arm_mips_isa_macros.patch
185     Patch3004: rpm_add_armv5tl.patch
186 tmb 343
187 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
188     # and not full path
189 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
190 tv 223198 #
191 dmorgan 185007 # Fedora patches
192 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
193     #
194 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
195     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
196 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
197 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
198 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
199 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
200 dmorgan 185007
201 tv 669980 # Mageia patches that are easier to rediff on top of FC patches:
202     #---------------------------------------------------------------
203 tv 276795 # (tv) merge mga stuff from rpm-setup:
204     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
205 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
206     # extraction of debuginfo can fail. This happens if you have a shared build dir
207     # which contains lots of subfolders for different packages (i.e. the default
208     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
209     # This fix simply uses the real build dir passed in as an argument to the script
210     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
211 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
212     # I suspect the real problem lies in the debugedit binary which I will debug further.
213     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
214     # still here after any reasonable length of time!)
215     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
216 lmenut 502275 # (lm) Don't uselessly bytecompile .py in docdir
217     Patch4008: rpm-4.11.1-dont-bytecompile-python-in-docdir.patch
218 tv 327195
219 dmorgan 621327 Patch4009: rpm-4.11.2-double-separator-warning.patch
220 tv 672732 # (tv) make old suggests be equivalent to recommends:
221     Patch4010: rpm-4.12.0-oldsuggest_equals_recommends.patch
222 tv 674935 Patch4012: rpm-mga-suggests.diff
223 dmorgan 621327
224 dmorgan 185007 License: GPLv2+
225     BuildRequires: autoconf
226 tmb 343 BuildRequires: zlib-devel
227     BuildRequires: bzip2-devel
228 tv 675399 BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
229 dmorgan 185007 BuildRequires: automake
230 tmb 343 BuildRequires: elfutils-devel
231     BuildRequires: libbeecrypt-devel
232 dmorgan 185007 BuildRequires: ed
233     BuildRequires: gettext-devel
234 tmb 343 BuildRequires: libsqlite3-devel
235 tv 675399 BuildRequires: db4.8-devel
236 tmb 343 BuildRequires: neon-devel
237     BuildRequires: popt-devel
238     BuildRequires: nss-devel
239     BuildRequires: magic-devel
240 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
241 tmb 343 BuildRequires: readline-devel
242     BuildRequires: ncurses-devel
243 dmorgan 185007 BuildRequires: openssl-devel
244 tv 675399 BuildRequires: lua-devel
245 dmorgan 185007 BuildRequires: libcap-devel
246     # Needed for doc
247 tmb 343 #BuildRequires: graphviz
248 dmorgan 185007 BuildRequires: tetex
249 tmb 343 %if %buildpython
250     BuildRequires: python-devel
251     %endif
252 tv 223263 # for testsuite:
253 tv 641033 BuildRequires: eatmydata
254 tv 674498 BuildRequires: fakechroot
255 tmb 343
256     Requires: bzip2 >= 0.9.0c-2
257 tv 675399 Requires: lzma
258 tmb 343 Requires: cpio
259     Requires: gawk
260     Requires: mktemp
261 tmb 345 Requires: setup >= 2.2.0-8
262 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
263 tmb 343 Requires: update-alternatives
264     Requires: %librpmname = %epoch:%version-%release
265     URL: http://rpm.org/
266     %define git_url http://rpm.org/git/rpm.git
267 dmorgan 185007 Requires(pre): rpm-helper
268 tmb 343 Requires(pre): coreutils
269 dmorgan 185007 Requires(postun): rpm-helper
270 tmb 343
271 tv 675431 Conflicts: perl-URPM < 3.38.4-1.1.mga2
272 dmorgan 185007
273 tmb 343 %description
274     RPM is a powerful command line driven package management system capable of
275     installing, uninstalling, verifying, querying, and updating software packages.
276     Each software package consists of an archive of files along with information
277     about the package like its version, a description, etc.
278    
279 dmorgan 185191 %package -n %librpmbuild
280     Summary: Libraries for building and signing RPM packages
281     Group: System/Libraries
282 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
283 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
284    
285     %description -n %librpmbuild
286     This package contains the RPM shared libraries for building and signing
287     packages.
288    
289     %package -n %librpmsign
290     Summary: Libraries for building and signing RPM packages
291     Group: System/Libraries
292    
293     %description -n %librpmsign
294     This package contains the RPM shared libraries for building and signing
295     packages.
296    
297 tmb 343 %package -n %librpmname
298 tmb 345 Summary: Library used by rpm
299     Group: System/Libraries
300     Provides: librpm = %version-%release
301 tmb 343
302     %description -n %librpmname
303     RPM is a powerful command line driven package management system capable of
304     installing, uninstalling, verifying, querying, and updating software packages.
305     This package contains common files to all applications based on rpm.
306    
307     %package -n %librpmnamedevel
308     Summary: Development files for applications which will manipulate RPM packages
309     Group: Development/C
310     Requires: rpm = %epoch:%{version}-%{release}
311     Provides: librpm-devel = %version-%release
312     Provides: rpm-devel = %version-%release
313 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
314     Requires: %librpmbuild = %epoch:%version-%release
315     Requires: %librpmsign = %epoch:%version-%release
316 tmb 343
317     %description -n %librpmnamedevel
318     This package contains the RPM C library and header files. These
319     development files will simplify the process of writing programs
320     which manipulate RPM packages and databases and are intended to make
321     it easier to create graphical package managers or any other tools
322     that need an intimate knowledge of RPM packages in order to function.
323    
324     This package should be installed if you want to develop programs that
325     will manipulate RPM packages and databases.
326    
327     %package build
328     Summary: Scripts and executable programs used to build packages
329 tv 675407 Group: System/Configuration/Packaging
330 tmb 343 Requires: autoconf
331     Requires: automake
332     Requires: file
333     Requires: gcc-c++
334     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
335 dmorgan 185007 Requires: libtool-base
336     Requires: patch
337 tmb 343 Requires: make
338     Requires: tar
339     Requires: unzip
340     Requires: elfutils
341 tv 675460 #Requires: perl(CPAN::Meta) >= 2.112.150
342     #Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
343     #Requires: perl(YAML::Tiny)
344 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
345 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
346 tmb 343
347     %description build
348     This package contains scripts and executable programs that are used to
349     build packages using RPM.
350    
351 dmorgan 185007 %package sign
352     Summary: Package signing support
353     Group: System/Base
354    
355     %description sign
356     This package contains support for digitally signing RPM packages.
357    
358 tmb 343 %if %buildpython
359     %package -n python-rpm
360     Summary: Python bindings for apps which will manipulate RPM packages
361     Group: Development/Python
362     Requires: rpm = %epoch:%{version}-%{release}
363    
364     %description -n python-rpm
365     The rpm-python package contains a module which permits applications
366     written in the Python programming language to use the interface
367     supplied by RPM (RPM Package Manager) libraries.
368    
369     This package should be installed if you want to develop Python
370     programs that will manipulate RPM packages and databases.
371     %endif
372    
373     %prep
374     %setup -q -n %name-%srcver
375 dmorgan 186388 %apply_patches
376 tmb 343
377     %build
378 tv 447560 aclocal
379 tv 675399 automake --add-missing
380 tv 447560 automake
381 tmb 343 autoreconf
382    
383     %if %builddebug
384     RPM_OPT_FLAGS=-g
385     %endif
386 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
387 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
388 fwang 215771 %configure2_5x \
389 tmb 343 --enable-nls \
390     --enable-python \
391     --enable-sqlite3 \
392     --without-javaglue \
393     %if %builddebug
394     --enable-debug \
395     %endif
396 dmorgan 185007 --with-external-db \
397 tmb 343 %if %buildpython
398     --with-python=%{pyver} \
399     %else
400     --without-python \
401     %endif
402 dmorgan 185007 %if ! %buildplugins
403     --disable-plugins \
404     %endif
405 tmb 343 --with-glob \
406     --without-selinux \
407 dmorgan 185007 --without-apidocs \
408     --with-cap
409 tmb 343
410     %make
411    
412     %install
413     make DESTDIR=%buildroot install
414    
415 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
416    
417 tmb 343 # Save list of packages through cron
418     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
419     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
420    
421     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
422     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
423    
424     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
425     for dbi in \
426     Basenames Conflictname Dirnames Group Installtid Name Providename \
427     Provideversion Removetid Requirename Requireversion Triggername \
428 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
429     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
430 tmb 343 do
431     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
432     done
433    
434     test -d doc-copy || mkdir doc-copy
435     rm -rf doc-copy/*
436     ln -f doc/manual/* doc-copy/
437     rm -f doc-copy/Makefile*
438    
439     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
440    
441     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
442     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
443     # Put your own system macros here
444     # usually contains
445    
446     # Set this one according your locales
447     # %%_install_langs
448    
449     EOF
450    
451     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
452    
453 tv 206214 %check
454 tv 641033 eatmydata make check
455 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
456 tv 206214
457 tmb 343 %pre
458     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
459    
460     rm -rf /usr/lib/rpm/*-mandrake-*
461 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
462 tmb 343
463 tmb 345
464 tmb 343 %post
465     # nuke __db.00? when updating to this rpm
466     rm -f /var/lib/rpm/__db.00?
467    
468 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
469 tmb 343 /bin/rpm --initdb
470     fi
471    
472     %postun
473     /usr/share/rpm-helper/del-user rpm $1 rpm
474    
475     %define rpmattr %attr(0755, rpm, rpm)
476    
477     %files -f %{name}.lang
478     %doc GROUPS CHANGES doc/manual/[a-z]*
479     %attr(0755,rpm,rpm) /bin/rpm
480     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
481     %attr(0755, rpm, rpm) %{_bindir}/gendiff
482     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
483 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
484 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
485 colin 490405 %{_bindir}/rpmquery
486     %{_bindir}/rpmverify
487 tmb 343
488     %dir %{_localstatedir}/spool/repackage
489     %dir %{rpmdir}
490     %dir /etc/rpm
491     %config(noreplace) /etc/rpm/macros
492     %dir /etc/rpm/macros.d
493     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
494     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
495     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
496     %attr(0644, rpm, rpm) %{rpmdir}/macros
497     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
498     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
499     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
500     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
501 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
502     %attr(0755, rpm, rpm) %{rpmdir}/script.req
503 tv 256610 %exclude %{rpmdir}/tcl.req
504 tmb 343
505     %rpmattr %{rpmdir}/rpm2cpio.sh
506     %rpmattr %{rpmdir}/tgpg
507    
508 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
509     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
510    
511 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
512     %ifarch %{ix86} x86_64
513     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
514     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
515     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
516     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
517 rtp 267694 %else
518 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
519     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
520     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
521     %exclude %{rpmdir}/platform/geode-%{_os}/macros
522 tmb 343 %endif
523     %ifarch x86_64
524     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
525     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
526     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
527 rtp 267694 %else
528 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
529     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
530     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
531 tmb 343 %endif
532     %ifarch %arm
533 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
534 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
535 tv 256613 %else
536     %exclude %{rpmdir}/platform/arm*/macros
537 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
538 tmb 343 %endif
539     %ifarch %mips
540     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
541     %endif
542     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
543 tv 256613 # new in 4.10.0:
544 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
545     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
546     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
547 tv 672469 %exclude %{rpmdir}/platform/m68k*-%{_os}/macros
548 kamil 469312 %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
549     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
550     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
551 tmb 343
552 tv 256613
553    
554 tmb 343 %{_mandir}/man[18]/*.[18]*
555     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
556     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
557     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
558     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
559     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
560     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
561    
562     %config(noreplace,missingok) /etc/cron.daily/rpm
563     %config(noreplace,missingok) /etc/logrotate.d/rpm
564    
565     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
566    
567     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
568    
569     %rpmdbattr /var/lib/rpm/Basenames
570     %rpmdbattr /var/lib/rpm/Conflictname
571     %rpmdbattr /var/lib/rpm/__db.0*
572     %rpmdbattr /var/lib/rpm/Dirnames
573     %rpmdbattr /var/lib/rpm/Group
574     %rpmdbattr /var/lib/rpm/Installtid
575     %rpmdbattr /var/lib/rpm/Name
576 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
577 tmb 343 %rpmdbattr /var/lib/rpm/Packages
578     %rpmdbattr /var/lib/rpm/Providename
579     %rpmdbattr /var/lib/rpm/Provideversion
580     %rpmdbattr /var/lib/rpm/Removetid
581     %rpmdbattr /var/lib/rpm/Requirename
582     %rpmdbattr /var/lib/rpm/Requireversion
583 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
584     %rpmdbattr /var/lib/rpm/Sigmd5
585 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
586    
587     %files build
588     %doc CHANGES
589     %doc doc-copy/*
590     %rpmattr %{_bindir}/rpmbuild
591 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
592 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
593     %rpmattr %{_prefix}/lib/rpm/check-files
594     %rpmattr %{_prefix}/lib/rpm/debugedit
595 tv 672469 %rpmattr %{_prefix}/lib/rpm/*.prov
596 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
597     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
598     %rpmattr %{_prefix}/lib/rpm/find-provides
599     %rpmattr %{_prefix}/lib/rpm/find-requires
600     %rpmattr %{_prefix}/lib/rpm/perldeps.pl
601     %rpmattr %{_prefix}/lib/rpm/perl.req
602    
603     %rpmattr %{_prefix}/lib/rpm/check-buildroot
604     %rpmattr %{_prefix}/lib/rpm/check-prereqs
605     %rpmattr %{_prefix}/lib/rpm/check-rpaths
606     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
607     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
608     %rpmattr %{_prefix}/lib/rpm/macros.perl
609     %rpmattr %{_prefix}/lib/rpm/macros.php
610     %rpmattr %{_prefix}/lib/rpm/macros.python
611     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
612     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
613 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
614     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
615 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
616     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
617    
618     %rpmattr %{_prefix}/lib/rpm/rpmdeps
619 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
620 tmb 343
621 tv 255921
622 tmb 343 %{_mandir}/man8/rpmbuild.8*
623     %{_mandir}/man8/rpmdeps.8*
624    
625     %if %buildpython
626     %files -n python-rpm
627     %{_libdir}/python*/site-packages/rpm
628     %endif
629    
630     %files -n %librpmname
631 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
632     %{_libdir}/librpmio.so.%{libmajor}*
633 tv 669979 %if %buildplugins
634 dmorgan 185007 %{_libdir}/rpm-plugins
635     %endif
636    
637     %files -n %librpmbuild
638 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
639 tmb 343
640 dmorgan 185007 %files -n %librpmsign
641     %{_libdir}/librpmsign.so.%{libmajorsign}*
642    
643     %files sign
644     %{_bindir}/rpmsign
645     %{_mandir}/man8/rpmsign.8*
646    
647 tmb 343 %files -n %librpmnamedevel
648     %{_includedir}/rpm
649     %{_libdir}/librpm.so
650     %{_libdir}/librpmio.so
651     %{_libdir}/librpmbuild.so
652 dmorgan 185007 %{_libdir}/librpmsign.so
653 tmb 343 %{_libdir}/pkgconfig/rpm.pc
654 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30